1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-15 13:22:50 +03:00

upgrade orion to 2.6.26-rc5

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11436 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
kaloz 2008-06-11 11:59:45 +00:00
parent c4019d34c1
commit 1aeb183751
4 changed files with 14 additions and 14 deletions

View File

@ -599,7 +599,7 @@
select CRC32
--- a/drivers/net/Makefile
+++ b/drivers/net/Makefile
@@ -143,6 +143,7 @@
@@ -142,6 +142,7 @@
obj-$(CONFIG_XEN_NETDEV_FRONTEND) += xen-netfront.o
obj-$(CONFIG_DUMMY) += dummy.o
@ -643,7 +643,7 @@
+#endif /* _IP6T_IMQ_H */
--- a/include/linux/skbuff.h
+++ b/include/linux/skbuff.h
@@ -296,6 +296,10 @@
@@ -300,6 +300,10 @@
struct nf_conntrack *nfct;
struct sk_buff *nfct_reasm;
#endif
@ -654,7 +654,7 @@
#ifdef CONFIG_BRIDGE_NETFILTER
struct nf_bridge_info *nf_bridge;
#endif
@@ -1736,6 +1740,10 @@
@@ -1633,6 +1637,10 @@
dst->nfct_reasm = src->nfct_reasm;
nf_conntrack_get_reasm(src->nfct_reasm);
#endif
@ -677,7 +677,7 @@
#include <linux/proc_fs.h>
#include <linux/seq_file.h>
#include <linux/stat.h>
@@ -1537,7 +1540,11 @@
@@ -1545,7 +1548,11 @@
int dev_hard_start_xmit(struct sk_buff *skb, struct net_device *dev)
{
if (likely(!skb->next)) {
@ -784,7 +784,7 @@
depends on IP_NF_FILTER
--- a/net/ipv4/netfilter/Makefile
+++ b/net/ipv4/netfilter/Makefile
@@ -55,6 +55,7 @@
@@ -58,6 +58,7 @@
obj-$(CONFIG_IP_NF_TARGET_CLUSTERIP) += ipt_CLUSTERIP.o
obj-$(CONFIG_IP_NF_TARGET_ECN) += ipt_ECN.o
obj-$(CONFIG_IP_NF_TARGET_LOG) += ipt_LOG.o

View File

@ -1,6 +1,6 @@
--- a/fs/yaffs2/yaffs_fs.c
+++ b/fs/yaffs2/yaffs_fs.c
@@ -183,7 +183,13 @@
@@ -181,7 +181,13 @@
#else
static int yaffs_statfs(struct super_block *sb, struct statfs *buf);
#endif
@ -14,7 +14,7 @@
static void yaffs_put_inode(struct inode *inode);
static void yaffs_delete_inode(struct inode *);
@@ -286,7 +292,9 @@
@@ -284,7 +290,9 @@
static struct super_operations yaffs_super_ops = {
.statfs = yaffs_statfs,
@ -24,7 +24,7 @@
.put_inode = yaffs_put_inode,
.put_super = yaffs_put_super,
.delete_inode = yaffs_delete_inode,
@@ -848,11 +856,17 @@
@@ -844,11 +852,17 @@
T(YAFFS_TRACE_OS,
(KERN_DEBUG "yaffs_get_inode for object %d\n", obj->objectId));
@ -42,7 +42,7 @@
return inode;
}
@@ -1453,6 +1467,39 @@
@@ -1427,6 +1441,39 @@
}
@ -82,7 +82,7 @@
static void yaffs_read_inode(struct inode *inode)
{
/* NB This is called as a side effect of other functions, but
@@ -1474,6 +1521,7 @@
@@ -1448,6 +1495,7 @@
yaffs_GrossUnlock(dev);
}

View File

@ -11,7 +11,7 @@ BOARD:=orion
BOARDNAME:=Marvell Orion
FEATURES:=squashfs
LINUX_VERSION:=2.6.26-rc4
LINUX_VERSION:=2.6.26-rc5
include $(INCLUDE_DIR)/target.mk

View File

@ -44,8 +44,8 @@ CONFIG_ARCH_SUSPEND_POSSIBLE=y
# CONFIG_ARCH_VERSATILE is not set
CONFIG_ARM=y
# CONFIG_ARM_THUMB is not set
# CONFIG_ARTHUR is not set
# CONFIG_ARPD is not set
# CONFIG_ARTHUR is not set
CONFIG_ATA=m
# CONFIG_ATA_NONSTANDARD is not set
# CONFIG_ATA_PIIX is not set
@ -97,11 +97,10 @@ CONFIG_DLCI_MAX=8
CONFIG_DNOTIFY=y
# CONFIG_DSCC4 is not set
# CONFIG_E100 is not set
# CONFIG_E1000 is not set
# CONFIG_E1000E_ENABLED is not set
# CONFIG_FARSYNC is not set
# CONFIG_FPE_NWFPE is not set
# CONFIG_FPE_FASTFPE is not set
# CONFIG_FPE_NWFPE is not set
CONFIG_FRAME_POINTER=y
CONFIG_FRAME_WARN=1024
CONFIG_FS_POSIX_ACL=y
@ -342,6 +341,7 @@ CONFIG_USB=m
# CONFIG_USB_C67X00_HCD is not set
# CONFIG_USB_CATC is not set
CONFIG_USB_EHCI_HCD=m
# CONFIG_USB_ISIGHTFW is not set
# CONFIG_USB_ISP1760_HCD is not set
# CONFIG_USB_KAWETH is not set
# CONFIG_USB_OHCI_BIG_ENDIAN_DESC is not set