mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-24 01:01:52 +02:00
[package] libnl: update linux/genetlink.h for iw package (thanks to Hauke Mehrtens <hauke@hauke-m.de>)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14234 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
d3ca1bb1e5
commit
1c32b56b31
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2006-2008 OpenWrt.org
|
||||
# Copyright (C) 2006-2009 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libnl
|
||||
PKG_VERSION:=1.1
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=4
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://people.suug.ch/~tgr/libnl/files/
|
||||
|
34
package/libnl/patches/160-update_includes_for_iw.patch
Normal file
34
package/libnl/patches/160-update_includes_for_iw.patch
Normal file
@ -0,0 +1,34 @@
|
||||
--- a/include/linux/genetlink.h
|
||||
+++ b/include/linux/genetlink.h
|
||||
@@ -39,6 +39,9 @@ enum {
|
||||
CTRL_CMD_NEWOPS,
|
||||
CTRL_CMD_DELOPS,
|
||||
CTRL_CMD_GETOPS,
|
||||
+ CTRL_CMD_NEWMCAST_GRP,
|
||||
+ CTRL_CMD_DELMCAST_GRP,
|
||||
+ CTRL_CMD_GETMCAST_GRP, /* unused */
|
||||
__CTRL_CMD_MAX,
|
||||
};
|
||||
|
||||
@@ -52,6 +55,7 @@ enum {
|
||||
CTRL_ATTR_HDRSIZE,
|
||||
CTRL_ATTR_MAXATTR,
|
||||
CTRL_ATTR_OPS,
|
||||
+ CTRL_ATTR_MCAST_GROUPS,
|
||||
__CTRL_ATTR_MAX,
|
||||
};
|
||||
|
||||
@@ -66,4 +70,13 @@ enum {
|
||||
|
||||
#define CTRL_ATTR_OP_MAX (__CTRL_ATTR_OP_MAX - 1)
|
||||
|
||||
+enum {
|
||||
+ CTRL_ATTR_MCAST_GRP_UNSPEC,
|
||||
+ CTRL_ATTR_MCAST_GRP_NAME,
|
||||
+ CTRL_ATTR_MCAST_GRP_ID,
|
||||
+ __CTRL_ATTR_MCAST_GRP_MAX,
|
||||
+};
|
||||
+
|
||||
+#define CTRL_ATTR_MCAST_GRP_MAX (__CTRL_ATTR_MCAST_GRP_MAX - 1)
|
||||
+
|
||||
#endif /* __LINUX_GENERIC_NETLINK_H */
|
Loading…
Reference in New Issue
Block a user