mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-29 14:22:54 +02:00
Added vrrpd package, fixed typo in vgp Config.in and added them to the package list in menuconfig
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2644 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
e47a7f0c69
commit
1cc1ad595a
@ -129,6 +129,8 @@ source "package/tor/Config.in"
|
||||
source "package/ttcp/Config.in"
|
||||
source "package/ulogd/Config.in"
|
||||
source "package/updatedd/Config.in"
|
||||
source "package/vgp/Config.in"
|
||||
source "package/vrrpd/Config.in"
|
||||
source "package/vsftpd/Config.in"
|
||||
source "package/vtun/Config.in"
|
||||
source "package/wificonf/Config.in"
|
||||
|
@ -205,6 +205,8 @@ package-$(BR2_COMPILE_USBUTILS) += usbutils
|
||||
package-$(BR2_PACKAGE_USTL) += ustl
|
||||
package-$(BR2_COMPILE_UTIL_LINUX) += util-linux
|
||||
package-$(BR2_PACKAGE_UDEV) += udev
|
||||
package-$(BR2_PACKAGE_VGP) += vgp
|
||||
package-$(BR2_PACKGE_VRRPD) += vrrpd
|
||||
package-$(BR2_PACKAGE_VTUN) += vtun
|
||||
package-$(BR2_PACKAGE_VSFTPD) += vsftpd
|
||||
package-$(BR2_PACKAGE_WIFICONF) += wificonf
|
||||
|
@ -1,11 +1,7 @@
|
||||
config BR2_PACKAGE_VGP
|
||||
tristate "vgp - a daemon working like Cisco(c) HSRP"
|
||||
tristate "vgp............................... a daemon working like Cisco(c) HSRP"
|
||||
default m if CONFIG_DEVEL
|
||||
help
|
||||
VGP (Virtual Gateway Protocol)is a very simple protocol able to work in
|
||||
a way similar to Cisco(c) HSRP. It implements the idea of Virtual Gateway
|
||||
to provide fault tollerance (and load balancing) on your net.
|
||||
Each client on your net has as its default gateway the virtual gateway
|
||||
and not the real router.
|
||||
|
||||
http://vgpd.freaknet.org/
|
||||
a way similar to Cisco(c) HSRP. It implements the idea of Virtual Gateway to provide fault tollerance (and load balancing) on your net. Each client on your net has as its default gateway the virtual gateway and not the real router.
|
||||
http://vgpd.freaknet.org/
|
||||
|
8
openwrt/package/vrrpd/Config.in
Executable file
8
openwrt/package/vrrpd/Config.in
Executable file
@ -0,0 +1,8 @@
|
||||
config BR2_PACKAGE_VRRPD
|
||||
tristate "vrrpd............................. Virtual Router Redundancy Protocol daemon"
|
||||
default m if CONFIG_DEVEL
|
||||
help
|
||||
VRRPd is an implementation of Virtual Router Redundancy Protocol as specified in rfc2338.
|
||||
VRRPd is interoperable with other RFC-based VRRP implementations, including Cisco and Juniper, and is included as a standard feature on ImageStream routers.
|
||||
|
||||
http://www.sourceforge.net/projects/vrrpd
|
33
openwrt/package/vrrpd/Makefile
Executable file
33
openwrt/package/vrrpd/Makefile
Executable file
@ -0,0 +1,33 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=vrrpd
|
||||
PKG_VERSION:=1.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_MD5SUM:=6d5066ea1a6ced817376ca0f54765447
|
||||
PKG_SOURCE_URL:=@SF/vrrpd
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(TOPDIR)/package/rules.mk
|
||||
|
||||
$(eval $(call PKG_template,VRRPD,VRRPD,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||
|
||||
$(PKG_BUILD_DIR)/.configured:
|
||||
touch $@
|
||||
|
||||
$(PKG_BUILD_DIR)/.built:
|
||||
mkdir -p $(PKG_INSTALL_DIR)/usr/sbin
|
||||
$(MAKE) CC=$(TARGET_CC) -C $(PKG_BUILD_DIR)
|
||||
install -m0755 $(PKG_BUILD_DIR)/vrrpd $(PKG_INSTALL_DIR)/usr/sbin/
|
||||
touch $@
|
||||
|
||||
$(IPKG_VRRPD):
|
||||
mkdir -p $(IDIR_VRRPD)
|
||||
cp -fpR $(PKG_INSTALL_DIR)/* $(IDIR_VRRPD)/
|
||||
$(RSTRIP) $(IDIR_VRRPD)
|
||||
$(IPKG_BUILD) $(IDIR_VRRPD) $(PACKAGE_DIR)
|
5
openwrt/package/vrrpd/ipkg/vrrpd.control
Executable file
5
openwrt/package/vrrpd/ipkg/vrrpd.control
Executable file
@ -0,0 +1,5 @@
|
||||
Package: vrrpd
|
||||
Section: net
|
||||
Architecture: mipsel
|
||||
Priority: optional
|
||||
Description: VRRPd is an implementation of Virtual Router Redundancy Protocol as specified in rfc2338.
|
11
openwrt/package/vrrpd/patches/01-honor-target_cc.patch
Normal file
11
openwrt/package/vrrpd/patches/01-honor-target_cc.patch
Normal file
@ -0,0 +1,11 @@
|
||||
diff -urN orig/vrrpd-1.0/Makefile vrrpd-1.0/Makefile
|
||||
--- orig/vrrpd-1.0/Makefile 2002-09-09 16:51:13.000000000 +0200
|
||||
+++ vrrpd-1.0/Makefile 2005-12-12 23:31:30.000000000 +0100
|
||||
@@ -15,7 +15,6 @@
|
||||
COMMON_CFLAGS= $(MAIN_OPT) $(INCLUDEOPT) $(PROF_OPT) $(DBG_OPT) $(MACHINEOPT)
|
||||
|
||||
# set to compile with GCC
|
||||
-CC=gcc
|
||||
CFLAGS= $(COMMON_CFLAGS) -Wall
|
||||
|
||||
vrrpd : $(VRRPD_OBJS)
|
Loading…
Reference in New Issue
Block a user