1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2025-02-17 15:04:42 +02:00

kernel: use -fno-caller-saves

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26301 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nbd 2011-03-26 01:07:16 +00:00
parent d46648401a
commit 1e0188b074
2 changed files with 13 additions and 7 deletions

View File

@ -1,15 +1,18 @@
--- a/Makefile
+++ b/Makefile
@@ -540,7 +540,7 @@ all: vmlinux
@@ -538,9 +538,9 @@
all: vmlinux
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
KBUILD_CFLAGS += -Os
-KBUILD_CFLAGS += -Os
+KBUILD_CFLAGS += -Os -fno-caller-saves
else
-KBUILD_CFLAGS += -O2
+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch
+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch -fno-caller-saves
endif
include $(srctree)/arch/$(SRCARCH)/Makefile
@@ -595,6 +595,9 @@ endif
@@ -595,6 +595,9 @@
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
CHECKFLAGS += $(NOSTDINC_FLAGS)

View File

@ -1,11 +1,14 @@
--- a/Makefile
+++ b/Makefile
@@ -541,7 +541,7 @@ all: vmlinux
@@ -539,9 +539,9 @@ endif # $(dot-config)
all: vmlinux
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
KBUILD_CFLAGS += -Os
-KBUILD_CFLAGS += -Os
+KBUILD_CFLAGS += -Os -fno-caller-saves
else
-KBUILD_CFLAGS += -O2
+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch
+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch -fno-caller-saves
endif
include $(srctree)/arch/$(SRCARCH)/Makefile