1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-10-06 16:50:22 +03:00

[adm5120] rename NAND driver

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8932 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
juhosg 2007-09-21 19:00:45 +00:00
parent 7472625106
commit 202118260a
3 changed files with 11 additions and 7 deletions

View File

@ -2,15 +2,19 @@ Index: linux-2.6.22.1/drivers/mtd/nand/Kconfig
===================================================================
--- linux-2.6.22.1.orig/drivers/mtd/nand/Kconfig
+++ linux-2.6.22.1/drivers/mtd/nand/Kconfig
@@ -81,6 +81,12 @@ config MTD_NAND_TS7250
@@ -81,6 +81,16 @@ config MTD_NAND_TS7250
help
Support for NAND flash on Technologic Systems TS-7250 platform.
+config MTD_NAND_RB100
+ tristate "NAND Flash device on RB100 board"
+ depends on MTD_NAND
+config MTD_NAND_ADM5120
+ tristate "ADM5120 NAND support"
+ depends on MTD_NAND && MIPS_ADM5120
+ help
+ Support for NAND flash on RB100 platform.
+ This enables the driver for the ADM5120 SoC built-in
+ NAND flash interface.
+
+ No board specific support is done by this driver, each board
+ must advertise a platform_device for the driver to attach.
+
config MTD_NAND_IDS
tristate
@ -23,7 +27,7 @@ Index: linux-2.6.22.1/drivers/mtd/nand/Makefile
obj-$(CONFIG_MTD_NAND_SPIA) += spia.o
obj-$(CONFIG_MTD_NAND_AMS_DELTA) += ams-delta.o
obj-$(CONFIG_MTD_NAND_TOTO) += toto.o
+obj-$(CONFIG_MTD_NAND_RB100) += rbmipsnand.o
+obj-$(CONFIG_MTD_NAND_ADM5120) += adm5120-nand.o
obj-$(CONFIG_MTD_NAND_AUTCPU12) += autcpu12.o
obj-$(CONFIG_MTD_NAND_EDB7312) += edb7312.o
obj-$(CONFIG_MTD_NAND_AU1550) += au1550nd.o

View File

@ -163,7 +163,7 @@ CONFIG_MTD_NAND_IDS=y
# CONFIG_MTD_NAND_MUSEUM_IDS is not set
# CONFIG_MTD_NAND_NANDSIM is not set
# CONFIG_MTD_NAND_PLATFORM is not set
CONFIG_MTD_NAND_RB100=y
CONFIG_MTD_NAND_ADM5120=y
# CONFIG_MTD_NAND_VERIFY_WRITE is not set
# CONFIG_MTD_ONENAND is not set
CONFIG_MTD_PARTITIONS=y