1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-04 22:17:20 +03:00

opkg: apparently array bounds checking is gcc 4.3 specific, move -Wno-array-bounds into TARGET_CFLAGS instead of a patch and make it conditional

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14508 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nbd 2009-02-14 14:11:12 +00:00
parent d927107601
commit 260c8f7eb6
2 changed files with 1 additions and 11 deletions

View File

@ -40,7 +40,7 @@ define Package/opkg/conffiles
/etc/opkg.conf
endef
TARGET_CFLAGS += $(FPIC)
TARGET_CFLAGS += $(FPIC) $(if $(CONFIG_GCC_VERSION_4_3),-Wno-array-bounds)
EXTRA_CFLAGS+=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/lib
EXTRA_LDFLAGS+=-L$(STAGING_DIR)/usr/lib -Wl,-rpath-link,$(STAGING_DIR)/usr/lib

View File

@ -1,10 +0,0 @@
--- a/libopkg/Makefile.am
+++ b/libopkg/Makefile.am
@@ -1,6 +1,6 @@
HOST_CPU=@host_cpu@
-AM_CFLAGS=-Wall -Werror -DHOST_CPU_STR=\"$(HOST_CPU)\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS)
+AM_CFLAGS=-Wall -Werror -Wno-array-bounds -DHOST_CPU_STR=\"$(HOST_CPU)\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS)
libopkg_includedir=$(includedir)/libopkg
libopkg_include_HEADERS= opkg.h