mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-24 00:30:16 +02:00
[kernel] update to 2.6.35.11
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25582 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
ea7e9693a2
commit
31ed958204
@ -14,8 +14,8 @@ endif
|
||||
ifeq ($(LINUX_VERSION),2.6.34.7)
|
||||
LINUX_KERNEL_MD5SUM:=8964e26120e84844998a673464a980ea
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),2.6.35.9)
|
||||
LINUX_KERNEL_MD5SUM:=18d339e9229560e73c4249dffdc3fd90
|
||||
ifeq ($(LINUX_VERSION),2.6.35.11)
|
||||
LINUX_KERNEL_MD5SUM:=4c9ee33801f5ad0f4d5e615fac66d535
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),2.6.36.4)
|
||||
LINUX_KERNEL_MD5SUM:=c05dd941d0e249695e9f72568888e1bf
|
||||
|
@ -14,7 +14,7 @@ FEATURES:=squashfs jffs2 targz
|
||||
CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time
|
||||
SUBTARGETS:=netus tqma9263
|
||||
|
||||
LINUX_VERSION:=2.6.35.9
|
||||
LINUX_VERSION:=2.6.35.11
|
||||
DEVICE_TYPE=
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
@ -12,7 +12,7 @@ BOARDNAME:=RMI/AMD AU1x00
|
||||
FEATURES:=jffs2 usb pci
|
||||
SUBTARGETS=au1500 au1550
|
||||
|
||||
LINUX_VERSION:=2.6.35.9
|
||||
LINUX_VERSION:=2.6.35.11
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES += wpad-mini yamonenv
|
||||
|
@ -10,7 +10,7 @@ ARCH:=mips
|
||||
BOARD:=brcm63xx
|
||||
BOARDNAME:=Broadcom BCM63xx
|
||||
FEATURES:=squashfs jffs2 usb atm pci pcmcia
|
||||
LINUX_VERSION:=2.6.35.9
|
||||
LINUX_VERSION:=2.6.35.11
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -99,7 +99,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
|
||||
|
||||
if (sock->type == SOCK_PACKET)
|
||||
po->prot_hook.func = packet_rcv_spkt;
|
||||
@@ -2027,6 +2031,16 @@ packet_setsockopt(struct socket *sock, i
|
||||
@@ -2030,6 +2034,16 @@ packet_setsockopt(struct socket *sock, i
|
||||
po->has_vnet_hdr = !!val;
|
||||
return 0;
|
||||
}
|
||||
@ -116,7 +116,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
|
||||
default:
|
||||
return -ENOPROTOOPT;
|
||||
}
|
||||
@@ -2084,6 +2098,13 @@ static int packet_getsockopt(struct sock
|
||||
@@ -2087,6 +2101,13 @@ static int packet_getsockopt(struct sock
|
||||
|
||||
data = &val;
|
||||
break;
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/drivers/usb/serial/usb-serial.c
|
||||
+++ b/drivers/usb/serial/usb-serial.c
|
||||
@@ -61,6 +61,7 @@ static struct usb_driver usb_serial_driv
|
||||
@@ -62,6 +62,7 @@ static struct usb_driver usb_serial_driv
|
||||
drivers depend on it.
|
||||
*/
|
||||
|
||||
@ -8,7 +8,7 @@
|
||||
static int debug;
|
||||
/* initially all NULL */
|
||||
static struct usb_serial *serial_table[SERIAL_TTY_MINORS];
|
||||
@@ -912,7 +913,7 @@ int usb_serial_probe(struct usb_interfac
|
||||
@@ -913,7 +914,7 @@ int usb_serial_probe(struct usb_interfac
|
||||
}
|
||||
buffer_size = serial->type->bulk_in_size;
|
||||
if (!buffer_size)
|
||||
@ -17,7 +17,7 @@
|
||||
port->bulk_in_size = buffer_size;
|
||||
port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
|
||||
port->bulk_in_buffer = kmalloc(buffer_size, GFP_KERNEL);
|
||||
@@ -1382,3 +1383,5 @@ MODULE_LICENSE("GPL");
|
||||
@@ -1385,3 +1386,5 @@ MODULE_LICENSE("GPL");
|
||||
|
||||
module_param(debug, bool, S_IRUGO | S_IWUSR);
|
||||
MODULE_PARM_DESC(debug, "Debug enabled or not");
|
||||
|
@ -48,7 +48,7 @@
|
||||
{
|
||||
--- a/kernel/exit.c
|
||||
+++ b/kernel/exit.c
|
||||
@@ -506,6 +506,7 @@ struct files_struct *get_files_struct(st
|
||||
@@ -514,6 +514,7 @@ struct files_struct *get_files_struct(st
|
||||
|
||||
return files;
|
||||
}
|
||||
@ -56,7 +56,7 @@
|
||||
|
||||
void put_files_struct(struct files_struct *files)
|
||||
{
|
||||
@@ -527,6 +528,7 @@ void put_files_struct(struct files_struc
|
||||
@@ -535,6 +536,7 @@ void put_files_struct(struct files_struc
|
||||
rcu_read_unlock();
|
||||
}
|
||||
}
|
||||
@ -76,7 +76,7 @@
|
||||
* macro override instead of weak attribute alias, to workaround
|
||||
--- a/kernel/sched.c
|
||||
+++ b/kernel/sched.c
|
||||
@@ -4262,6 +4262,7 @@ int can_nice(const struct task_struct *p
|
||||
@@ -4390,6 +4390,7 @@ int can_nice(const struct task_struct *p
|
||||
return (nice_rlim <= task_rlimit(p, RLIMIT_NICE) ||
|
||||
capable(CAP_SYS_NICE));
|
||||
}
|
||||
|
@ -12,7 +12,7 @@ BOARDNAME:=Marvell Kirkwood
|
||||
FEATURES:=targz usb jffs2
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=2.6.35.9
|
||||
LINUX_VERSION:=2.6.35.11
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -12,7 +12,7 @@ BOARDNAME:=Lantiq GPON/XWAY
|
||||
FEATURES:=squashfs jffs2 atm
|
||||
SUBTARGETS:=xway
|
||||
|
||||
LINUX_VERSION:=2.6.35.9
|
||||
LINUX_VERSION:=2.6.35.11
|
||||
|
||||
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user