mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-23 21:37:10 +02:00
[kernel] update to kernel 2.6.36.4
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25580 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
5a446cf2d8
commit
ea7e9693a2
@ -17,8 +17,8 @@ endif
|
||||
ifeq ($(LINUX_VERSION),2.6.35.9)
|
||||
LINUX_KERNEL_MD5SUM:=18d339e9229560e73c4249dffdc3fd90
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),2.6.36.2)
|
||||
LINUX_KERNEL_MD5SUM:=d465f8ba05bf1b7530c596f1cca658e7
|
||||
ifeq ($(LINUX_VERSION),2.6.36.4)
|
||||
LINUX_KERNEL_MD5SUM:=c05dd941d0e249695e9f72568888e1bf
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),2.6.37.1)
|
||||
LINUX_KERNEL_MD5SUM:=07d3b1868a67c1a7ddcf1d54444cb5d1
|
||||
|
@ -11,7 +11,7 @@ BOARD:=adm8668
|
||||
BOARDNAME:=Infineon WildPass ADM8668
|
||||
FEATURES:=squashfs
|
||||
|
||||
LINUX_VERSION:=2.6.36.2
|
||||
LINUX_VERSION:=2.6.36.4
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES += wpad-mini kmod-rt61-pci
|
||||
|
@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
|
||||
FEATURES:=squashfs
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=2.6.36.2
|
||||
LINUX_VERSION:=2.6.36.4
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -11,7 +11,7 @@ BOARD:=brcm47xx
|
||||
BOARDNAME:=Broadcom BCM947xx/953xx
|
||||
FEATURES:=squashfs usb pcmcia
|
||||
|
||||
LINUX_VERSION:=2.6.36.2
|
||||
LINUX_VERSION:=2.6.36.4
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
|
||||
|
@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks CNS21xx
|
||||
FEATURES:=squashfs broken
|
||||
CFLAGS:=-Os -pipe -march=armv4 -mtune=arm9tdmi -funit-at-a-time
|
||||
|
||||
LINUX_VERSION:=2.6.36.2
|
||||
LINUX_VERSION:=2.6.36.4
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -12,7 +12,7 @@ BOARDNAME:=Cirrus Logic EP93xx
|
||||
FEATURES:=squashfs jffs2 ext4 targz usb
|
||||
CFLAGS:=-Os -pipe -march=armv4t -funit-at-a-time
|
||||
|
||||
LINUX_VERSION:=2.6.36.2
|
||||
LINUX_VERSION:=2.6.36.4
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -81,7 +81,7 @@
|
||||
htc_excalibur_s620 MACH_HTC_EXCALIBUR_S620 HTC_EXCALIBUR_S620 2391
|
||||
htc_opal MACH_HTC_OPAL HTC_OPAL 2392
|
||||
touchbook MACH_TOUCHBOOK TOUCHBOOK 2393
|
||||
@@ -2446,7 +2446,7 @@ siogentoo1 MACH_SIOGENTOO1 SIOGENTOO1
|
||||
@@ -2446,7 +2446,7 @@ siogentoo1 MACH_SIOGENTOO1 SIOGENTOO1
|
||||
siogentoo2 MACH_SIOGENTOO2 SIOGENTOO2 2459
|
||||
sm3k MACH_SM3K SM3K 2460
|
||||
acer_tempo_f900 MACH_ACER_TEMPO_F900 ACER_TEMPO_F900 2461
|
||||
|
@ -99,7 +99,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
|
||||
|
||||
if (sock->type == SOCK_PACKET)
|
||||
po->prot_hook.func = packet_rcv_spkt;
|
||||
@@ -2054,6 +2058,16 @@ packet_setsockopt(struct socket *sock, i
|
||||
@@ -2057,6 +2061,16 @@ packet_setsockopt(struct socket *sock, i
|
||||
po->tp_tstamp = val;
|
||||
return 0;
|
||||
}
|
||||
@ -116,7 +116,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
|
||||
default:
|
||||
return -ENOPROTOOPT;
|
||||
}
|
||||
@@ -2111,6 +2125,13 @@ static int packet_getsockopt(struct sock
|
||||
@@ -2114,6 +2128,13 @@ static int packet_getsockopt(struct sock
|
||||
|
||||
data = &val;
|
||||
break;
|
||||
|
@ -17,7 +17,7 @@
|
||||
port->bulk_in_size = buffer_size;
|
||||
port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
|
||||
port->bulk_in_buffer = kmalloc(buffer_size, GFP_KERNEL);
|
||||
@@ -1376,3 +1377,5 @@ MODULE_LICENSE("GPL");
|
||||
@@ -1380,3 +1381,5 @@ MODULE_LICENSE("GPL");
|
||||
|
||||
module_param(debug, bool, S_IRUGO | S_IWUSR);
|
||||
MODULE_PARM_DESC(debug, "Debug enabled or not");
|
||||
|
@ -48,7 +48,7 @@
|
||||
{
|
||||
--- a/kernel/exit.c
|
||||
+++ b/kernel/exit.c
|
||||
@@ -506,6 +506,7 @@ struct files_struct *get_files_struct(st
|
||||
@@ -514,6 +514,7 @@ struct files_struct *get_files_struct(st
|
||||
|
||||
return files;
|
||||
}
|
||||
@ -56,7 +56,7 @@
|
||||
|
||||
void put_files_struct(struct files_struct *files)
|
||||
{
|
||||
@@ -527,6 +528,7 @@ void put_files_struct(struct files_struc
|
||||
@@ -535,6 +536,7 @@ void put_files_struct(struct files_struc
|
||||
rcu_read_unlock();
|
||||
}
|
||||
}
|
||||
@ -76,7 +76,7 @@
|
||||
* macro override instead of weak attribute alias, to workaround
|
||||
--- a/kernel/sched.c
|
||||
+++ b/kernel/sched.c
|
||||
@@ -4439,6 +4439,7 @@ int can_nice(const struct task_struct *p
|
||||
@@ -4567,6 +4567,7 @@ int can_nice(const struct task_struct *p
|
||||
return (nice_rlim <= task_rlimit(p, RLIMIT_NICE) ||
|
||||
capable(CAP_SYS_NICE));
|
||||
}
|
||||
|
@ -14,7 +14,7 @@ FEATURES+=fpu tgz
|
||||
CFLAGS:=-Os -pipe -mcpu=v8 -funit-at-a-time
|
||||
KERNELNAME:="uImage"
|
||||
|
||||
LINUX_VERSION:=2.6.36.2
|
||||
LINUX_VERSION:=2.6.36.4
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=603e
|
||||
FEATURES:=squashfs targz broken
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=2.6.36.2
|
||||
LINUX_VERSION:=2.6.36.4
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=8540
|
||||
FEATURES:=spe_fpu ramdisk broken
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=2.6.36.2
|
||||
LINUX_VERSION:=2.6.36.4
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x
|
||||
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
|
||||
FEATURES:=squashfs
|
||||
|
||||
LINUX_VERSION:=2.6.36.2
|
||||
LINUX_VERSION:=2.6.36.4
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES+=kmod-leds-gpio wpad-mini
|
||||
|
@ -11,7 +11,7 @@ BOARD:=sparc
|
||||
BOARDNAME:=Sun UltraSPARC
|
||||
FEATURES+=fpu tgz
|
||||
|
||||
LINUX_VERSION:=2.6.36.2
|
||||
LINUX_VERSION:=2.6.36.4
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
Loading…
Reference in New Issue
Block a user