1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-01 03:29:29 +03:00

[package] uci: use latest git, fixes reorder operation and incorperates nested delete patch

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25048 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2011-01-19 20:48:07 +00:00
parent 8e454c7abc
commit 38df04989f
2 changed files with 4 additions and 24 deletions

View File

@ -7,13 +7,13 @@
include $(TOPDIR)/rules.mk
UCI_VERSION=2010-09-28
UCI_RELEASE=2
UCI_VERSION=2011-01-19
UCI_RELEASE=1
PKG_NAME:=uci
PKG_VERSION:=$(UCI_VERSION)$(if $(UCI_RELEASE),.$(UCI_RELEASE))
PKG_RELEASE:=2
PKG_REV:=3fa65a20ae0fc77b951515bc5de7a0041adc9be1
PKG_RELEASE:=1
PKG_REV:=a5eb996e0f04d911ff61479508bbc3e17b16ff0c
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=git://nbd.name/uci.git

View File

@ -1,20 +0,0 @@
--- a/lua/uci.c
+++ b/lua/uci.c
@@ -266,7 +266,7 @@ uci_lua_foreach(lua_State *L)
{
struct uci_context *ctx;
struct uci_package *p;
- struct uci_element *e;
+ struct uci_element *e, *tmp;
const char *package, *type;
bool ret = false;
int offset = 0;
@@ -287,7 +287,7 @@ uci_lua_foreach(lua_State *L)
if (!p)
goto done;
- uci_foreach_element(&p->sections, e) {
+ uci_foreach_element_safe(&p->sections, tmp, e) {
struct uci_section *s = uci_to_section(e);
i++;