1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-10-01 11:04:10 +03:00

[uml] add a patch to disable compile-time buffer checks enabled by default on Ubuntu 8.10 and later (closes: #4826)

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15119 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2009-04-06 16:45:10 +00:00
parent 4b55233a08
commit 46a0a72043

View File

@ -0,0 +1,11 @@
--- a/arch/um/Makefile-i386
+++ b/arch/um/Makefile-i386
@@ -39,4 +39,8 @@ KBUILD_CFLAGS += $(shell if [ $(call cc-
echo $(call cc-option,-fno-unit-at-a-time); \
else echo $(call cc-option,-funit-at-a-time); fi ;)
+# disable compile-time buffer checks, enabled by default on Ubuntu 8.10
+# and later
+KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
+
KBUILD_CFLAGS += $(cflags-y)