1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-10-01 10:07:37 +03:00

[package] add uboot-envtools

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17981 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2009-10-07 15:14:28 +00:00
parent 4cc6c0d0a2
commit 4cce3b1620
3 changed files with 80 additions and 0 deletions

View File

@ -0,0 +1,34 @@
#
# Copyright (C) 2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=uboot-envtools
PKG_VERSION:=20081215
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
PKG_SOURCE_URL:=http://ftp.de.debian.org/debian/pool/main/u/uboot-envtools/
include $(INCLUDE_DIR)/package.mk
define Package/uboot-envtools
SECTION:=utils
CATEGORY:=Utilities
TITLE:=read/modify the environment for the bootloader U-Boot
endef
define Package/uboot-envtools/description
endef
define Package/uboot-envtools/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/fw_printenv $(1)/usr/sbin/
ln -s fw_printenv $(1)/usr/sbin/fw_setenv
endef
$(eval $(call BuildPackage,uboot-envtools))

View File

@ -0,0 +1,13 @@
Index: uboot-envtools-20080520/crc32.c
===================================================================
--- uboot-envtools-20080520.orig/crc32.c 2008-08-03 16:02:43.000000000 +0200
+++ uboot-envtools-20080520/crc32.c 2008-08-03 16:03:25.000000000 +0200
@@ -154,7 +154,7 @@
#define DO8(buf) DO4(buf); DO4(buf);
/* ========================================================================= */
-uint32_t ZEXPORT crc32 (uint32_t crc, const Bytef *buf, uInt len)
+uLong ZEXPORT crc32 (uLong crc, const Bytef *buf, uInt len)
{
#ifdef DYNAMIC_CRC_TABLE
if (crc_table_empty)

View File

@ -0,0 +1,33 @@
Index: uboot-envtools-20080520/Makefile
===================================================================
--- uboot-envtools-20080520.orig/Makefile 2008-08-03 15:50:27.000000000 +0200
+++ uboot-envtools-20080520/Makefile 2008-08-03 15:51:59.000000000 +0200
@@ -21,12 +21,10 @@
# MA 02111-1307 USA
#
-include $(TOPDIR)/config.mk
-
SRCS := $(obj)crc32.c fw_env.c fw_env_main.c
HEADERS := fw_env.h
-CPPFLAGS := -Wall -DUSE_HOSTCC -I$(SRCTREE)/include
+CPPFLAGS := -Wall -DUSE_HOSTCC -I/usr/include
ifeq ($(MTD_VERSION),old)
CPPFLAGS += -DMTD_OLD
@@ -39,14 +37,3 @@
clean:
rm -f $(obj)fw_printenv $(obj)crc32.c
-
-$(obj)crc32.c:
- ln -s $(src)../../lib_generic/crc32.c $(obj)crc32.c
-
-#########################################################################
-
-include $(TOPDIR)/rules.mk
-
-sinclude $(obj).depend
-
-#########################################################################