1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-10-02 15:53:49 +03:00

add slurm package (thanks to Thomas Reifferscheid)

git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2357 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2005-11-06 21:20:42 +00:00
parent be6fd5ee21
commit 4d0dbb5fc3
6 changed files with 161 additions and 0 deletions

View File

@ -111,6 +111,7 @@ source "package/ser/Config.in"
source "package/shat/Config.in"
source "package/siproxd/Config.in"
source "package/sipsak/Config.in"
source "package/slurm/Config.in"
source "package/snort/Config.in"
source "package/snort-wireless/Config.in"
source "package/socat/Config.in"

View File

@ -176,6 +176,7 @@ package-$(BR2_PACKAGE_SHAT) += shat
package-$(BR2_COMPILE_SHFS) += shfs
package-$(BR2_PACKAGE_SIPROXD) += siproxd
package-$(BR2_PACKAGE_SIPSAK) += sipsak
package-$(BR2_PACKAGE_SLURM) += slurm
package-$(BR2_COMPILE_SNORT) += snort
package-$(BR2_COMPILE_SNORT_WIRELESS) += snort-wireless
package-$(BR2_PACKAGE_SOCAT) += socat

15
package/slurm/Config.in Normal file
View File

@ -0,0 +1,15 @@
config BR2_PACKAGE_SLURM
prompt "slurm............................. A realtime network interface monitor"
tristate
default m if CONFIG_DEVEL
help
A realtime network interface monitor with the following features:
* realtime traffic statistics divided into incoming and outgoing
* optional combined view
* can monitor any kind of network interface
* shows detailed statistics about the interface.
* it's themeable
http://www.wormulon.net/projects/slurm

71
package/slurm/Makefile Normal file
View File

@ -0,0 +1,71 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=slurm
PKG_VERSION:=0.3.3
PKG_RELEASE:=1
PKG_MD5SUM:=e68d09202b835c644f7f6b7f070f29a2
PKG_SOURCE_URL:=http://www.wormulon.net/files/code/slurm/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,SLURM,slurm,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
touch configure.in; \
touch aclocal.m4; \
touch Makefile.in; \
touch config.h.in; \
touch configure; \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
LIBS="-lncurses" \
ac_cv_func_malloc_0_nonnull=yes \
ac_cv_lib_ncurses_use_default_colors=yes \
./configure \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
--program-prefix="" \
--program-suffix="" \
--prefix=/usr \
--exec-prefix=/usr \
--bindir=/usr/bin \
--datadir=/usr/share \
--includedir=/usr/include \
--infodir=/usr/share/info \
--libdir=/usr/lib \
--libexecdir=/usr/lib \
--localstatedir=/var \
--mandir=/usr/share/man \
--sbindir=/usr/sbin \
--sysconfdir=/etc \
$(DISABLE_LARGEFILE) \
$(DISABLE_NLS) \
);
touch $@
$(PKG_BUILD_DIR)/.built:
rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
all install
touch $@
$(IPKG_SLURM):
install -d -m0755 $(IDIR_SLURM)/usr/bin
cp -fpR $(PKG_INSTALL_DIR)/usr/bin/slurm $(IDIR_SLURM)/usr/bin/
$(RSTRIP) $(IDIR_SLURM)
$(IPKG_BUILD) $(IDIR_SLURM) $(PACKAGE_DIR)
mostlyclean:
-$(MAKE) -C $(PKG_BUILD_DIR) clean
rm $(PKG_BUILD_DIR)/.built

View File

@ -0,0 +1,6 @@
Package: slurm
Priority: standard
Section: net
Depends: libncurses
Description: Realtime network interface monitor

View File

@ -0,0 +1,67 @@
diff -ruN slurm-0.3.3-old/configure slurm-0.3.3-new/configure
--- slurm-0.3.3-old/configure 2004-09-28 16:34:56.000000000 +0200
+++ slurm-0.3.3-new/configure 2005-11-06 22:08:53.000000000 +0100
@@ -4762,35 +4762,35 @@
_ACEOF
-for cursespath in /usr/include/ncurses.h /usr/local/include/ncurses.h /usr/local/include/ncurses/ncurses.h /opt/include/ncurses.h /opt/include/curses.h /usr/include/curses.h /usr/local/include/curses.h /dev/null
-do
- test -f "${cursespath}" && break
-done
-case ${cursespath} in
- /usr/include/*)
- CFLAGS="$CFLAGS -I/usr/include"
- LDFLAGS=""
- ;;
- /usr/local/include/ncurses/*)
- CFLAGS="${CFLAGS} -I/usr/local/include/ncurses"
- LDFLAGS="-L/usr/local/lib"
- SOLLDFLAGS="-R/usr/local/lib"
- ;;
- /usr/local/include/*)
- CFLAGS="${CFLAGS} -I/usr/local/include"
- LDFLAGS="-L/usr/local/lib"
- SOLLDFLAGS="-R/usr/local/lib"
- ;;
- /opt/include/*)
- CFLAGS="${CFLAGS} -I/opt/include"
- LDFLAGS="-L/opt/lib"
- SOLLDFLAGS="-R/opt/lib"
- ;;
-esac
+#for cursespath in /usr/include/ncurses.h /usr/local/include/ncurses.h /usr/local/include/ncurses/ncurses.h /opt/include/ncurses.h /opt/include/curses.h /usr/include/curses.h /usr/local/include/curses.h /dev/null
+#do
+# test -f "${cursespath}" && break
+#done
+#case ${cursespath} in
+# /usr/include/*)
+# CFLAGS="$CFLAGS -I/usr/include"
+# LDFLAGS=""
+# ;;
+# /usr/local/include/ncurses/*)
+# CFLAGS="${CFLAGS} -I/usr/local/include/ncurses"
+# LDFLAGS="-L/usr/local/lib"
+# SOLLDFLAGS="-R/usr/local/lib"
+# ;;
+# /usr/local/include/*)
+# CFLAGS="${CFLAGS} -I/usr/local/include"
+# LDFLAGS="-L/usr/local/lib"
+# SOLLDFLAGS="-R/usr/local/lib"
+# ;;
+# /opt/include/*)
+# CFLAGS="${CFLAGS} -I/opt/include"
+# LDFLAGS="-L/opt/lib"
+# SOLLDFLAGS="-R/opt/lib"
+# ;;
+#esac
# add Slowlaris -R and libraries to LDFLAGS
-if test ${OSTYPE} = "solaris" ; then
- LDFLAGS="${LDFLAGS} ${SOLLDFLAGS} -lnsl -lsocket -lkstat"
-fi
+#if test ${OSTYPE} = "solaris" ; then
+# LDFLAGS="${LDFLAGS} ${SOLLDFLAGS} -lnsl -lsocket -lkstat"
+#fi
echo "$as_me:$LINENO: checking for vanilla_coke in -lfridge" >&5
echo $ECHO_N "checking for vanilla_coke in -lfridge... $ECHO_C" >&6