mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-04 23:25:01 +02:00
ipset: update to v6.14, drop obsolete patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33735 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
00435ce062
commit
4e0b033092
@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=ipset
|
||||
PKG_VERSION:=6.11
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=6.14
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://ipset.netfilter.org
|
||||
PKG_MD5SUM:=bfcc92e30a0fcf10ae6e7c4affa03c84
|
||||
PKG_MD5SUM:=70f2d4c054592236dcda285855a4ee58
|
||||
|
||||
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
|
||||
|
||||
|
@ -1,20 +0,0 @@
|
||||
--- a/kernel/net/netfilter/ipset/ip_set_getport.c
|
||||
+++ b/kernel/net/netfilter/ipset/ip_set_getport.c
|
||||
@@ -8,7 +8,7 @@
|
||||
/* Get Layer-4 data from the packets */
|
||||
|
||||
#include <linux/version.h>
|
||||
-#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,0,0)
|
||||
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,2,0)
|
||||
#include <linux/export.h>
|
||||
#endif
|
||||
#include <linux/ip.h>
|
||||
--- a/kernel/net/netfilter/ipset/pfxlen.c
|
||||
+++ b/kernel/net/netfilter/ipset/pfxlen.c
|
||||
@@ -1,5 +1,5 @@
|
||||
#include <linux/version.h>
|
||||
-#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,0,0)
|
||||
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,2,0)
|
||||
#include <linux/export.h>
|
||||
#endif
|
||||
#include <linux/netfilter/ipset/pfxlen.h>
|
@ -1,22 +0,0 @@
|
||||
--- a/kernel/net/netfilter/ipset/ip_set_hash_ip.c
|
||||
+++ b/kernel/net/netfilter/ipset/ip_set_hash_ip.c
|
||||
@@ -241,7 +241,7 @@ hash_ip6_data_isnull(const struct hash_i
|
||||
static inline void
|
||||
hash_ip6_data_copy(struct hash_ip6_elem *dst, const struct hash_ip6_elem *src)
|
||||
{
|
||||
- ipv6_addr_copy(&dst->ip.in6, &src->ip.in6);
|
||||
+ dst->ip.in6 = src->ip.in6;
|
||||
}
|
||||
|
||||
static inline void
|
||||
--- a/kernel/net/netfilter/ipset/ip_set_hash_net.c
|
||||
+++ b/kernel/net/netfilter/ipset/ip_set_hash_net.c
|
||||
@@ -295,7 +295,7 @@ static inline void
|
||||
hash_net6_data_copy(struct hash_net6_elem *dst,
|
||||
const struct hash_net6_elem *src)
|
||||
{
|
||||
- ipv6_addr_copy(&dst->ip.in6, &src->ip.in6);
|
||||
+ dst->ip.in6 = src->ip.in6;
|
||||
dst->cidr = src->cidr;
|
||||
dst->nomatch = src->nomatch;
|
||||
}
|
@ -1,29 +0,0 @@
|
||||
--- a/kernel/net/netfilter/ipset/ip_set_getport.c
|
||||
+++ b/kernel/net/netfilter/ipset/ip_set_getport.c
|
||||
@@ -113,6 +113,17 @@ ip_set_get_ip4_port(const struct sk_buff
|
||||
EXPORT_SYMBOL_GPL(ip_set_get_ip4_port);
|
||||
|
||||
#if defined(CONFIG_IP6_NF_IPTABLES) || defined(CONFIG_IP6_NF_IPTABLES_MODULE)
|
||||
+static int ip_set_skip_exthdr(const struct sk_buff *skb, int start,
|
||||
+ u8 *nexthdrp)
|
||||
+{
|
||||
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,3,0)
|
||||
+ __be16 fragoff;
|
||||
+ return ipv6_skip_exthdr(skb, start, nexthdrp, &fragoff);
|
||||
+#else
|
||||
+ return ipv6_skip_exthdr(skb, start, nexthdrp);
|
||||
+#endif
|
||||
+}
|
||||
+
|
||||
bool
|
||||
ip_set_get_ip6_port(const struct sk_buff *skb, bool src,
|
||||
__be16 *port, u8 *proto)
|
||||
@@ -121,7 +132,7 @@ ip_set_get_ip6_port(const struct sk_buff
|
||||
u8 nexthdr;
|
||||
|
||||
nexthdr = ipv6_hdr(skb)->nexthdr;
|
||||
- protoff = ipv6_skip_exthdr(skb, sizeof(struct ipv6hdr), &nexthdr);
|
||||
+ protoff = ip_set_skip_exthdr(skb, sizeof(struct ipv6hdr), &nexthdr);
|
||||
if (protoff < 0)
|
||||
return false;
|
||||
|
Loading…
Reference in New Issue
Block a user