1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-06-28 14:12:00 +03:00

[package] lua: remove posix from Lua core, almost nothing uses it - saves 9k compressed

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26822 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2011-05-04 14:51:06 +00:00
parent 9c731309db
commit 4ffa672cca
3 changed files with 2 additions and 1476 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2006-2009 OpenWrt.org
# Copyright (C) 2006-2011 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=lua
PKG_VERSION:=5.1.4
PKG_RELEASE:=7
PKG_RELEASE:=8
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.lua.org/ftp/ \

File diff suppressed because it is too large Load Diff

View File

@ -1,26 +0,0 @@
--- a/src/lposix.c
+++ b/src/lposix.c
@@ -727,11 +727,13 @@ static int Pctermid(lua_State *L) /** c
}
+#ifndef NO_GETLOGIN
static int Pgetlogin(lua_State *L) /** getlogin() */
{
lua_pushstring(L, getlogin());
return 1;
}
+#endif
static void Fgetpasswd(lua_State *L, int i, const void *data)
@@ -1052,7 +1054,9 @@ static const luaL_reg R[] =
{"getcwd", Pgetcwd},
{"getenv", Pgetenv},
{"getgroup", Pgetgroup},
+#ifndef NO_GETLOGIN
{"getlogin", Pgetlogin},
+#endif
{"getpasswd", Pgetpasswd},
{"getpid", Pgetpid},
{"glob", Pglob},