mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-23 23:46:16 +02:00
[ifxmips] update os abstraction layer
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20639 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
9e41f39fb6
commit
5332ca5fea
@ -10,16 +10,16 @@ include $(TOPDIR)/rules.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=lib_ifxos
|
||||
PKG_VERSION:=1.5.10
|
||||
PKG_VERSION:=1.5.12
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_RELEASE:=1
|
||||
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
|
||||
PKG_MD5SUM:=3602797b0f531f37546c6beb748d50cf
|
||||
#PKG_MD5SUM:=3602797b0f531f37546c6beb748d50cf
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define KernelPackage/ifxos
|
||||
SUBMENU:=Lantiq
|
||||
SUBMENU:=Other modules
|
||||
TITLE:=Lantiq OS abstraction library
|
||||
URL:=http://www.lantiq.com/
|
||||
MAINTAINER:=Lantiq
|
||||
|
@ -1,23 +1,8 @@
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -149,12 +149,12 @@ AC_ARG_ENABLE(targetincl,
|
||||
echo Set the target image include path $enableval
|
||||
AC_SUBST([TARGET_INCL_PATH],[$enableval])
|
||||
else
|
||||
- echo -e Set the default target image include path $DEFAULT_TARGET_INCL_PATH
|
||||
+ echo Set the default target image include path $DEFAULT_TARGET_INCL_PATH
|
||||
AC_SUBST([TARGET_INCL_PATH],[$DEFAULT_TARGET_INCL_PATH])
|
||||
fi
|
||||
],
|
||||
[
|
||||
- echo -e Set the default target image include path $DEFAULT_TARGET_INCL_PATH
|
||||
+ echo Set the default target image include path $DEFAULT_TARGET_INCL_PATH
|
||||
AC_SUBST([TARGET_INCL_PATH],[$DEFAULT_TARGET_INCL_PATH])
|
||||
]
|
||||
)
|
||||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -610,7 +610,7 @@ if KERNEL_2_6
|
||||
Index: lib_ifxos-1.5.12/src/Makefile.am
|
||||
===================================================================
|
||||
--- lib_ifxos-1.5.12.orig/src/Makefile.am 2010-01-08 18:12:15.000000000 +0100
|
||||
+++ lib_ifxos-1.5.12/src/Makefile.am 2010-03-31 18:56:12.000000000 +0200
|
||||
@@ -639,7 +639,7 @@
|
||||
drv_ifxos_OBJS = "$(subst .c,.o,$(filter %.c,$(drv_ifxos_SOURCES)))"
|
||||
|
||||
drv_ifxos.ko: $(drv_ifxos_SOURCES)
|
||||
@ -26,7 +11,7 @@
|
||||
if test ! -e common/ifxos_debug.c ; then \
|
||||
echo "copy source files (as links only!)"; \
|
||||
for f in $(filter %.c,$(drv_ifxos_SOURCES)); do \
|
||||
@@ -618,10 +618,10 @@ drv_ifxos.ko: $(drv_ifxos_SOURCES)
|
||||
@@ -647,10 +647,10 @@
|
||||
cp -s $(addprefix @abs_srcdir@/,$$f) $(PWD)/`dirname $$f`/ ; \
|
||||
done \
|
||||
fi
|
||||
|
Loading…
Reference in New Issue
Block a user