mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-24 03:50:37 +02:00
mac80211: update to latest wireless-testing from today
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19501 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
225afe78f2
commit
54023e7503
@ -10,12 +10,12 @@ include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=mac80211
|
||||
|
||||
PKG_VERSION:=2010-01-25
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=2010-02-02
|
||||
PKG_RELEASE:=1
|
||||
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
|
||||
# http://www.orbit-lab.org/kernel/compat-wireless-2.6/2010/11 \
|
||||
# http://wireless.kernel.org/download/compat-wireless-2.6
|
||||
PKG_MD5SUM:=66a1d519e7ebcbadd4e47e6e56f705af
|
||||
PKG_MD5SUM:=32602171b840132cbaa62d4b67f32d2c
|
||||
|
||||
PKG_SOURCE:=compat-wireless-$(PKG_VERSION).tar.bz2
|
||||
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/compat-wireless-$(PKG_VERSION)
|
||||
|
@ -8,7 +8,7 @@
|
||||
#include <asm/unaligned.h>
|
||||
|
||||
#include "hw.h"
|
||||
@@ -437,8 +438,18 @@ static int ath9k_hw_init_macaddr(struct
|
||||
@@ -441,8 +442,18 @@ static int ath9k_hw_init_macaddr(struct
|
||||
common->macaddr[2 * i] = eeval >> 8;
|
||||
common->macaddr[2 * i + 1] = eeval & 0xff;
|
||||
}
|
||||
|
@ -8,7 +8,7 @@
|
||||
#include "ath9k.h"
|
||||
|
||||
static struct pci_device_id ath_pci_id_table[] __devinitdata = {
|
||||
@@ -61,21 +62,36 @@ static void ath_pci_cleanup(struct ath_c
|
||||
@@ -52,21 +53,36 @@ static void ath_pci_read_cachesize(struc
|
||||
|
||||
static bool ath_pci_eeprom_read(struct ath_common *common, u32 off, u16 *data)
|
||||
{
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/drivers/net/wireless/ath/ath9k/hw.c
|
||||
+++ b/drivers/net/wireless/ath/ath9k/hw.c
|
||||
@@ -381,11 +381,8 @@ static void ath9k_hw_init_defaults(struc
|
||||
@@ -385,11 +385,8 @@ static void ath9k_hw_init_defaults(struc
|
||||
ah->hw_version.magic = AR5416_MAGIC;
|
||||
ah->hw_version.subvendorid = 0;
|
||||
|
||||
|
@ -11,7 +11,7 @@
|
||||
#include "hw.h"
|
||||
#include "rc.h"
|
||||
#include "initvals.h"
|
||||
@@ -424,17 +426,23 @@ static int ath9k_hw_rf_claim(struct ath_
|
||||
@@ -428,17 +430,23 @@ static int ath9k_hw_rf_claim(struct ath_
|
||||
static int ath9k_hw_init_macaddr(struct ath_hw *ah)
|
||||
{
|
||||
struct ath_common *common = ath9k_hw_common(ah);
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/drivers/net/wireless/ath/ath9k/hw.c
|
||||
+++ b/drivers/net/wireless/ath/ath9k/hw.c
|
||||
@@ -2087,7 +2087,7 @@ int ath9k_hw_reset(struct ath_hw *ah, st
|
||||
@@ -2092,7 +2092,7 @@ int ath9k_hw_reset(struct ath_hw *ah, st
|
||||
|
||||
if (ah->config.rx_intr_mitigation) {
|
||||
REG_RMW_FIELD(ah, AR_RIMT, AR_RIMT_LAST, 500);
|
||||
|
@ -1,8 +1,8 @@
|
||||
--- a/drivers/net/wireless/ath/ath9k/debug.c
|
||||
+++ b/drivers/net/wireless/ath/ath9k/debug.c
|
||||
@@ -75,6 +75,90 @@ static const struct file_operations fops
|
||||
@@ -77,6 +77,90 @@ static const struct file_operations fops
|
||||
|
||||
#endif
|
||||
#define DMA_BUF_LEN 1024
|
||||
|
||||
+static ssize_t read_file_tx_chainmask(struct file *file, char __user *user_buf,
|
||||
+ size_t count, loff_t *ppos)
|
||||
@ -91,7 +91,7 @@
|
||||
static ssize_t read_file_dma(struct file *file, char __user *user_buf,
|
||||
size_t count, loff_t *ppos)
|
||||
{
|
||||
@@ -710,6 +794,16 @@ int ath9k_init_debug(struct ath_hw *ah)
|
||||
@@ -719,6 +803,16 @@ int ath9k_init_debug(struct ath_hw *ah)
|
||||
goto err;
|
||||
#endif
|
||||
|
||||
@ -108,7 +108,7 @@
|
||||
sc->debug.debugfs_dma = debugfs_create_file("dma", S_IRUSR,
|
||||
sc->debug.debugfs_phy, sc, &fops_dma);
|
||||
if (!sc->debug.debugfs_dma)
|
||||
@@ -760,6 +854,8 @@ void ath9k_exit_debug(struct ath_hw *ah)
|
||||
@@ -769,6 +863,8 @@ void ath9k_exit_debug(struct ath_hw *ah)
|
||||
struct ath_common *common = ath9k_hw_common(ah);
|
||||
struct ath_softc *sc = (struct ath_softc *) common->priv;
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/drivers/net/wireless/ath/ath9k/debug.c
|
||||
+++ b/drivers/net/wireless/ath/ath9k/debug.c
|
||||
@@ -774,6 +774,86 @@ static const struct file_operations fops
|
||||
@@ -783,6 +783,86 @@ static const struct file_operations fops
|
||||
.owner = THIS_MODULE
|
||||
};
|
||||
|
||||
@ -87,7 +87,7 @@
|
||||
int ath9k_init_debug(struct ath_hw *ah)
|
||||
{
|
||||
struct ath_common *common = ath9k_hw_common(ah);
|
||||
@@ -843,6 +923,17 @@ int ath9k_init_debug(struct ath_hw *ah)
|
||||
@@ -852,6 +932,17 @@ int ath9k_init_debug(struct ath_hw *ah)
|
||||
if (!sc->debug.debugfs_recv)
|
||||
goto err;
|
||||
|
||||
@ -105,7 +105,7 @@
|
||||
return 0;
|
||||
err:
|
||||
ath9k_exit_debug(ah);
|
||||
@@ -856,6 +947,8 @@ void ath9k_exit_debug(struct ath_hw *ah)
|
||||
@@ -865,6 +956,8 @@ void ath9k_exit_debug(struct ath_hw *ah)
|
||||
|
||||
debugfs_remove(sc->debug.debugfs_tx_chainmask);
|
||||
debugfs_remove(sc->debug.debugfs_rx_chainmask);
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/drivers/net/wireless/ath/ath9k/hw.c
|
||||
+++ b/drivers/net/wireless/ath/ath9k/hw.c
|
||||
@@ -1228,6 +1228,11 @@ void ath9k_hw_init_global_settings(struc
|
||||
@@ -1233,6 +1233,11 @@ void ath9k_hw_init_global_settings(struc
|
||||
/* As defined by IEEE 802.11-2007 17.3.8.6 */
|
||||
slottime = ah->slottime + 3 * ah->coverage_class;
|
||||
acktimeout = slottime + sifstime;
|
||||
|
20
package/mac80211/patches/540-ath9k_fix_eap_handling.patch
Normal file
20
package/mac80211/patches/540-ath9k_fix_eap_handling.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- a/drivers/net/wireless/ath/ath9k/xmit.c
|
||||
+++ b/drivers/net/wireless/ath/ath9k/xmit.c
|
||||
@@ -1610,7 +1610,7 @@ static int ath_tx_setup_buffer(struct ie
|
||||
bf->bf_frmlen -= padsize;
|
||||
}
|
||||
|
||||
- if (conf_is_ht(&hw->conf) && !is_pae(skb))
|
||||
+ if (conf_is_ht(&hw->conf))
|
||||
bf->bf_state.bf_type |= BUF_HT;
|
||||
|
||||
bf->bf_flags = setup_tx_flags(sc, skb, txctl->txq);
|
||||
@@ -1696,7 +1696,7 @@ static void ath_tx_start_dma(struct ath_
|
||||
goto tx_done;
|
||||
}
|
||||
|
||||
- if (tx_info->flags & IEEE80211_TX_CTL_AMPDU) {
|
||||
+ if ((tx_info->flags & IEEE80211_TX_CTL_AMPDU) && !is_pae(skb)) {
|
||||
/*
|
||||
* Try aggregation if it's a unicast data frame
|
||||
* and the destination is HT capable.
|
@ -1,20 +0,0 @@
|
||||
--- a/net/mac80211/rx.c
|
||||
+++ b/net/mac80211/rx.c
|
||||
@@ -2359,7 +2359,7 @@ static void __ieee80211_rx_handle_packet
|
||||
continue;
|
||||
}
|
||||
|
||||
- rx.sta = sta_info_get(prev, hdr->addr2);
|
||||
+ rx.sta = sta_info_get_bss(prev, hdr->addr2);
|
||||
|
||||
rx.flags |= IEEE80211_RX_RA_MATCH;
|
||||
prepares = prepare_for_handlers(prev, &rx, hdr);
|
||||
@@ -2395,7 +2395,7 @@ next:
|
||||
}
|
||||
|
||||
if (prev) {
|
||||
- rx.sta = sta_info_get(prev, hdr->addr2);
|
||||
+ rx.sta = sta_info_get_bss(prev, hdr->addr2);
|
||||
|
||||
rx.flags |= IEEE80211_RX_RA_MATCH;
|
||||
prepares = prepare_for_handlers(prev, &rx, hdr);
|
@ -1,48 +0,0 @@
|
||||
--- a/include/net/mac80211.h
|
||||
+++ b/include/net/mac80211.h
|
||||
@@ -274,6 +274,8 @@ struct ieee80211_bss_conf {
|
||||
* @IEEE80211_TX_INTFL_RETRANSMISSION: This frame is being retransmitted
|
||||
* after TX status because the destination was asleep, it must not
|
||||
* be modified again (no seqno assignment, crypto, etc.)
|
||||
+ * @IEEE80211_TX_INTFL_HAS_RADIOTAP: This frame was injected and still
|
||||
+ * has a radiotap header at skb->data.
|
||||
*/
|
||||
enum mac80211_tx_control_flags {
|
||||
IEEE80211_TX_CTL_REQ_TX_STATUS = BIT(0),
|
||||
@@ -295,6 +297,7 @@ enum mac80211_tx_control_flags {
|
||||
IEEE80211_TX_CTL_PSPOLL_RESPONSE = BIT(17),
|
||||
IEEE80211_TX_CTL_MORE_FRAMES = BIT(18),
|
||||
IEEE80211_TX_INTFL_RETRANSMISSION = BIT(19),
|
||||
+ IEEE80211_TX_INTFL_HAS_RADIOTAP = BIT(20),
|
||||
};
|
||||
|
||||
/**
|
||||
--- a/net/mac80211/tx.c
|
||||
+++ b/net/mac80211/tx.c
|
||||
@@ -1110,7 +1110,7 @@ ieee80211_tx_prepare(struct ieee80211_su
|
||||
tx->flags |= IEEE80211_TX_FRAGMENTED;
|
||||
|
||||
/* process and remove the injection radiotap header */
|
||||
- if (unlikely(info->flags & IEEE80211_TX_CTL_INJECTED)) {
|
||||
+ if (unlikely(info->flags & IEEE80211_TX_INTFL_HAS_RADIOTAP)) {
|
||||
if (!__ieee80211_parse_tx_radiotap(tx, skb))
|
||||
return TX_DROP;
|
||||
|
||||
@@ -1119,6 +1119,7 @@ ieee80211_tx_prepare(struct ieee80211_su
|
||||
* the radiotap header that was present and pre-filled
|
||||
* 'tx' with tx control information.
|
||||
*/
|
||||
+ info->flags &= ~IEEE80211_TX_INTFL_HAS_RADIOTAP;
|
||||
}
|
||||
|
||||
/*
|
||||
@@ -1501,7 +1502,8 @@ static void ieee80211_xmit(struct ieee80
|
||||
int hdrlen;
|
||||
u16 len_rthdr;
|
||||
|
||||
- info->flags |= IEEE80211_TX_CTL_INJECTED;
|
||||
+ info->flags |= IEEE80211_TX_CTL_INJECTED |
|
||||
+ IEEE80211_TX_INTFL_HAS_RADIOTAP;
|
||||
|
||||
len_rthdr = ieee80211_get_radiotap_len(skb->data);
|
||||
hdr = (struct ieee80211_hdr *)(skb->data + len_rthdr);
|
@ -1,37 +0,0 @@
|
||||
--- a/drivers/net/wireless/ath/ath9k/xmit.c
|
||||
+++ b/drivers/net/wireless/ath/ath9k/xmit.c
|
||||
@@ -1353,25 +1353,6 @@ static enum ath9k_pkt_type get_hw_packet
|
||||
return htype;
|
||||
}
|
||||
|
||||
-static bool is_pae(struct sk_buff *skb)
|
||||
-{
|
||||
- struct ieee80211_hdr *hdr;
|
||||
- __le16 fc;
|
||||
-
|
||||
- hdr = (struct ieee80211_hdr *)skb->data;
|
||||
- fc = hdr->frame_control;
|
||||
-
|
||||
- if (ieee80211_is_data(fc)) {
|
||||
- if (ieee80211_is_nullfunc(fc) ||
|
||||
- /* Port Access Entity (IEEE 802.1X) */
|
||||
- (skb->protocol == cpu_to_be16(ETH_P_PAE))) {
|
||||
- return true;
|
||||
- }
|
||||
- }
|
||||
-
|
||||
- return false;
|
||||
-}
|
||||
-
|
||||
static int get_hw_crypto_keytype(struct sk_buff *skb)
|
||||
{
|
||||
struct ieee80211_tx_info *tx_info = IEEE80211_SKB_CB(skb);
|
||||
@@ -1610,7 +1591,7 @@ static int ath_tx_setup_buffer(struct ie
|
||||
bf->bf_frmlen -= padsize;
|
||||
}
|
||||
|
||||
- if (conf_is_ht(&hw->conf) && !is_pae(skb))
|
||||
+ if (conf_is_ht(&hw->conf))
|
||||
bf->bf_state.bf_type |= BUF_HT;
|
||||
|
||||
bf->bf_flags = setup_tx_flags(sc, skb, txctl->txq);
|
@ -1,11 +0,0 @@
|
||||
--- a/net/mac80211/tx.c
|
||||
+++ b/net/mac80211/tx.c
|
||||
@@ -1135,6 +1135,8 @@ ieee80211_tx_prepare(struct ieee80211_su
|
||||
tx->sta = rcu_dereference(sdata->u.vlan.sta);
|
||||
if (!tx->sta && sdata->dev->ieee80211_ptr->use_4addr)
|
||||
return TX_DROP;
|
||||
+ } else if (info->flags & IEEE80211_TX_CTL_INJECTED) {
|
||||
+ tx->sta = sta_info_get_bss(sdata, hdr->addr1);
|
||||
}
|
||||
if (!tx->sta)
|
||||
tx->sta = sta_info_get(sdata, hdr->addr1);
|
Loading…
Reference in New Issue
Block a user