1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-10-04 02:38:12 +03:00

[mac80211] remove pcmcia and sdio

This fixes #6701

Remove the pcmcia and sdio interface from b43 driver to not depend on these modules.


git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19756 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
hauke 2010-02-19 15:41:55 +00:00
parent e850d545e6
commit 5608c64b51
4 changed files with 34 additions and 3 deletions

View File

@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=mac80211
PKG_VERSION:=2010-02-16
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
# http://www.orbit-lab.org/kernel/compat-wireless-2.6/2010/11 \
# http://wireless.kernel.org/download/compat-wireless-2.6

View File

@ -5,7 +5,25 @@
CONFIG_PCI=y
CONFIG_USB=y
- CONFIG_PCMCIA=y
+ # CONFIG_PCMCIA=y
+# CONFIG_PCMCIA=y
CONFIG_SSB=m
else
include $(KLIB_BUILD)/.config
@@ -197,7 +197,7 @@ CONFIG_B43=m
CONFIG_B43_HWRNG=y
CONFIG_B43_PCI_AUTOSELECT=y
ifneq ($(CONFIG_PCMCIA),)
-CONFIG_B43_PCMCIA=y
+# CONFIG_B43_PCMCIA=y
endif
CONFIG_B43_LEDS=y
CONFIG_B43_PHY_LP=y
@@ -248,7 +248,7 @@ CONFIG_SSB_BLOCKIO=y
CONFIG_SSB_PCIHOST=y
CONFIG_SSB_B43_PCI_BRIDGE=y
ifneq ($(CONFIG_PCMCIA),)
-CONFIG_SSB_PCMCIAHOST=y
+# CONFIG_SSB_PCMCIAHOST=y
endif
# CONFIG_SSB_DEBUG=y
CONFIG_SSB_DRIVER_PCICORE=y

View File

@ -0,0 +1,13 @@
--- a/config.mk
+++ b/config.mk
@@ -382,8 +382,8 @@ endif # end of SPI driver list
ifneq ($(CONFIG_MMC),)
-CONFIG_SSB_SDIOHOST=y
-CONFIG_B43_SDIO=y
+# CONFIG_SSB_SDIOHOST=y
+# CONFIG_B43_SDIO=y
CONFIG_WL1251_SDIO=m
ifdef CONFIG_COMPAT_KERNEL_27

View File

@ -1,6 +1,6 @@
--- a/net/wireless/nl80211.c
+++ b/net/wireless/nl80211.c
@@ -5667,7 +5667,11 @@
@@ -5662,7 +5662,11 @@ int nl80211_send_action(struct cfg80211_
return err;
}