mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-27 16:10:39 +02:00
[package] opkg: only select overlay_root if the install destination is root, this eliminates the need for force_space when using external destinations like usb disks
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18884 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
f790b2a225
commit
5e52855bff
@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
|
||||
PKG_NAME:=opkg
|
||||
PKG_REV:=503
|
||||
PKG_VERSION:=$(PKG_REV)
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE_PROTO:=svn
|
||||
PKG_SOURCE_VERSION:=$(PKG_REV)
|
||||
|
@ -26,17 +26,26 @@ Signed-off-by: Nicolas Thill <nico@openwrt.org>
|
||||
int noaction;
|
||||
--- a/libopkg/opkg_install.c
|
||||
+++ b/libopkg/opkg_install.c
|
||||
@@ -194,8 +194,11 @@
|
||||
@@ -189,13 +189,19 @@
|
||||
verify_pkg_installable(pkg_t *pkg)
|
||||
{
|
||||
unsigned long kbs_available, pkg_size_kbs;
|
||||
- char *root_dir;
|
||||
+ char *root_dir = NULL;
|
||||
|
||||
if (conf->force_space || pkg->installed_size == 0)
|
||||
return 0;
|
||||
|
||||
- root_dir = pkg->dest ? pkg->dest->root_dir :
|
||||
- conf->default_dest->root_dir;
|
||||
+ root_dir = pkg->dest
|
||||
+ ? pkg->dest->root_dir
|
||||
+ : conf->overlay_root
|
||||
+ ? conf->overlay_root
|
||||
+ : conf->default_dest->root_dir;
|
||||
+ if( !pkg->dest || !strcmp(pkg->dest->name, "root") )
|
||||
+ root_dir = conf->overlay_root;
|
||||
+ else
|
||||
+ root_dir = pkg->dest->root_dir;
|
||||
+
|
||||
+ if( !root_dir )
|
||||
+ root_dir = conf->default_dest->root_dir;
|
||||
+
|
||||
kbs_available = get_available_kbytes(root_dir);
|
||||
|
||||
pkg_size_kbs = (pkg->installed_size + 1023)/1024;
|
||||
|
Loading…
Reference in New Issue
Block a user