1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-04 21:34:32 +03:00

update openssl to 0.9.8

git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3265 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
mbm 2006-02-23 00:33:09 +00:00
parent 6152dc565b
commit 5ed5b75f5c
4 changed files with 20 additions and 46 deletions

View File

@ -3,9 +3,9 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=openssl
PKG_VERSION:=0.9.7i
PKG_VERSION:=0.9.8a
PKG_RELEASE:=1
PKG_MD5SUM:=f69d82b206ff8bff9d0e721f97380b9e
PKG_MD5SUM:=1d16c727c10185e4d694f87f5e424ee1
PKG_SOURCE_URL:=http://www.openssl.org/source/ \
ftp://ftp.funet.fi/pub/crypt/cryptography/libs/openssl/source/ \
@ -28,7 +28,7 @@ $(PKG_BUILD_DIR)/.configured:
$(SED) 's,/CFLAG=,/CFLAG= $(TARGET_SOFT_FLOAT) ,g' $(PKG_BUILD_DIR)/Configure
(cd $(PKG_BUILD_DIR); \
PATH=$(TARGET_PATH) \
./Configure linux-$(ARCH) \
./Configure linux-generic32 \
--prefix=/usr \
--openssldir=/etc/ssl \
-I$(STAGING_DIR)/usr/include \

View File

@ -1,15 +1,11 @@
diff -Nur openssl-0.9.7g/Configure openssl-0.9.7g-Os/Configure
--- openssl-0.9.7g/Configure 2005-04-07 18:06:01.000000000 +0200
+++ openssl-0.9.7g-Os/Configure 2005-05-01 00:13:09.000000000 +0200
@@ -401,8 +401,9 @@
"debug-linux-elf","gcc:-DBN_DEBUG -DREF_CHECK -DCONF_DEBUG -DBN_CTX_DEBUG -DCRYPTO_MDEBUG -DL_ENDIAN -DTERMIO -g -m486 -Wall::-D_REENTRANT::-lefence -ldl:BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_elf_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
"debug-linux-elf-noefence","gcc:-DBN_DEBUG -DREF_CHECK -DCONF_DEBUG -DBN_CTX_DEBUG -DCRYPTO_MDEBUG -DL_ENDIAN -DTERMIO -g -m486 -Wall::-D_REENTRANT::-ldl:BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_elf_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
"linux-aout", "gcc:-DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -m486 -Wall::(unknown):::BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_out_asm}",
-"linux-mipsel", "gcc:-DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL DES_RISC2::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
-"linux-mips", "gcc:-DB_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL DES_RISC2::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+"linux-mipsel", "gcc:-DL_ENDIAN -DTERMIO \$(CCOPTS) -Wall::-D_REENTRANT::-ldl:BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL DES_RISC2::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+"linux-mips", "gcc:-DB_ENDIAN -DTERMIO \$(CCOPTS) -Wall::-D_REENTRANT::-ldl:BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL DES_RISC2::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+"linux-i386", "gcc:-DL_ENDIAN -DTERMIO \$(CCOPTS) -Wall::-D_REENTRANT::-ldl:BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_elf_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
"linux-ppc", "gcc:-DB_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC4_CHAR RC4_CHUNK DES_RISC1 DES_UNROLL:asm/linux_ppc32.o:::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
# -bpowerpc64-linux is transient option, -m64 should be the one to use...
"linux-ppc64", "gcc:-bpowerpc64-linux -DB_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC4_CHAR RC4_CHUNK DES_RISC1 DES_UNROLL:asm/linux_ppc64.o:::::::::dlfcn:linux-shared:-fPIC:-bpowerpc64-linux:.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
--- openssl-0.9.8a/Configure 2006-02-21 20:18:36.000000000 -0800
+++ openssl-0.9.8a-new/Configure 2006-02-21 20:53:32.000000000 -0800
@@ -313,7 +313,7 @@
####
# *-generic* is endian-neutral target, but ./config is free to
# throw in -D[BL]_ENDIAN, whichever appropriate...
-"linux-generic32","gcc:-DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC4_CHAR RC4_CHUNK DES_INT DES_UNROLL BF_PTR:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+"linux-generic32","gcc:-DTERMIO -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC4_CHAR RC4_CHUNK DES_INT DES_UNROLL BF_PTR:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
"linux-ppc", "gcc:-DB_ENDIAN -DTERMIO -O3 -Wall::-D_REENTRANT::-ldl:BN_LLONG RC4_CHAR RC4_CHUNK DES_RISC1 DES_UNROLL::linux_ppc32.o::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
#### IA-32 targets...
"linux-ia32-icc", "icc:-DL_ENDIAN -DTERMIO -O2 -no_cpprt::-D_REENTRANT::-ldl:BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_elf_asm}:dlfcn:linux-shared:-KPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",

View File

@ -1,11 +1,10 @@
diff -Nur openssl-0.9.7f/Makefile.org openssl-0.9.7f.new/Makefile.org
--- openssl-0.9.7f/Makefile.org 2005-03-15 10:46:13.000000000 +0100
+++ openssl-0.9.7f.new/Makefile.org 2005-04-03 20:15:26.000000000 +0200
@@ -175,7 +175,7 @@
# we might set SHLIB_MARK to '$(SHARED_LIBS)'.
SHLIB_MARK=
--- openssl-0.9.8a/Makefile.org 2006-02-21 20:57:45.000000000 -0800
+++ openssl-0.9.8a-new/Makefile.org 2006-02-21 21:37:11.000000000 -0800
@@ -100,7 +100,7 @@
KRB5_INCLUDES=
LIBKRB5=
-DIRS= crypto fips ssl $(SHLIB_MARK) sigs apps test tools
-DIRS= crypto ssl engines apps test tools
+DIRS= crypto ssl apps
SHLIBDIRS= crypto ssl

View File

@ -1,21 +0,0 @@
diff -ruN openssl-0.9.7h-old/Makefile.org openssl-0.9.7h-new/Makefile.org
--- openssl-0.9.7h-old/Makefile.org 2005-10-12 23:12:38.000000000 +0200
+++ openssl-0.9.7h-new/Makefile.org 2005-10-12 23:13:38.000000000 +0200
@@ -230,7 +230,6 @@
libcrypto.a.sha1: libcrypto.a
@if egrep 'define OPENSSL_FIPS' $(TOP)/include/openssl/opensslconf.h > /dev/null; then \
$(RANLIB) libcrypto.a; \
- fips/sha/fips_standalone_sha1 libcrypto.a > libcrypto.a.sha1; \
fi
sub_all:
@@ -258,9 +257,6 @@
libcrypto$(SHLIB_EXT): libcrypto.a
@if [ "$(SHLIB_TARGET)" != "" ]; then \
$(MAKE) SHLIBDIRS=crypto build-shared; \
- if egrep 'define OPENSSL_FIPS' $(TOP)/include/openssl/opensslconf.h > /dev/null; then \
- fips/sha/fips_standalone_sha1 -binary $@ > $@.$${HMAC_EXT:-sha1}; \
- fi; \
else \
echo "There's no support for shared libraries on this platform" >&2; \
fi