mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-24 01:37:10 +02:00
generic: rtl8366_smi: rename debugfs Kconfig symbol
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31915 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
5a1c605a9e
commit
63d3e3114d
@ -2305,8 +2305,8 @@ CONFIG_RTC_LIB=y
|
||||
# CONFIG_RTL8306_PHY is not set
|
||||
# CONFIG_RTL8366RB_PHY is not set
|
||||
# CONFIG_RTL8366S_PHY is not set
|
||||
# CONFIG_RTL8366S_PHY_DEBUG_FS is not set
|
||||
# CONFIG_RTL8366_SMI is not set
|
||||
# CONFIG_RTL8366_SMI_DEBUG_FS is not set
|
||||
# CONFIG_RTL8367_PHY is not set
|
||||
# CONFIG_RTS_PSTOR is not set
|
||||
CONFIG_RT_MUTEXES=y
|
||||
|
@ -17,7 +17,7 @@
|
||||
#include <linux/skbuff.h>
|
||||
#include <linux/rtl8366.h>
|
||||
|
||||
#ifdef CONFIG_RTL8366S_PHY_DEBUG_FS
|
||||
#ifdef CONFIG_RTL8366_SMI_DEBUG_FS
|
||||
#include <linux/debugfs.h>
|
||||
#endif
|
||||
|
||||
@ -579,7 +579,7 @@ static int rtl8366_init_vlan(struct rtl8366_smi *smi)
|
||||
return rtl8366_enable_vlan(smi, 1);
|
||||
}
|
||||
|
||||
#ifdef CONFIG_RTL8366S_PHY_DEBUG_FS
|
||||
#ifdef CONFIG_RTL8366_SMI_DEBUG_FS
|
||||
int rtl8366_debugfs_open(struct inode *inode, struct file *file)
|
||||
{
|
||||
file->private_data = inode->i_private;
|
||||
@ -890,7 +890,7 @@ static void rtl8366_debugfs_remove(struct rtl8366_smi *smi)
|
||||
#else
|
||||
static inline void rtl8366_debugfs_init(struct rtl8366_smi *smi) {}
|
||||
static inline void rtl8366_debugfs_remove(struct rtl8366_smi *smi) {}
|
||||
#endif /* CONFIG_RTL8366S_PHY_DEBUG_FS */
|
||||
#endif /* CONFIG_RTL8366_SMI_DEBUG_FS */
|
||||
|
||||
static int rtl8366_smi_mii_init(struct rtl8366_smi *smi)
|
||||
{
|
||||
|
@ -52,7 +52,7 @@ struct rtl8366_smi {
|
||||
int vlan4k_enabled;
|
||||
|
||||
char buf[4096];
|
||||
#ifdef CONFIG_RTL8366S_PHY_DEBUG_FS
|
||||
#ifdef CONFIG_RTL8366_SMI_DEBUG_FS
|
||||
struct dentry *debugfs_root;
|
||||
u16 dbg_reg;
|
||||
u8 dbg_vlan_4k_page;
|
||||
@ -112,7 +112,7 @@ int rtl8366_reset_vlan(struct rtl8366_smi *smi);
|
||||
int rtl8366_enable_vlan(struct rtl8366_smi *smi, int enable);
|
||||
int rtl8366_enable_all_ports(struct rtl8366_smi *smi, int enable);
|
||||
|
||||
#ifdef CONFIG_RTL8366S_PHY_DEBUG_FS
|
||||
#ifdef CONFIG_RTL8366_SMI_DEBUG_FS
|
||||
int rtl8366_debugfs_open(struct inode *inode, struct file *file);
|
||||
#endif
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/drivers/net/phy/Kconfig
|
||||
+++ b/drivers/net/phy/Kconfig
|
||||
@@ -168,6 +168,31 @@ config MDIO_OCTEON
|
||||
@@ -168,6 +168,30 @@ config MDIO_OCTEON
|
||||
|
||||
If in doubt, say Y.
|
||||
|
||||
@ -13,6 +13,11 @@
|
||||
+
|
||||
+if RTL8366_SMI
|
||||
+
|
||||
+config RTL8366_SMI_DEBUG_FS
|
||||
+ bool "RTL8366 SMI interface debugfs support"
|
||||
+ depends on DEBUG_FS
|
||||
+ default n
|
||||
+
|
||||
+config RTL8366S_PHY
|
||||
+ tristate "Driver for the Realtek RTL8366S switch"
|
||||
+ select SWCONFIG
|
||||
@ -21,12 +26,6 @@
|
||||
+ tristate "Driver for the Realtek RTL8366RB switch"
|
||||
+ select SWCONFIG
|
||||
+
|
||||
+config RTL8366S_PHY_DEBUG_FS
|
||||
+ bool "RTL8366 switch driver DEBUG_FS support"
|
||||
+ depends on RTL8366S_PHY || RTL8366RB_PHY
|
||||
+ depends on DEBUG_FS
|
||||
+ default n
|
||||
+
|
||||
+endif # RTL8366_SMI
|
||||
+
|
||||
endif # PHYLIB
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/drivers/net/phy/Kconfig
|
||||
+++ b/drivers/net/phy/Kconfig
|
||||
@@ -185,6 +185,10 @@ config RTL8366RB_PHY
|
||||
@@ -190,6 +190,10 @@ config RTL8366RB_PHY
|
||||
tristate "Driver for the Realtek RTL8366RB switch"
|
||||
select SWCONFIG
|
||||
|
||||
@ -8,9 +8,9 @@
|
||||
+ tristate "Driver for the Realtek RTL8367R/M switches"
|
||||
+ select SWCONFIG
|
||||
+
|
||||
config RTL8366S_PHY_DEBUG_FS
|
||||
bool "RTL8366 switch driver DEBUG_FS support"
|
||||
depends on RTL8366S_PHY || RTL8366RB_PHY
|
||||
endif # RTL8366_SMI
|
||||
|
||||
endif # PHYLIB
|
||||
--- a/drivers/net/phy/Makefile
|
||||
+++ b/drivers/net/phy/Makefile
|
||||
@@ -25,6 +25,7 @@ obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
|
||||
|
Loading…
Reference in New Issue
Block a user