1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-04 21:42:01 +03:00

make uclibc a bit smaller

git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2219 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nbd 2005-10-21 23:39:26 +00:00
parent be49e4aef8
commit 68aef69e6a
3 changed files with 14 additions and 2 deletions

View File

@ -57,7 +57,7 @@ ARCH_LITTLE_ENDIAN=y
ARCH_HAS_MMU=y
UCLIBC_HAS_FLOATS=y
HAS_FPU=y
DO_C99_MATH=y
# DO_C99_MATH is not set
KERNEL_SOURCE="./toolchain_build_i386/linux"
C_SYMBOL_PREFIX=""
HAVE_DOT_CONFIG=y

View File

@ -42,7 +42,7 @@ ARCH_LITTLE_ENDIAN=y
ARCH_HAS_MMU=y
UCLIBC_HAS_FLOATS=y
HAS_FPU=y
DO_C99_MATH=y
# DO_C99_MATH is not set
KERNEL_SOURCE="./toolchain_build_mipsel/linux"
C_SYMBOL_PREFIX=""
HAVE_DOT_CONFIG=y

View File

@ -0,0 +1,12 @@
diff -urN uClibc.old/libm/Makefile uClibc.dev/libm/Makefile
--- uClibc.old/libm/Makefile 2005-08-18 00:49:41.000000000 +0200
+++ uClibc.dev/libm/Makefile 2005-10-22 00:56:03.106683500 +0200
@@ -81,6 +81,8 @@
w_cosh.c w_exp.c s_fabs.c s_floor.c w_fmod.c s_frexp.c \
s_ldexp.c w_log.c w_log10.c s_modf.c w_pow.c s_sin.c \
w_sinh.c w_sqrt.c s_tan.c s_tanh.c
+# extra stuff required for some apps
+CSRC+= fpmacros.c nan.c s_rint.c e_hypot.c w_hypot.c
CSRC+= s_expm1.c s_scalbn.c s_copysign.c e_acos.c e_asin.c e_atan2.c \
k_cos.c e_cosh.c e_exp.c e_fmod.c e_log.c e_log10.c e_pow.c \
k_sin.c e_sinh.c e_sqrt.c k_tan.c e_rem_pio2.c k_rem_pio2.c \