1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-04 21:34:32 +03:00

remove support for the madwifi upstream release, it doesn't work on newer kernels and it's not very reliable anyway

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17315 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nbd 2009-08-19 15:16:11 +00:00
parent 0efdde7bb2
commit 71d6652e39
4 changed files with 14 additions and 67 deletions

View File

@ -23,11 +23,6 @@ choice
config MADWIFI_STABLE
bool "Use the OpenWrt stable version of madwifi"
config MADWIFI_UPSTREAM
depends BROKEN
depends !TARGET_atheros
bool "Use the upstream release version 0.9.4"
endchoice
config MADWIFI_SINGLE_MODULE

View File

@ -10,33 +10,17 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=madwifi
ifneq ($(CONFIG_MADWIFI_UPSTREAM),)
PKG_VERSION:=0.9.4
PKG_RELEASE:=2
PKG_REV:=3314
PKG_VERSION:=r$(PKG_REV)
PKG_RELEASE:=2
PKG_SOURCE:=madwifi-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/madwifi
PKG_MD5SUM:=399d20de8d855a59f20058857c2178ad
PKG_SOURCE_PROTO:=svn
PKG_SOURCE_VERSION:=$(PKG_REV)
PKG_SOURCE_SUBDIR:=$(if $(PKG_BRANCH),$(PKG_BRANCH),madwifi-trunk)-$(PKG_VERSION)
PKG_SOURCE_URL:=http://madwifi-project.org/svn/madwifi/$(if $(PKG_BRANCH),branches/$(PKG_BRANCH),trunk)
PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/madwifi-$(PKG_VERSION)
PATCH_DIR=./patches-upstream
else
# PKG_BRANCH:=madwifi-dfs
PKG_REV:=3314
PKG_VERSION:=r$(PKG_REV)
PKG_RELEASE:=2
PKG_SOURCE_PROTO:=svn
PKG_SOURCE_VERSION:=$(PKG_REV)
PKG_SOURCE_SUBDIR:=$(if $(PKG_BRANCH),$(PKG_BRANCH),madwifi-trunk)-$(PKG_VERSION)
PKG_SOURCE_URL:=http://madwifi-project.org/svn/madwifi/$(if $(PKG_BRANCH),branches/$(PKG_BRANCH),trunk)
PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(if $(PKG_BRANCH),$(PKG_BRANCH),madwifi-trunk)-$(PKG_VERSION)
PATCH_DIR=./patches
endif
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(if $(PKG_BRANCH),$(PKG_BRANCH),madwifi-trunk)-$(PKG_VERSION)
HAL_VERSION:=20090508
HAL_FILE:=ath_hal-$(HAL_VERSION).tgz
@ -77,10 +61,10 @@ ifneq ($(CONFIG_CPU_MIPS32_R2),)
endif
else
ifeq ($(ARCH),mips)
HAL_TARGET:=$(if $(CONFIG_MADWIFI_UPSTREAM),mips-be-elf,mips32-be-elf)
HAL_TARGET:=mips32-be-elf
endif
ifeq ($(ARCH),mipsel)
HAL_TARGET:=$(if $(CONFIG_MADWIFI_UPSTREAM),mips-le-elf,mips32-le-elf)
HAL_TARGET:=mips32-le-elf
endif
endif
ifeq ($(ARCH),i386)
@ -165,13 +149,10 @@ ifeq ($(findstring PCI,$(BUS)),PCI)
MADWIFI_AUTOLOAD+= ath_pci
endif
MADWIFI_APPLETS:=80211stats athchans athkey athstats wlanconfig ath_info
MADWIFI_APPLETS:=80211stats athchans athkey athstats wlanconfig ath_info madwifi_multi
ifdef CONFIG_MADWIFI_DEBUG
MADWIFI_APPLETS += athdebug 80211debug
endif
ifndef CONFIG_MADWIFI_UPSTREAM
MADWIFI_APPLETS += madwifi_multi
endif
define KernelPackage/madwifi
SUBMENU:=Wireless Drivers
@ -220,15 +201,13 @@ MAKE_ARGS:= \
MAKE_VARS:= \
COPTS="-DATH_REVERSE_ENGINEERING=1" \
ifeq ($(CONFIG_MADWIFI_UPSTREAM),)
define Build/Prepare/HAL
define Build/Prepare/HAL
rm -rf $(PKG_BUILD_DIR)/tmp
mkdir -p $(PKG_BUILD_DIR)/tmp
tar xvzf $(DL_DIR)/$(HAL_FILE) -C $(PKG_BUILD_DIR)/tmp
$(CP) $(PKG_BUILD_DIR)/tmp/ath_hal*/* $(PKG_BUILD_DIR)/hal/
rm -rf $(PKG_BUILD_DIR)/tmp
endef
endif
endef
define Build/Prepare
$(call Build/Prepare/Default)

View File

@ -1,13 +0,0 @@
Index: madwifi-0.9.4/ath/if_ath.c
===================================================================
--- madwifi-0.9.4.old/ath/if_ath.c 2008-02-13 06:13:10.000000000 +0100
+++ madwifi-0.9.4/ath/if_ath.c 2008-05-06 10:25:15.000000000 +0200
@@ -404,7 +404,7 @@
struct ath_hal *ah;
HAL_STATUS status;
int error = 0, i;
- int autocreatemode = IEEE80211_M_STA;
+ int autocreatemode = -1;
u_int8_t csz;
sc->devid = devid;

View File

@ -1,14 +0,0 @@
Index: madwifi-0.9.4/ath_rate/minstrel/minstrel.c
===================================================================
--- madwifi-0.9.4.old/ath_rate/minstrel/minstrel.c 2007-12-12 05:11:07.000000000 +0100
+++ madwifi-0.9.4/ath_rate/minstrel/minstrel.c 2008-07-24 15:15:41.000000000 +0200
@@ -394,6 +394,9 @@
int rc1, rc2, rc3; /* Index into the rate table, so for example, it is 0..11 */
int rixc1, rixc2, rixc3; /* The actual bit rate used */
+ if (sn->num_rates <= 0)
+ return;
+
if (sn->is_sampling) {
sn->is_sampling = 0;
if (sn->rs_sample_rate_slower)