mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-23 23:46:16 +02:00
upgrade x86 to 2.6.31.6, resync patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18609 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
8d2137b93d
commit
785fefeaea
@ -22,8 +22,8 @@ endif
|
||||
ifeq ($(LINUX_VERSION),2.6.30.9)
|
||||
LINUX_KERNEL_MD5SUM:=5a4cd5543a9d7c1a819700b21be31ef1
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),2.6.31.5)
|
||||
LINUX_KERNEL_MD5SUM:=926bff46d24e2f303e4ee92234e394d8
|
||||
ifeq ($(LINUX_VERSION),2.6.31.6)
|
||||
LINUX_KERNEL_MD5SUM:=485472df88af84becdcf47f45de3ba46
|
||||
endif
|
||||
|
||||
# disable the md5sum check for unknown kernel versions
|
||||
|
@ -122,7 +122,7 @@
|
||||
+
|
||||
--- a/arch/mips/kernel/Makefile
|
||||
+++ b/arch/mips/kernel/Makefile
|
||||
@@ -85,6 +85,7 @@ obj-$(CONFIG_GPIO_TXX9) += gpio_txx9.o
|
||||
@@ -87,6 +87,7 @@ obj-$(CONFIG_GPIO_TXX9) += gpio_txx9.o
|
||||
|
||||
obj-$(CONFIG_KEXEC) += machine_kexec.o relocate_kernel.o
|
||||
obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
|
||||
|
@ -1,35 +1,11 @@
|
||||
--- a/arch/mips/kernel/Makefile
|
||||
+++ b/arch/mips/kernel/Makefile
|
||||
@@ -2,6 +2,8 @@
|
||||
# Makefile for the Linux/MIPS kernel.
|
||||
#
|
||||
@@ -4,6 +4,8 @@
|
||||
|
||||
CPPFLAGS_vmlinux.lds := $(KBUILD_CFLAGS)
|
||||
|
||||
+CPPFLAGS_vmlinux.lds := $(KBUILD_CFLAGS) $(EXTRA_LDSFLAGS)
|
||||
+
|
||||
extra-y := head.o init_task.o vmlinux.lds
|
||||
|
||||
obj-y += cpu-probe.o branch.o entry.o genex.o irq.o process.o \
|
||||
--- a/arch/mips/kernel/vmlinux.lds.S
|
||||
+++ b/arch/mips/kernel/vmlinux.lds.S
|
||||
@@ -10,15 +10,15 @@ PHDRS {
|
||||
note PT_NOTE FLAGS(4); /* R__ */
|
||||
}
|
||||
|
||||
-ifdef CONFIG_32BIT
|
||||
- ifdef CONFIG_CPU_LITTLE_ENDIAN
|
||||
+#ifdef CONFIG_32BIT
|
||||
+ #ifdef CONFIG_CPU_LITTLE_ENDIAN
|
||||
jiffies = jiffies_64;
|
||||
- else
|
||||
+ #else
|
||||
jiffies = jiffies_64 + 4;
|
||||
- endif
|
||||
-else
|
||||
+ #endif
|
||||
+#else
|
||||
jiffies = jiffies_64;
|
||||
-endif
|
||||
+#endif
|
||||
|
||||
SECTIONS
|
||||
{
|
||||
|
@ -48,8 +48,6 @@ Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
|
||||
include/linux/unaligned/le_byteshift.h | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/include/linux/unaligned/be_byteshift.h b/include/linux/unaligned/be_byteshift.h
|
||||
index 46dd12c..9356b24 100644
|
||||
--- a/include/linux/unaligned/be_byteshift.h
|
||||
+++ b/include/linux/unaligned/be_byteshift.h
|
||||
@@ -1,7 +1,7 @@
|
||||
@ -61,8 +59,6 @@ index 46dd12c..9356b24 100644
|
||||
|
||||
static inline u16 __get_unaligned_be16(const u8 *p)
|
||||
{
|
||||
diff --git a/include/linux/unaligned/le_byteshift.h b/include/linux/unaligned/le_byteshift.h
|
||||
index 59777e9..be376fb 100644
|
||||
--- a/include/linux/unaligned/le_byteshift.h
|
||||
+++ b/include/linux/unaligned/le_byteshift.h
|
||||
@@ -1,7 +1,7 @@
|
||||
@ -74,6 +70,3 @@ index 59777e9..be376fb 100644
|
||||
|
||||
static inline u16 __get_unaligned_le16(const u8 *p)
|
||||
{
|
||||
--
|
||||
1.6.5.1
|
||||
|
||||
|
@ -1,6 +1,3 @@
|
||||
diff --git a/include/linux/decompress/unlzo.h b/include/linux/decompress/unlzo.h
|
||||
new file mode 100644
|
||||
index 0000000..9872297
|
||||
--- /dev/null
|
||||
+++ b/include/linux/decompress/unlzo.h
|
||||
@@ -0,0 +1,10 @@
|
||||
@ -14,8 +11,6 @@ index 0000000..9872297
|
||||
+ int *pos,
|
||||
+ void(*error)(char *x));
|
||||
+#endif
|
||||
diff --git a/init/Kconfig b/init/Kconfig
|
||||
index f515864..eb65318 100644
|
||||
--- a/init/Kconfig
|
||||
+++ b/init/Kconfig
|
||||
@@ -115,10 +115,13 @@ config HAVE_KERNEL_BZIP2
|
||||
@ -60,9 +55,6 @@ index f515864..eb65318 100644
|
||||
endchoice
|
||||
|
||||
config SWAP
|
||||
diff --git a/lib/decompress_unlzo.c b/lib/decompress_unlzo.c
|
||||
new file mode 100644
|
||||
index 0000000..2bb736f
|
||||
--- /dev/null
|
||||
+++ b/lib/decompress_unlzo.c
|
||||
@@ -0,0 +1,208 @@
|
||||
@ -274,8 +266,6 @@ index 0000000..2bb736f
|
||||
+}
|
||||
+
|
||||
+#define decompress unlzo
|
||||
diff --git a/lib/lzo/lzo1x_decompress.c b/lib/lzo/lzo1x_decompress.c
|
||||
index 5dc6b29..f2fd098 100644
|
||||
--- a/lib/lzo/lzo1x_decompress.c
|
||||
+++ b/lib/lzo/lzo1x_decompress.c
|
||||
@@ -11,11 +11,13 @@
|
||||
@ -306,8 +296,6 @@ index 5dc6b29..f2fd098 100644
|
||||
MODULE_DESCRIPTION("LZO1X Decompressor");
|
||||
|
||||
+#endif
|
||||
diff --git a/scripts/Makefile.lib b/scripts/Makefile.lib
|
||||
index ffdafb2..39c3483 100644
|
||||
--- a/scripts/Makefile.lib
|
||||
+++ b/scripts/Makefile.lib
|
||||
@@ -230,3 +230,8 @@ quiet_cmd_lzma = LZMA $@
|
||||
|
@ -1,5 +1,3 @@
|
||||
diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
|
||||
index 1c4119c..350921d 100644
|
||||
--- a/arch/arm/Kconfig
|
||||
+++ b/arch/arm/Kconfig
|
||||
@@ -18,6 +18,8 @@ config ARM
|
||||
@ -11,8 +9,6 @@ index 1c4119c..350921d 100644
|
||||
help
|
||||
The ARM series is a line of low-power-consumption RISC chip designs
|
||||
licensed by ARM Ltd and targeted at embedded applications and
|
||||
diff --git a/arch/arm/boot/compressed/Makefile b/arch/arm/boot/compressed/Makefile
|
||||
index ce39dc5..5b4629b 100644
|
||||
--- a/arch/arm/boot/compressed/Makefile
|
||||
+++ b/arch/arm/boot/compressed/Makefile
|
||||
@@ -63,8 +63,12 @@ endif
|
||||
@ -69,8 +65,6 @@ index ce39dc5..5b4629b 100644
|
||||
|
||||
CFLAGS_font.o := -Dstatic=
|
||||
|
||||
diff --git a/arch/arm/boot/compressed/misc.c b/arch/arm/boot/compressed/misc.c
|
||||
index 17153b5..7e0fe4d 100644
|
||||
--- a/arch/arm/boot/compressed/misc.c
|
||||
+++ b/arch/arm/boot/compressed/misc.c
|
||||
@@ -18,10 +18,15 @@
|
||||
@ -89,7 +83,7 @@ index 17153b5..7e0fe4d 100644
|
||||
|
||||
#ifdef STANDALONE_DEBUG
|
||||
#define putstr printf
|
||||
@@ -188,34 +193,8 @@ static inline __ptr_t memcpy(__ptr_t __dest, __const __ptr_t __src,
|
||||
@@ -188,34 +193,8 @@ static inline __ptr_t memcpy(__ptr_t __d
|
||||
/*
|
||||
* gzip delarations
|
||||
*/
|
||||
@ -124,7 +118,7 @@ index 17153b5..7e0fe4d 100644
|
||||
/* Diagnostic functions */
|
||||
#ifdef DEBUG
|
||||
# define Assert(cond,msg) {if(!(cond)) error(msg);}
|
||||
@@ -233,24 +212,20 @@ static unsigned outcnt; /* bytes in output buffer */
|
||||
@@ -233,24 +212,20 @@ static unsigned outcnt; /* bytes in out
|
||||
# define Tracecv(c,x)
|
||||
#endif
|
||||
|
||||
@ -260,9 +254,6 @@ index 17153b5..7e0fe4d 100644
|
||||
}
|
||||
#endif
|
||||
-
|
||||
diff --git a/arch/arm/boot/compressed/piggy.S b/arch/arm/boot/compressed/piggy.S
|
||||
deleted file mode 100644
|
||||
index 54c9518..0000000
|
||||
--- a/arch/arm/boot/compressed/piggy.S
|
||||
+++ /dev/null
|
||||
@@ -1,6 +0,0 @@
|
||||
@ -272,9 +263,6 @@ index 54c9518..0000000
|
||||
- .incbin "arch/arm/boot/compressed/piggy.gz"
|
||||
- .globl input_data_end
|
||||
-input_data_end:
|
||||
diff --git a/arch/arm/boot/compressed/piggy.gzip.S b/arch/arm/boot/compressed/piggy.gzip.S
|
||||
new file mode 100644
|
||||
index 0000000..a68adf9
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/compressed/piggy.gzip.S
|
||||
@@ -0,0 +1,6 @@
|
||||
@ -284,9 +272,6 @@ index 0000000..a68adf9
|
||||
+ .incbin "arch/arm/boot/compressed/piggy.gzip"
|
||||
+ .globl input_data_end
|
||||
+input_data_end:
|
||||
diff --git a/arch/arm/boot/compressed/piggy.lzo.S b/arch/arm/boot/compressed/piggy.lzo.S
|
||||
new file mode 100644
|
||||
index 0000000..a425ad9
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/compressed/piggy.lzo.S
|
||||
@@ -0,0 +1,6 @@
|
||||
|
@ -1,5 +1,3 @@
|
||||
diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig
|
||||
index 72ace95..89f7771 100644
|
||||
--- a/arch/x86/Kconfig
|
||||
+++ b/arch/x86/Kconfig
|
||||
@@ -49,6 +49,7 @@ config X86
|
||||
@ -10,8 +8,6 @@ index 72ace95..89f7771 100644
|
||||
select HAVE_ARCH_KMEMCHECK
|
||||
|
||||
config OUTPUT_FORMAT
|
||||
diff --git a/arch/x86/boot/compressed/Makefile b/arch/x86/boot/compressed/Makefile
|
||||
index f8ed065..0e835d0 100644
|
||||
--- a/arch/x86/boot/compressed/Makefile
|
||||
+++ b/arch/x86/boot/compressed/Makefile
|
||||
@@ -4,7 +4,7 @@
|
||||
@ -23,7 +19,7 @@ index f8ed065..0e835d0 100644
|
||||
|
||||
KBUILD_CFLAGS := -m$(BITS) -D__KERNEL__ $(LINUX_INCLUDE) -O2
|
||||
KBUILD_CFLAGS += -fno-strict-aliasing -fPIC
|
||||
@@ -48,10 +48,13 @@ $(obj)/vmlinux.bin.bz2: $(vmlinux.bin.all-y) FORCE
|
||||
@@ -48,10 +48,13 @@ $(obj)/vmlinux.bin.bz2: $(vmlinux.bin.al
|
||||
$(call if_changed,bzip2)
|
||||
$(obj)/vmlinux.bin.lzma: $(vmlinux.bin.all-y) FORCE
|
||||
$(call if_changed,lzma)
|
||||
@ -37,8 +33,6 @@ index f8ed065..0e835d0 100644
|
||||
|
||||
quiet_cmd_mkpiggy = MKPIGGY $@
|
||||
cmd_mkpiggy = $(obj)/mkpiggy $< > $@ || ( rm -f $@ ; false )
|
||||
diff --git a/arch/x86/boot/compressed/misc.c b/arch/x86/boot/compressed/misc.c
|
||||
index 842b2a3..3b22fe8 100644
|
||||
--- a/arch/x86/boot/compressed/misc.c
|
||||
+++ b/arch/x86/boot/compressed/misc.c
|
||||
@@ -162,6 +162,10 @@ static int lines, cols;
|
||||
|
@ -1,10 +1,8 @@
|
||||
diff --git a/lib/Kconfig b/lib/Kconfig
|
||||
index bb1326d..8639349 100644
|
||||
--- a/lib/Kconfig
|
||||
+++ b/lib/Kconfig
|
||||
@@ -117,6 +117,10 @@ config DECOMPRESS_BZIP2
|
||||
config DECOMPRESS_LZMA
|
||||
tristate
|
||||
@@ -120,6 +120,10 @@ config DECOMPRESS_LZMA
|
||||
config DECOMPRESS_LZMA_NEEDED
|
||||
boolean
|
||||
|
||||
+config DECOMPRESS_LZO
|
||||
+ select LZO_DECOMPRESS
|
||||
@ -13,8 +11,6 @@ index bb1326d..8639349 100644
|
||||
#
|
||||
# Generic allocator support is selected if needed
|
||||
#
|
||||
diff --git a/lib/Makefile b/lib/Makefile
|
||||
index 2e78277..cfa4041 100644
|
||||
--- a/lib/Makefile
|
||||
+++ b/lib/Makefile
|
||||
@@ -69,6 +69,7 @@ obj-$(CONFIG_LZO_DECOMPRESS) += lzo/
|
||||
@ -25,8 +21,6 @@ index 2e78277..cfa4041 100644
|
||||
|
||||
obj-$(CONFIG_TEXTSEARCH) += textsearch.o
|
||||
obj-$(CONFIG_TEXTSEARCH_KMP) += ts_kmp.o
|
||||
diff --git a/lib/decompress.c b/lib/decompress.c
|
||||
index d2842f5..a760681 100644
|
||||
--- a/lib/decompress.c
|
||||
+++ b/lib/decompress.c
|
||||
@@ -9,6 +9,7 @@
|
||||
@ -55,8 +49,6 @@ index d2842f5..a760681 100644
|
||||
{ {0, 0}, NULL, NULL }
|
||||
};
|
||||
|
||||
diff --git a/usr/Kconfig b/usr/Kconfig
|
||||
index 1c3039f..e2721f5 100644
|
||||
--- a/usr/Kconfig
|
||||
+++ b/usr/Kconfig
|
||||
@@ -72,6 +72,15 @@ config RD_LZMA
|
||||
|
@ -13,8 +13,6 @@ Signed-off-by: Albin Tonnerre <albin.tonnerre@free-electrons.com>
|
||||
4 files changed, 12 insertions(+), 0 deletions(-)
|
||||
create mode 100644 arch/arm/boot/compressed/piggy.lzma.S
|
||||
|
||||
diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
|
||||
index ea71c0c..f5bf779 100644
|
||||
--- a/arch/arm/Kconfig
|
||||
+++ b/arch/arm/Kconfig
|
||||
@@ -20,6 +20,7 @@ config ARM
|
||||
@ -25,11 +23,9 @@ index ea71c0c..f5bf779 100644
|
||||
help
|
||||
The ARM series is a line of low-power-consumption RISC chip designs
|
||||
licensed by ARM Ltd and targeted at embedded applications and
|
||||
diff --git a/arch/arm/boot/compressed/Makefile b/arch/arm/boot/compressed/Makefile
|
||||
index 5b4629b..dcfcb74 100644
|
||||
--- a/arch/arm/boot/compressed/Makefile
|
||||
+++ b/arch/arm/boot/compressed/Makefile
|
||||
@@ -65,6 +65,7 @@ SEDFLAGS = s/TEXT_START/$(ZTEXTADDR)/;s/BSS_START/$(ZBSSADDR)/
|
||||
@@ -65,6 +65,7 @@ SEDFLAGS = s/TEXT_START/$(ZTEXTADDR)/;s/
|
||||
|
||||
suffix_$(CONFIG_KERNEL_GZIP) = gzip
|
||||
suffix_$(CONFIG_KERNEL_LZO) = lzo
|
||||
@ -37,8 +33,6 @@ index 5b4629b..dcfcb74 100644
|
||||
|
||||
targets := vmlinux vmlinux.lds \
|
||||
piggy.$(suffix_y) piggy.$(suffix_y).o \
|
||||
diff --git a/arch/arm/boot/compressed/misc.c b/arch/arm/boot/compressed/misc.c
|
||||
index 7e0fe4d..4e35a10 100644
|
||||
--- a/arch/arm/boot/compressed/misc.c
|
||||
+++ b/arch/arm/boot/compressed/misc.c
|
||||
@@ -237,6 +237,10 @@ static unsigned long free_mem_end_ptr;
|
||||
@ -52,9 +46,6 @@ index 7e0fe4d..4e35a10 100644
|
||||
#ifdef CONFIG_KERNEL_LZO
|
||||
#include "../../../../lib/decompress_unlzo.c"
|
||||
#endif
|
||||
diff --git a/arch/arm/boot/compressed/piggy.lzma.S b/arch/arm/boot/compressed/piggy.lzma.S
|
||||
new file mode 100644
|
||||
index 0000000..d7e69cf
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/compressed/piggy.lzma.S
|
||||
@@ -0,0 +1,6 @@
|
||||
@ -64,6 +55,3 @@ index 0000000..d7e69cf
|
||||
+ .incbin "arch/arm/boot/compressed/piggy.lzma"
|
||||
+ .globl input_data_end
|
||||
+input_data_end:
|
||||
--
|
||||
1.6.5
|
||||
|
||||
|
@ -176,7 +176,7 @@ This patch adds support for bfs v230, modified for diff size reduction
|
||||
#define sched_exec() {}
|
||||
--- a/init/Kconfig
|
||||
+++ b/init/Kconfig
|
||||
@@ -441,9 +441,22 @@ config LOG_BUF_SHIFT
|
||||
@@ -451,9 +451,22 @@ config LOG_BUF_SHIFT
|
||||
config HAVE_UNSTABLE_SCHED_CLOCK
|
||||
bool
|
||||
|
||||
@ -199,7 +199,7 @@ This patch adds support for bfs v230, modified for diff size reduction
|
||||
default n
|
||||
help
|
||||
This feature lets CPU scheduler recognize task groups and control CPU
|
||||
@@ -494,6 +507,7 @@ endchoice
|
||||
@@ -504,6 +517,7 @@ endchoice
|
||||
|
||||
menuconfig CGROUPS
|
||||
boolean "Control Group support"
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/lib/Kconfig
|
||||
+++ b/lib/Kconfig
|
||||
@@ -148,16 +148,16 @@ config REED_SOLOMON_DEC16
|
||||
@@ -152,16 +152,16 @@ config REED_SOLOMON_DEC16
|
||||
# Textsearch support is select'ed if needed
|
||||
#
|
||||
config TEXTSEARCH
|
||||
|
@ -1,12 +1,14 @@
|
||||
--- a/scripts/Makefile.lib
|
||||
+++ b/scripts/Makefile.lib
|
||||
@@ -228,5 +228,5 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
|
||||
@@ -228,7 +228,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
|
||||
|
||||
quiet_cmd_lzma = LZMA $@
|
||||
cmd_lzma = (cat $(filter-out FORCE,$^) | \
|
||||
- lzma -9 && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
|
||||
+ lzma e -lc1 -lp2 -pb2 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
|
||||
(rm -f $@ ; false)
|
||||
|
||||
quiet_cmd_lzo = LZO $@
|
||||
--- a/scripts/gen_initramfs_list.sh
|
||||
+++ b/scripts/gen_initramfs_list.sh
|
||||
@@ -225,7 +225,7 @@ cpio_list=
|
||||
|
@ -12,7 +12,7 @@ BOARDNAME:=x86
|
||||
FEATURES:=squashfs jffs2 ext2 vdi vmdk pcmcia tgz
|
||||
SUBTARGETS=generic olpc
|
||||
|
||||
LINUX_VERSION:=2.6.31.5
|
||||
LINUX_VERSION:=2.6.31.6
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- a/drivers/ata/pata_sc1200.c
|
||||
+++ b/drivers/ata/pata_sc1200.c
|
||||
@@ -236,7 +236,7 @@ static int sc1200_init_one(struct pci_de
|
||||
.port_ops = &sc1200_port_ops
|
||||
};
|
||||
/* Can't enable port 2 yet, see top comments */
|
||||
- const struct ata_port_info *ppi[] = { &info, };
|
||||
+ const struct ata_port_info *ppi[] = { &info, &ata_dummy_port_info };
|
||||
|
||||
return ata_pci_sff_init_one(dev, ppi, &sc1200_sht, NULL);
|
||||
}
|
@ -1,8 +1,6 @@
|
||||
Index: linux-2.6.31.5/arch/x86/kernel/vmlinux.lds.S
|
||||
===================================================================
|
||||
--- linux-2.6.31.5.orig/arch/x86/kernel/vmlinux.lds.S 2009-10-23 00:57:56.000000000 +0200
|
||||
+++ linux-2.6.31.5/arch/x86/kernel/vmlinux.lds.S 2009-11-07 14:31:54.000000000 +0100
|
||||
@@ -244,6 +244,12 @@
|
||||
--- a/arch/x86/kernel/vmlinux.lds.S
|
||||
+++ b/arch/x86/kernel/vmlinux.lds.S
|
||||
@@ -244,6 +244,12 @@ SECTIONS
|
||||
__initcall_end = .;
|
||||
}
|
||||
|
||||
@ -15,10 +13,8 @@ Index: linux-2.6.31.5/arch/x86/kernel/vmlinux.lds.S
|
||||
.con_initcall.init : AT(ADDR(.con_initcall.init) - LOAD_OFFSET) {
|
||||
__con_initcall_start = .;
|
||||
*(.con_initcall.init)
|
||||
Index: linux-2.6.31.5/drivers/mtd/devices/block2mtd.c
|
||||
===================================================================
|
||||
--- linux-2.6.31.5.orig/drivers/mtd/devices/block2mtd.c 2009-11-07 14:30:57.000000000 +0100
|
||||
+++ linux-2.6.31.5/drivers/mtd/devices/block2mtd.c 2009-11-07 14:31:19.000000000 +0100
|
||||
--- a/drivers/mtd/devices/block2mtd.c
|
||||
+++ b/drivers/mtd/devices/block2mtd.c
|
||||
@@ -18,10 +18,18 @@
|
||||
#include <linux/buffer_head.h>
|
||||
#include <linux/mutex.h>
|
||||
@ -38,7 +34,7 @@ Index: linux-2.6.31.5/drivers/mtd/devices/block2mtd.c
|
||||
|
||||
/* Info for the block device */
|
||||
struct block2mtd_dev {
|
||||
@@ -33,10 +41,34 @@
|
||||
@@ -33,10 +41,34 @@ struct block2mtd_dev {
|
||||
char devname[0];
|
||||
};
|
||||
|
||||
@ -73,7 +69,7 @@ Index: linux-2.6.31.5/drivers/mtd/devices/block2mtd.c
|
||||
|
||||
static struct page *page_read(struct address_space *mapping, int index)
|
||||
{
|
||||
@@ -511,7 +543,9 @@
|
||||
@@ -511,7 +543,9 @@ static int block2mtd_setup2(const char *
|
||||
if (token[2] && (strlen(token[2]) + 1 > 80))
|
||||
parse_err("mtd device name too long");
|
||||
|
||||
@ -84,10 +80,8 @@ Index: linux-2.6.31.5/drivers/mtd/devices/block2mtd.c
|
||||
|
||||
return 0;
|
||||
}
|
||||
Index: linux-2.6.31.5/include/asm-generic/vmlinux.lds.h
|
||||
===================================================================
|
||||
--- linux-2.6.31.5.orig/include/asm-generic/vmlinux.lds.h 2009-11-07 14:30:57.000000000 +0100
|
||||
+++ linux-2.6.31.5/include/asm-generic/vmlinux.lds.h 2009-11-07 14:31:19.000000000 +0100
|
||||
--- a/include/asm-generic/vmlinux.lds.h
|
||||
+++ b/include/asm-generic/vmlinux.lds.h
|
||||
@@ -622,12 +622,14 @@
|
||||
*(.initcall4s.init) \
|
||||
*(.initcall5.init) \
|
||||
@ -104,11 +98,9 @@ Index: linux-2.6.31.5/include/asm-generic/vmlinux.lds.h
|
||||
#define INIT_CALLS \
|
||||
VMLINUX_SYMBOL(__initcall_start) = .; \
|
||||
INITCALLS \
|
||||
Index: linux-2.6.31.5/init/do_mounts.c
|
||||
===================================================================
|
||||
--- linux-2.6.31.5.orig/init/do_mounts.c 2009-10-23 00:57:56.000000000 +0200
|
||||
+++ linux-2.6.31.5/init/do_mounts.c 2009-11-07 14:31:19.000000000 +0100
|
||||
@@ -176,16 +176,8 @@
|
||||
--- a/init/do_mounts.c
|
||||
+++ b/init/do_mounts.c
|
||||
@@ -176,16 +176,8 @@ static int __init fs_names_setup(char *s
|
||||
return 1;
|
||||
}
|
||||
|
||||
@ -125,7 +117,7 @@ Index: linux-2.6.31.5/init/do_mounts.c
|
||||
|
||||
static void __init get_fs_names(char *page)
|
||||
{
|
||||
@@ -366,23 +358,6 @@
|
||||
@@ -366,23 +358,6 @@ void __init prepare_namespace(void)
|
||||
{
|
||||
int is_floppy;
|
||||
|
||||
@ -149,10 +141,8 @@ Index: linux-2.6.31.5/init/do_mounts.c
|
||||
if (saved_root_name[0]) {
|
||||
root_device_name = saved_root_name;
|
||||
if (!strncmp(root_device_name, "mtd", 3) ||
|
||||
Index: linux-2.6.31.5/init/main.c
|
||||
===================================================================
|
||||
--- linux-2.6.31.5.orig/init/main.c 2009-11-07 14:30:59.000000000 +0100
|
||||
+++ linux-2.6.31.5/init/main.c 2009-11-07 14:31:19.000000000 +0100
|
||||
--- a/init/main.c
|
||||
+++ b/init/main.c
|
||||
@@ -79,6 +79,7 @@
|
||||
#ifdef CONFIG_X86_LOCAL_APIC
|
||||
#include <asm/smp.h>
|
||||
@ -161,7 +151,7 @@ Index: linux-2.6.31.5/init/main.c
|
||||
|
||||
static int kernel_init(void *);
|
||||
|
||||
@@ -784,12 +785,13 @@
|
||||
@@ -784,12 +785,13 @@ int do_one_initcall(initcall_t fn)
|
||||
|
||||
|
||||
extern initcall_t __initcall_start[], __initcall_end[], __early_initcall_end[];
|
||||
@ -177,7 +167,7 @@ Index: linux-2.6.31.5/init/main.c
|
||||
do_one_initcall(*call);
|
||||
|
||||
/* Make sure there is no pending stuff from the initcall sequence */
|
||||
@@ -812,7 +814,7 @@
|
||||
@@ -812,7 +814,7 @@ static void __init do_basic_setup(void)
|
||||
driver_init();
|
||||
init_irq_proc();
|
||||
do_ctors();
|
||||
@ -186,7 +176,7 @@ Index: linux-2.6.31.5/init/main.c
|
||||
}
|
||||
|
||||
static void __init do_pre_smp_initcalls(void)
|
||||
@@ -873,6 +875,13 @@
|
||||
@@ -873,6 +875,13 @@ static noinline int init_post(void)
|
||||
panic("No init found. Try passing init= option to kernel.");
|
||||
}
|
||||
|
||||
@ -200,7 +190,7 @@ Index: linux-2.6.31.5/init/main.c
|
||||
static int __init kernel_init(void * unused)
|
||||
{
|
||||
lock_kernel();
|
||||
@@ -917,7 +926,16 @@
|
||||
@@ -917,7 +926,16 @@ static int __init kernel_init(void * unu
|
||||
|
||||
if (sys_access((const char __user *) ramdisk_execute_command, 0) != 0) {
|
||||
ramdisk_execute_command = NULL;
|
||||
|
Loading…
Reference in New Issue
Block a user