1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-10-02 16:31:40 +03:00

uclibc: add some libpthread fixes

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14013 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nbd 2009-01-13 02:15:14 +00:00
parent 640843ffb0
commit 7cae514282
2 changed files with 23 additions and 0 deletions

View File

@ -0,0 +1,12 @@
--- a/libpthread/linuxthreads/Makefile.in
+++ b/libpthread/linuxthreads/Makefile.in
@@ -128,7 +128,9 @@ linuxthreads_headers:
$(Q)$(LN) -sf ../$(PTDIR)/sysdeps/pthread/pthread.h $(top_builddir)include/
$(Q)$(LN) -sf ../$(PTDIR)/semaphore.h $(top_builddir)include/
$(Q)$(INSTALL) -d $(top_builddir)include/bits
+ $(Q)$(INSTALL) -d $(top_builddir)include/sys
$(Q)$(LN) -sf ../../$(PTDIR)/sysdeps/pthread/bits/pthreadtypes.h $(top_builddir)include/bits/
+ $(Q)$(LN) -sf ../../$(PTDIR)/sysdeps/$(TARGET_ARCH)/tls.h $(top_builddir)include/sys/
linuxthreads_headers_clean:
$(RM) $(top_builddir)include/pthread.h $(top_builddir)include/semaphore.h \

View File

@ -0,0 +1,11 @@
--- a/libpthread/linuxthreads/Makefile.in
+++ b/libpthread/linuxthreads/Makefile.in
@@ -65,7 +65,7 @@ CFLAGS-OMIT-libc_pthread_init.c := $(CFL
libpthread_libc_CSRC := \
forward.c libc-cancellation.c libc_pthread_init.c # alloca_cutoff.c
libpthread_libc_OBJ := $(patsubst %.c, $(libpthread_OUT)/%.o,$(libpthread_libc_CSRC))
-libc-static-y += $(libpthread_OUT)/libc_pthread_init.o
+libc-static-y += $(libpthread_OUT)/libc_pthread_init.o $(libpthread_OUT)/libc-cancellation.o
libc-shared-y += $(libpthread_libc_OBJ:.o=.oS)
libpthread-static-y += $(patsubst %,$(libpthread_OUT)/%.o,$(libpthread_static_SRC))