mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-27 18:17:32 +02:00
[backfire] merge r22495
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@22496 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
0b00ddfee9
commit
7cd9bd5b3d
@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=ppp
|
||||
PKG_VERSION:=2.4.4
|
||||
PKG_RELEASE:=8
|
||||
PKG_RELEASE:=9
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
|
||||
|
@ -78,7 +78,7 @@
|
||||
|
||||
if (ppp_dev_fd >= 0) {
|
||||
dbglog("in make_ppp_unit, already had /dev/ppp open?");
|
||||
@@ -645,6 +650,32 @@ static int make_ppp_unit()
|
||||
@@ -645,6 +650,30 @@ static int make_ppp_unit()
|
||||
}
|
||||
if (x < 0)
|
||||
error("Couldn't create new ppp unit: %m");
|
||||
@ -103,8 +103,6 @@
|
||||
+ error("Couldn't rename %s to %s", ifr.ifr_name, ifr.ifr_newname);
|
||||
+ close(ppp_dev_fd);
|
||||
+ ppp_dev_fd = -1;
|
||||
+ } else {
|
||||
+ info("Renamed %s to %s", ifr.ifr_name, ifr.ifr_newname);
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
|
10
package/ppp/patches/330-retain_foreign_default_routes.patch
Normal file
10
package/ppp/patches/330-retain_foreign_default_routes.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- a/pppd/sys-linux.c
|
||||
+++ b/pppd/sys-linux.c
|
||||
@@ -1717,6 +1717,7 @@ int cifdefaultroute (int unit, u_int32_t
|
||||
SIN_ADDR(rt.rt_genmask) = 0L;
|
||||
}
|
||||
|
||||
+ rt.rt_dev = ifname;
|
||||
rt.rt_flags = RTF_UP;
|
||||
if (ioctl(sock_fd, SIOCDELRT, &rt) < 0 && errno != ESRCH) {
|
||||
if (still_ppp()) {
|
Loading…
Reference in New Issue
Block a user