mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-10 12:50:16 +02:00
Add mips kernel entry patch
Fix image creation git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3723 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
05a7af7651
commit
857c3cb625
@ -17,10 +17,10 @@ $(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
|
||||
@$(CP) config $(LINUX_DIR)/.config
|
||||
touch $@
|
||||
|
||||
$(LINUX_BUILD_DIR)/zImage: $(LINUX_DIR)/vmlinux
|
||||
$(LINUX_BUILD_DIR)/zImage.flash.srec: $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.flash.srec $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec
|
||||
$(MAKE) -C $(LINUX_DIR) V=1 CROSS_COMPILE=$(TARGET_CROSS) ARCH=$(LINUX_KARCH) PATH=$(TARGET_PATH) zImage.flash $(MAKE_TRACE)
|
||||
$(CP) $(LINUX_DIR)/vmlinux $@
|
||||
echo "toto"
|
||||
$(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.flash.srec $(LINUX_DIR)/zImage.flash.srec
|
||||
$(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
|
||||
touch $@
|
||||
|
||||
compile: $(LINUX_DIR)/vmlinux
|
||||
|
15
openwrt/target/linux/au1000-2.6/patches/009-boot.patch
Normal file
15
openwrt/target/linux/au1000-2.6/patches/009-boot.patch
Normal file
@ -0,0 +1,15 @@
|
||||
diff -Nur linux-cvs/arch/mips/kernel/head.S linux-aruba/arch/mips/kernel/head.S
|
||||
--- linux-cvs/arch/mips/kernel/head.S 2004-12-23 00:21:39.000000000 -0800
|
||||
+++ linux-aruba/arch/mips/kernel/head.S 2005-10-20 09:16:08.000000000 -0700
|
||||
@@ -122,6 +122,10 @@
|
||||
#endif
|
||||
.endm
|
||||
|
||||
+
|
||||
+ j kernel_entry
|
||||
+ nop
|
||||
+
|
||||
/*
|
||||
* Reserved space for exception handlers.
|
||||
* Necessary for machines which link their kernels at KSEG0.
|
||||
|
@ -1,6 +1,6 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
LOADADDR = 0x8008c8f4 # RAM start + 16M
|
||||
LOADADDR = 0x8108c8f4 # RAM start + 16M
|
||||
KERNEL_ENTRY = 0x80100000
|
||||
RAMSIZE = 0x04000000 # 1MB
|
||||
|
||||
@ -31,25 +31,12 @@ endif
|
||||
ifeq ($(KERNEL),2.6)
|
||||
FSNAME:=$(patsubst jffs2-%,jffs2,$(FS))
|
||||
|
||||
$(KDIR)/vmlinux.srec: $(KDIR)/vmlinux
|
||||
$(TARGET_CROSS)objcopy -O srec $(LINUX_DIR)/vmlinux $(KDIR)/vmlinux.srec
|
||||
|
||||
ifeq ($(FS),jffs2-4MB)
|
||||
|
||||
$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FSNAME).bin: $(KDIR)/root.$(FS) $(KDIR)/vmlinux.srec
|
||||
$(TARGET_CROSS)objcopy -O srec -I binary --adjust-vma 0xbe000000 $(KDIR)/root.$(FS) $(KDIR)/root.srec
|
||||
grep -v S7 $(KDIR)/root.srec > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img
|
||||
grep -v S0 $(KDIR)/vmlinux.srec >> $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img
|
||||
|
||||
install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FSNAME).bin
|
||||
endif
|
||||
|
||||
ifeq ($(FS),jffs2-8MB)
|
||||
|
||||
$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FSNAME).bin: $(KDIR)/root.$(FS) $(KDIR)/vmlinux.srec
|
||||
$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FSNAME).bin: $(KDIR)/root.$(FS)
|
||||
$(TARGET_CROSS)objcopy -O srec -I binary --adjust-vma 0xbe000000 $(KDIR)/root.$(FS) $(KDIR)/root.srec
|
||||
grep -v S7 $(KDIR)/root.srec > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img
|
||||
grep -v S0 $(KDIR)/vmlinux.srec >> $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img
|
||||
grep -v S0 $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.flash.srec >> $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img
|
||||
|
||||
install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FSNAME).bin
|
||||
endif
|
||||
@ -64,16 +51,17 @@ install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tar.gz
|
||||
endif
|
||||
|
||||
ifeq ($(FS),squashfs)
|
||||
$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FSNAME).bin: $(KDIR)/root.$(FS) $(KDIR)/vmlinux.srec
|
||||
$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FSNAME).bin: $(KDIR)/root.$(FS)
|
||||
$(TARGET_CROSS)objcopy -O srec -I binary --adjust-vma 0xbe000000 $(KDIR)/root.$(FS) $(KDIR)/root.srec
|
||||
grep -v S7 $(KDIR)/root.srec > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img
|
||||
grep -v S0 $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.flash.srec >> $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img
|
||||
|
||||
endif
|
||||
|
||||
install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FSNAME).bin
|
||||
endif
|
||||
|
||||
$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz: $(KDIR)/vmlinux
|
||||
$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz: $(KDIR)/zImage.flash
|
||||
$(CP) $^ $@
|
||||
|
||||
ifeq ($(IB),)
|
||||
|
Loading…
Reference in New Issue
Block a user