mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-05 06:56:16 +02:00
[ar7] add some missing patches to acx-mac80211 it now builds the pci module as well
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20020 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
1a467d902b
commit
875b899bb6
13
package/acx-mac80211/patches/003-build_as_modules.patch
Normal file
13
package/acx-mac80211/patches/003-build_as_modules.patch
Normal file
@ -0,0 +1,13 @@
|
||||
Index: acx-mac80211-20100302/Makefile
|
||||
===================================================================
|
||||
--- acx-mac80211-20100302.orig/Makefile 2010-03-06 22:13:23.000000000 +0100
|
||||
+++ acx-mac80211-20100302/Makefile 2010-03-06 22:13:28.000000000 +0100
|
||||
@@ -29,7 +29,7 @@
|
||||
acx-mac80211-obj-$(CONFIG_ACX_MAC80211_PCI) += pci.o
|
||||
acx-mac80211-obj-$(CONFIG_ACX_MAC80211_USB) += usb.o
|
||||
acx-mac80211-obj-$(CONFIG_ACX_MAC80211_MEM) += mem.o
|
||||
- acx-mac80211-objs := common.o $(acx-mac80211-obj-y)
|
||||
+ acx-mac80211-objs := common.o $(acx-mac80211-obj-m)
|
||||
|
||||
else
|
||||
# Otherwise we were called directly from the command line: the kernel build
|
49
package/acx-mac80211/patches/004-vlynq_fixes.patch
Normal file
49
package/acx-mac80211/patches/004-vlynq_fixes.patch
Normal file
@ -0,0 +1,49 @@
|
||||
Index: acx-mac80211-20100302/pci.c
|
||||
===================================================================
|
||||
--- acx-mac80211-20100302.orig/pci.c 2010-03-06 22:22:02.000000000 +0100
|
||||
+++ acx-mac80211-20100302/pci.c 2010-03-06 22:22:29.000000000 +0100
|
||||
@@ -4309,7 +4309,7 @@
|
||||
addr = (u32)ioremap(vdev->mem_start, 0x1000);
|
||||
if (!addr) {
|
||||
printk(KERN_ERR "acx: %s: failed to remap io memory\n",
|
||||
- vdev->dev.bus_id);
|
||||
+ dev_name(&vdev->dev));
|
||||
result = -ENXIO;
|
||||
goto fail;
|
||||
}
|
||||
@@ -4323,7 +4323,7 @@
|
||||
ieee = ieee80211_alloc_hw(sizeof(struct acx_device), &acxpci_hw_ops);
|
||||
if (!ieee) {
|
||||
printk("acx: could not allocate ieee80211 structure %s\n",
|
||||
- vdev->dev.bus_id);
|
||||
+ dev_name(&vdev->dev));
|
||||
goto fail_alloc_netdev;
|
||||
}
|
||||
ieee->flags &= ~IEEE80211_HW_RX_INCLUDES_FCS;
|
||||
@@ -4365,7 +4365,7 @@
|
||||
|
||||
printk("acx: found %s-based wireless network card at %s, irq:%d, "
|
||||
"phymem:0x%x, mem:0x%p\n",
|
||||
- match->name, vdev->dev.bus_id, adev->irq,
|
||||
+ match->name, dev_name(&vdev->dev), adev->irq,
|
||||
vdev->mem_start, adev->iobase);
|
||||
log(L_ANY, "acx: the initial debug setting is 0x%04X\n", acx_debug);
|
||||
|
||||
@@ -4416,7 +4416,7 @@
|
||||
* firmware operations happening in parallel or uninitialized data */
|
||||
|
||||
|
||||
- acx_proc_register_entries(ieee);
|
||||
+ acx_proc_register_entries(ieee, 0);
|
||||
|
||||
/* Now we have our device, so make sure the kernel doesn't try
|
||||
* to send packets even though we're not associated to a network yet */
|
||||
@@ -4536,7 +4536,7 @@
|
||||
CLEAR_BIT(adev->dev_state_mask, ACX_STATE_IFACE_UP);
|
||||
}
|
||||
|
||||
- acx_proc_unregister_entries(adev->ieee);
|
||||
+ acx_proc_unregister_entries(adev->ieee, 0);
|
||||
|
||||
/* finally, clean up PCI bus state */
|
||||
acxpci_s_delete_dma_regions(adev);
|
Loading…
Reference in New Issue
Block a user