1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-04 23:30:43 +03:00

[ar71xx] add parallel flash driver

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16353 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
juhosg 2009-06-06 08:41:47 +00:00
parent 35cd7b3053
commit 8fe43eefaf
9 changed files with 361 additions and 5 deletions

View File

@ -121,8 +121,8 @@ CONFIG_MIPS_MT_DISABLED=y
# CONFIG_MIPS_MT_SMP is not set
# CONFIG_MIPS_MT_SMTC is not set
# CONFIG_MIPS_SIM is not set
CONFIG_MTD_AR91XX_FLASH=y
# CONFIG_MTD_CFI is not set
# CONFIG_MTD_COMPLEX_MAPPINGS is not set
CONFIG_MTD_CONCAT=y
CONFIG_MTD_M25P80=y
CONFIG_MTD_MYLOADER_PARTS=y

View File

@ -126,8 +126,8 @@ CONFIG_MIPS_MT_DISABLED=y
# CONFIG_MIPS_MT_SMTC is not set
# CONFIG_MIPS_SIM is not set
CONFIG_MISC_FILESYSTEMS=y
CONFIG_MTD_AR91XX_FLASH=y
# CONFIG_MTD_CFI is not set
# CONFIG_MTD_COMPLEX_MAPPINGS is not set
CONFIG_MTD_CONCAT=y
CONFIG_MTD_M25P80=y
CONFIG_MTD_NAND=y

View File

@ -134,8 +134,8 @@ CONFIG_MIPS_MT_DISABLED=y
# CONFIG_MIPS_MT_SMP is not set
# CONFIG_MIPS_MT_SMTC is not set
# CONFIG_MIPS_SIM is not set
CONFIG_MTD_AR91XX_FLASH=y
# CONFIG_MTD_CFI is not set
# CONFIG_MTD_COMPLEX_MAPPINGS is not set
CONFIG_MTD_CONCAT=y
CONFIG_MTD_M25P80=y
CONFIG_MTD_NAND=y

View File

@ -68,7 +68,7 @@ static struct mtd_partition ap83_flash_partitions[] = {
};
#endif /* CONFIG_MTD_PARTITIONS */
static struct physmap_flash_data ap83_flash_data = {
static struct ar91xx_flash_platform_data ap83_flash_data = {
.width = 2,
#ifdef CONFIG_MTD_PARTITIONS
.parts = ap83_flash_partitions,
@ -85,7 +85,7 @@ static struct resource ap83_flash_resources[] = {
};
static struct platform_device ap83_flash_device = {
.name = "physmap-flash",
.name = "ar91xx-flash",
.id = -1,
.resource = ap83_flash_resources,
.num_resources = ARRAY_SIZE(ap83_flash_resources),

View File

@ -16,6 +16,8 @@
#include <linux/skbuff.h>
#include <linux/phy.h>
#include <linux/spi/spi.h>
#include <linux/mtd/mtd.h>
#include <linux/mtd/partitions.h>
struct ag71xx_platform_data {
phy_interface_t phy_if_mode;
@ -51,4 +53,12 @@ struct ar71xx_spi_platform_data {
#define AR71XX_SPI_CS_INACTIVE 0
#define AR71XX_SPI_CS_ACTIVE 1
struct ar91xx_flash_platform_data {
unsigned int width;
#ifdef CONFIG_MTD_PARTITIONS
unsigned int nr_parts;
struct mtd_partition *parts;
#endif
};
#endif /* __ASM_MACH_AR71XX_PLATFORM_H */

View File

@ -0,0 +1,268 @@
/*
* Parallel flash driver for the Atheros AR91xx SoC
*
* Copyright (C) 2009 Gabor Juhos <juhosg@openwrt.org>
*
* This program is free software; you can redistribute it and/or modify
* it under the terms of the GNU General Public License version 2 as
* published by the Free Software Foundation.
*
*/
#include <linux/module.h>
#include <linux/types.h>
#include <linux/kernel.h>
#include <linux/init.h>
#include <linux/slab.h>
#include <linux/device.h>
#include <linux/platform_device.h>
#include <linux/mtd/mtd.h>
#include <linux/mtd/map.h>
#include <linux/mtd/partitions.h>
#include <linux/io.h>
#include <asm/mach-ar71xx/ar71xx.h>
#include <asm/mach-ar71xx/platform.h>
#define DRV_NAME "ar91xx-flash"
struct ar91xx_flash_info {
struct mtd_info *mtd;
struct map_info map;
#ifdef CONFIG_MTD_PARTITIONS
int nr_parts;
struct mtd_partition *parts;
#endif
};
static map_word ar91xx_flash_read(struct map_info *map, unsigned long ofs)
{
map_word val;
if (map_bankwidth_is_1(map))
val.x[0] = __raw_readb(map->virt + (ofs ^ 3));
else if (map_bankwidth_is_2(map))
val.x[0] = __raw_readw(map->virt + (ofs ^ 2));
else
val = map_word_ff(map);
return val;
}
static void ar91xx_flash_write(struct map_info *map, map_word d,
unsigned long ofs)
{
if (map_bankwidth_is_1(map))
__raw_writeb(d.x[0], map->virt + (ofs ^ 3));
else if (map_bankwidth_is_2(map))
__raw_writew(d.x[0], map->virt + (ofs ^ 2));
mb();
}
static int ar91xx_flash_remove(struct platform_device *pdev)
{
struct ar91xx_flash_platform_data *pdata;
struct ar91xx_flash_info *info;
info = platform_get_drvdata(pdev);
if (info == NULL)
return 0;
platform_set_drvdata(pdev, NULL);
if (info->mtd == NULL)
return 0;
pdata = pdev->dev.platform_data;
#ifdef CONFIG_MTD_PARTITIONS
if (info->nr_parts) {
del_mtd_partitions(info->mtd);
kfree(info->parts);
} else if (pdata->nr_parts) {
del_mtd_partitions(info->mtd);
} else {
del_mtd_device(info->mtd);
}
#else
del_mtd_device(info->mtd);
#endif
map_destroy(info->mtd);
return 0;
}
static const char *rom_probe_types[] = { "cfi_probe", "jedec_probe", NULL };
#ifdef CONFIG_MTD_PARTITIONS
static const char *part_probe_types[] = { "cmdlinepart", "RedBoot", NULL };
#endif
static int ar91xx_flash_probe(struct platform_device *pdev)
{
struct ar91xx_flash_platform_data *pdata;
struct ar91xx_flash_info *info;
struct resource *res;
struct resource *region;
const char **probe_type;
int err = 0;
pdata = pdev->dev.platform_data;
if (pdata == NULL)
return -EINVAL;
info = devm_kzalloc(&pdev->dev, sizeof(struct ar91xx_flash_info),
GFP_KERNEL);
if (info == NULL) {
err = -ENOMEM;
goto err_out;
}
platform_set_drvdata(pdev, info);
res = platform_get_resource(pdev, IORESOURCE_MEM, 0);
if (res == NULL) {
err = -ENOENT;
goto err_out;
}
dev_info(&pdev->dev, "%.8llx at %.8llx\n",
(unsigned long long)(res->end - res->start + 1),
(unsigned long long)res->start);
region = devm_request_mem_region(&pdev->dev,
res->start, res->end - res->start + 1,
dev_name(&pdev->dev));
if (region == NULL) {
dev_err(&pdev->dev, "could not reserve memory region\n");
err = -ENOMEM;
goto err_out;
}
info->map.name = dev_name(&pdev->dev);
info->map.phys = res->start;
info->map.size = res->end - res->start + 1;
info->map.bankwidth = pdata->width;
info->map.virt = devm_ioremap(&pdev->dev, info->map.phys,
info->map.size);
if (info->map.virt == NULL) {
dev_err(&pdev->dev, "failed to ioremap flash region\n");
err = -EIO;
goto err_out;
}
simple_map_init(&info->map);
info->map.read = ar91xx_flash_read;
info->map.write = ar91xx_flash_write;
probe_type = rom_probe_types;
for (; info->mtd == NULL && *probe_type != NULL; probe_type++)
info->mtd = do_map_probe(*probe_type, &info->map);
if (info->mtd == NULL) {
dev_err(&pdev->dev, "map_probe failed\n");
err = -ENXIO;
goto err_out;
}
info->mtd->owner = THIS_MODULE;
#ifdef CONFIG_MTD_PARTITIONS
if (pdata->nr_parts) {
dev_info(&pdev->dev, "using static partition mapping\n");
add_mtd_partitions(info->mtd, pdata->parts, pdata->nr_parts);
return 0;
}
err = parse_mtd_partitions(info->mtd, part_probe_types,
&info->parts, 0);
if (err > 0) {
add_mtd_partitions(info->mtd, info->parts, err);
return 0;
}
#endif
add_mtd_device(info->mtd);
return 0;
err_out:
ar91xx_flash_remove(pdev);
return err;
}
#ifdef CONFIG_PM
static int ar91xx_flash_suspend(struct platform_device *dev, pm_message_t state)
{
struct ar91xx_flash_info *info = platform_get_drvdata(dev);
int ret = 0;
if (info->mtd->suspend)
ret = info->mtd->suspend(info->mtd);
if (ret)
goto fail;
return 0;
fail:
if (info->mtd->suspend) {
BUG_ON(!info->mtd->resume);
info->mtd->resume(info->mtd);
}
return ret;
}
static int ar91xx_flash_resume(struct platform_device *pdev)
{
struct ar91xx_flash_info *info = platform_get_drvdata(pdev);
if (info->mtd->resume)
info->mtd->resume(info->mtd);
return 0;
}
static void ar91xx_flash_shutdown(struct platform_device *pdev)
{
struct ar91xx_flash_info *info = platform_get_drvdata(pdev);
if (info->mtd->suspend && info->mtd->resume)
if (info->mtd->suspend(info->mtd) == 0)
info->mtd->resume(info->mtd);
}
#else
#define ar91xx_flash_suspend NULL
#define ar91xx_flash_resume NULL
#define ar91xx_flash_shutdown NULL
#endif
static struct platform_driver ar91xx_flash_driver = {
.probe = ar91xx_flash_probe,
.remove = ar91xx_flash_remove,
.suspend = ar91xx_flash_suspend,
.resume = ar91xx_flash_resume,
.shutdown = ar91xx_flash_shutdown,
.driver = {
.name = DRV_NAME,
.owner = THIS_MODULE,
},
};
static int __init ar91xx_flash_init(void)
{
return platform_driver_register(&ar91xx_flash_driver);
}
static void __exit ar91xx_flash_exit(void)
{
platform_driver_unregister(&ar91xx_flash_driver);
}
module_init(ar91xx_flash_init);
module_exit(ar91xx_flash_exit);
MODULE_LICENSE("GPL v2");
MODULE_AUTHOR("Gabor Juhos <juhosg@openwrt.org>");
MODULE_DESCRIPTION("Parallel flash driver for the Atheros AR91xx SoC");
MODULE_ALIAS("platform:" DRV_NAME);

View File

@ -0,0 +1,26 @@
--- a/drivers/mtd/maps/Kconfig
+++ b/drivers/mtd/maps/Kconfig
@@ -257,6 +257,13 @@ config MTD_ALCHEMY
help
Flash memory access on AMD Alchemy Pb/Db/RDK Reference Boards
+config MTD_AR91XX_FLASH
+ tristate "Atheros AR91xx parallel flash support"
+ depends on ATHEROS_AR71XX
+ select MTD_COMPLEX_MAPPINGS
+ help
+ Parallel flash driver for the Atheros AR91xx based boards.
+
config MTD_DILNETPC
tristate "CFI Flash device mapped on DIL/Net PC"
depends on X86 && MTD_CONCAT && MTD_PARTITIONS && MTD_CFI_INTELEXT
--- a/drivers/mtd/maps/Makefile
+++ b/drivers/mtd/maps/Makefile
@@ -42,6 +42,7 @@ obj-$(CONFIG_MTD_DBOX2) += dbox2-flash.
obj-$(CONFIG_MTD_SOLUTIONENGINE)+= solutionengine.o
obj-$(CONFIG_MTD_PCI) += pci.o
obj-$(CONFIG_MTD_ALCHEMY) += alchemy-flash.o
+obj-$(CONFIG_MTD_AR91XX_FLASH) += ar91xx_flash.o
obj-$(CONFIG_MTD_AUTCPU12) += autcpu12-nvram.o
obj-$(CONFIG_MTD_EDB7312) += edb7312.o
obj-$(CONFIG_MTD_IMPA7) += impa7.o

View File

@ -0,0 +1,26 @@
--- a/drivers/mtd/maps/Kconfig
+++ b/drivers/mtd/maps/Kconfig
@@ -268,6 +268,13 @@ config MTD_ALCHEMY
help
Flash memory access on AMD Alchemy Pb/Db/RDK Reference Boards
+config MTD_AR91XX_FLASH
+ tristate "Atheros AR91xx parallel flash support"
+ depends on ATHEROS_AR71XX
+ select MTD_COMPLEX_MAPPINGS
+ help
+ Parallel flash driver for the Atheros AR91xx based boards.
+
config MTD_DILNETPC
tristate "CFI Flash device mapped on DIL/Net PC"
depends on X86 && MTD_CONCAT && MTD_PARTITIONS && MTD_CFI_INTELEXT
--- a/drivers/mtd/maps/Makefile
+++ b/drivers/mtd/maps/Makefile
@@ -42,6 +42,7 @@ obj-$(CONFIG_MTD_DBOX2) += dbox2-flash.
obj-$(CONFIG_MTD_SOLUTIONENGINE)+= solutionengine.o
obj-$(CONFIG_MTD_PCI) += pci.o
obj-$(CONFIG_MTD_ALCHEMY) += alchemy-flash.o
+obj-$(CONFIG_MTD_AR91XX_FLASH) += ar91xx_flash.o
obj-$(CONFIG_MTD_AUTCPU12) += autcpu12-nvram.o
obj-$(CONFIG_MTD_EDB7312) += edb7312.o
obj-$(CONFIG_MTD_IMPA7) += impa7.o

View File

@ -0,0 +1,26 @@
--- a/drivers/mtd/maps/Kconfig
+++ b/drivers/mtd/maps/Kconfig
@@ -268,6 +268,13 @@ config MTD_ALCHEMY
help
Flash memory access on AMD Alchemy Pb/Db/RDK Reference Boards
+config MTD_AR91XX_FLASH
+ tristate "Atheros AR91xx parallel flash support"
+ depends on ATHEROS_AR71XX
+ select MTD_COMPLEX_MAPPINGS
+ help
+ Parallel flash driver for the Atheros AR91xx based boards.
+
config MTD_DILNETPC
tristate "CFI Flash device mapped on DIL/Net PC"
depends on X86 && MTD_CONCAT && MTD_PARTITIONS && MTD_CFI_INTELEXT
--- a/drivers/mtd/maps/Makefile
+++ b/drivers/mtd/maps/Makefile
@@ -42,6 +42,7 @@ obj-$(CONFIG_MTD_DBOX2) += dbox2-flash.
obj-$(CONFIG_MTD_SOLUTIONENGINE)+= solutionengine.o
obj-$(CONFIG_MTD_PCI) += pci.o
obj-$(CONFIG_MTD_ALCHEMY) += alchemy-flash.o
+obj-$(CONFIG_MTD_AR91XX_FLASH) += ar91xx_flash.o
obj-$(CONFIG_MTD_AUTCPU12) += autcpu12-nvram.o
obj-$(CONFIG_MTD_EDB7312) += edb7312.o
obj-$(CONFIG_MTD_IMPA7) += impa7.o