mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-10 14:21:51 +02:00
Add openldap package
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@872 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
db93e5444f
commit
94874fca43
@ -84,6 +84,8 @@ source "package/speex/Config.in"
|
||||
source "package/libusb/Config.in"
|
||||
source "package/libpng/Config.in"
|
||||
source "package/libgd/Config.in"
|
||||
source "package/cyrus-sasl/Config.in"
|
||||
source "package/openldap/Config.in"
|
||||
|
||||
comment "Extra stuff"
|
||||
source "package/sdk/Config.in"
|
||||
|
@ -43,6 +43,7 @@ package-$(BR2_PACKAGE_NMAP) += nmap
|
||||
package-$(BR2_PACKAGE_NOCATSPLASH) += nocatsplash
|
||||
package-$(BR2_PACKAGE_NTPCLIENT) += ntpclient
|
||||
package-$(BR2_PACKAGE_OLSRD) += olsrd
|
||||
package-$(BR2_PACKAGE_OPENLDAP) += openldap
|
||||
package-$(BR2_PACKAGE_OPENSSL) += openssl
|
||||
package-$(BR2_PACKAGE_OPENSWAN) += openswan
|
||||
package-$(BR2_PACKAGE_OPENNTPD) += openntpd
|
||||
@ -124,6 +125,7 @@ kismet-compile: uclibc++-compile libpcap-compile
|
||||
tinc-compile: zlib-compile openssl-compile lzo-compile
|
||||
fprobe-compile: libpcap-compile
|
||||
cyrus-sasl-compile: openssl-compile
|
||||
openldap-compile: cyrus-sasl-compile openssl-compile
|
||||
|
||||
snort-compile: libnet-compile libpcap-compile pcre-compile
|
||||
ifeq ($(BR2_PACKAGE_SNORT_MYSQL),y)
|
||||
|
20
openwrt/package/openldap/Config.in
Normal file
20
openwrt/package/openldap/Config.in
Normal file
@ -0,0 +1,20 @@
|
||||
config BR2_PACKAGE_OPENLDAP
|
||||
tristate "OpenLDAP"
|
||||
default m if CONFIG_DEVEL
|
||||
help
|
||||
OpenLDAP Software is an open source implementation of the
|
||||
Lightweight Directory Access Protocol (LDAP).
|
||||
|
||||
http://www.openldap.org/
|
||||
|
||||
|
||||
config BR2_PACKAGE_LIBOPENLDAP
|
||||
tristate "libopenldap (client libraries)"
|
||||
default m if CONFIG_DEVEL
|
||||
depends BR2_PACKAGE_OPENLDAP
|
||||
|
||||
config BR2_PACKAGE_OPENLDAP_UTILS
|
||||
tristate "openldap-utils (client utilities)"
|
||||
default m if CONFIG_DEVEL
|
||||
depends BR2_PACKAGE_OPENLDAP
|
||||
|
136
openwrt/package/openldap/Makefile
Normal file
136
openwrt/package/openldap/Makefile
Normal file
@ -0,0 +1,136 @@
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=openldap
|
||||
PKG_VERSION:=2.2.26
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=afc8700b5738da863b30208e1d3e9de8
|
||||
|
||||
PKG_SOURCE_URL:= \
|
||||
ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/ \
|
||||
http://nthill.free.fr/openwrt/sources/$(PKG_NAME)/
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
PKG_CONFIGURE_OPTIONS = \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--disable-debug \
|
||||
--enable-dynamic \
|
||||
--enable-syslog \
|
||||
--disable-local \
|
||||
--disable-slapd \
|
||||
--disable-slurpd \
|
||||
--with-cyrus-sasl \
|
||||
--without-fetch \
|
||||
--with-threads \
|
||||
--with-tls \
|
||||
--with-yielding_select="yes" \
|
||||
|
||||
include $(TOPDIR)/package/rules.mk
|
||||
|
||||
$(eval $(call PKG_template,LIBOPENLDAP,libopenldap,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||
$(eval $(call PKG_template,OPENLDAP_UTILS,openldap-utils,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||
|
||||
$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
|
||||
touch $(PKG_BUILD_DIR)/.configured
|
||||
|
||||
$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
|
||||
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
|
||||
./configure \
|
||||
--target=$(GNU_HOST_NAME) \
|
||||
--host=$(GNU_HOST_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--program-prefix="" \
|
||||
--program-suffix="" \
|
||||
--prefix=/usr \
|
||||
--exec-prefix=/usr \
|
||||
--bindir=/usr/bin \
|
||||
--datadir=/usr/share \
|
||||
--includedir=/usr/include \
|
||||
--libdir=/usr/lib \
|
||||
--libexecdir=/usr/lib \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/share/man \
|
||||
--sbindir=/usr/sbin \
|
||||
--sysconfdir=/etc \
|
||||
$(DISABLE_LARGEFILE) \
|
||||
$(DISABLE_NLS) \
|
||||
$(PKG_CONFIGURE_OPTIONS) \
|
||||
)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) depend
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)/libraries/liblutil
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)/libraries/liblber
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)/libraries/liblunicode
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)/libraries/liblber clean
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)/libraries/liblutil clean
|
||||
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
|
||||
ac_cv_func_memcmp_clean="yes" \
|
||||
./configure \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--program-prefix="" \
|
||||
--program-suffix="" \
|
||||
--prefix=/usr \
|
||||
--exec-prefix=/usr \
|
||||
--bindir=/usr/bin \
|
||||
--datadir=/usr/share \
|
||||
--includedir=/usr/include \
|
||||
--libdir=/usr/lib \
|
||||
--libexecdir=/usr/lib \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/share/man \
|
||||
--sbindir=/usr/sbin \
|
||||
--sysconfdir=/etc \
|
||||
$(DISABLE_LARGEFILE) \
|
||||
$(DISABLE_NLS) \
|
||||
$(PKG_CONFIGURE_OPTIONS) \
|
||||
)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
install
|
||||
touch $(PKG_BUILD_DIR)/.built
|
||||
|
||||
|
||||
$(IPKG_LIBOPENLDAP):
|
||||
mkdir -p $(IDIR_LIBOPENLDAP)/etc/openldap
|
||||
cp -fpR $(PKG_INSTALL_DIR)/etc/openldap/ldap.conf $(IDIR_LIBOPENLDAP)/etc/openldap/
|
||||
mkdir -p $(IDIR_LIBOPENLDAP)/usr/lib/
|
||||
cp -fpR $(PKG_INSTALL_DIR)/usr/lib/lib{lber,ldap}*.so.* $(IDIR_LIBOPENLDAP)/usr/lib/
|
||||
mkdir -p $(IDIR_LIBOPENLDAP)/usr/share/openldap
|
||||
cp -fpR $(PKG_INSTALL_DIR)/usr/share/openldap/* $(IDIR_LIBOPENLDAP)/usr/share/openldap/
|
||||
$(RSTRIP) $(IDIR_LIBOPENLDAP)
|
||||
$(IPKG_BUILD) $(IDIR_LIBOPENLDAP) $(PACKAGE_DIR)
|
||||
|
||||
$(IPKG_OPENLDAP_UTILS):
|
||||
mkdir -p $(IDIR_OPENLDAP_UTILS)/usr/bin
|
||||
cp -fpR $(PKG_INSTALL_DIR)/usr/bin/ldap* $(IDIR_OPENLDAP_UTILS)/usr/bin/
|
||||
$(RSTRIP) $(IDIR_OPENLDAP_UTILS)
|
||||
$(IPKG_BUILD) $(IDIR_OPENLDAP_UTILS) $(PACKAGE_DIR)
|
||||
|
||||
$(STAGING_DIR)/usr/lib/libldap.so: $(PKG_BUILD_DIR)/.built
|
||||
mkdir -p $(STAGING_DIR)/usr/include
|
||||
cp -fpR $(PKG_INSTALL_DIR)/usr/include/{lber,ldap}*.h $(STAGING_DIR)/usr/include/
|
||||
mkdir -p $(STAGING_DIR)/usr/lib/
|
||||
cp -fpR $(PKG_INSTALL_DIR)/usr/lib/lib{lber,ldap}*.{a,so*} $(STAGING_DIR)/usr/lib/
|
||||
touch $(STAGING_DIR)/usr/lib/libldap.so
|
||||
|
||||
install-dev: $(STAGING_DIR)/usr/lib/libldap.so
|
||||
|
||||
uninstall-dev:
|
||||
rm -rf $(STAGING_DIR)/usr/include/{lber,ldap}*.h
|
||||
rm -rf $(STAGING_DIR)/usr/lib/lib{lber,ldap}*.{a,so*}
|
||||
|
||||
compile: install-dev
|
||||
clean: uninstall-dev
|
1
openwrt/package/openldap/ipkg/libopenldap.conffiles
Normal file
1
openwrt/package/openldap/ipkg/libopenldap.conffiles
Normal file
@ -0,0 +1 @@
|
||||
/etc/openldap/ldap.conf
|
9
openwrt/package/openldap/ipkg/libopenldap.control
Normal file
9
openwrt/package/openldap/ipkg/libopenldap.control
Normal file
@ -0,0 +1,9 @@
|
||||
Package: libopenldap
|
||||
Priority: optional
|
||||
Section: libs
|
||||
Version: [TBDL]
|
||||
Architecture: [TBDL]
|
||||
Maintainer: Nico <nthill@free.fr>
|
||||
Source: http://nthill.free.fr/openwrt/sources/misc/openldap/
|
||||
Description: OpenLDAP client library
|
||||
Depends: libopenssl, libsasl2
|
9
openwrt/package/openldap/ipkg/openldap-utils.control
Normal file
9
openwrt/package/openldap/ipkg/openldap-utils.control
Normal file
@ -0,0 +1,9 @@
|
||||
Package: openldap-utils
|
||||
Priority: optional
|
||||
Section: admin
|
||||
Version: [TBDL]
|
||||
Architecture: [TBDL]
|
||||
Maintainer: Nico <nthill@free.fr>
|
||||
Source: http://nthill.free.fr/openwrt/sources/misc/openldap/
|
||||
Description: OpenLDAP client utilities
|
||||
Depends: libopenldap, libopenssl, libsasl2
|
12
openwrt/package/openldap/patches/500-cross-compile.patch
Normal file
12
openwrt/package/openldap/patches/500-cross-compile.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -ruN openldap-2.2.26-orig/libraries/liblunicode/Makefile.in openldap-2.2.26-1/libraries/liblunicode/Makefile.in
|
||||
--- openldap-2.2.26-orig/libraries/liblunicode/Makefile.in 2005-01-20 18:01:03.000000000 +0100
|
||||
+++ openldap-2.2.26-1/libraries/liblunicode/Makefile.in 2005-05-08 15:47:08.000000000 +0200
|
||||
@@ -29,7 +29,7 @@
|
||||
LDAP_INCDIR= ../../include
|
||||
LDAP_LIBDIR= ../../libraries
|
||||
|
||||
-ucgendat: $(XLIBS) ucgendat.o
|
||||
+ucgendat: ucgendat.o
|
||||
$(LTLINK) -o $@ ucgendat.o $(LIBS)
|
||||
./ucgendat $(srcdir)/UnicodeData.txt -x $(srcdir)/CompositionExclusions.txt
|
||||
|
36
openwrt/package/openldap/patches/750-no-strip.patch
Normal file
36
openwrt/package/openldap/patches/750-no-strip.patch
Normal file
@ -0,0 +1,36 @@
|
||||
diff -ruN openldap-2.2.26-orig/clients/tools/Makefile.in openldap-2.2.26-1/clients/tools/Makefile.in
|
||||
--- openldap-2.2.26-orig/clients/tools/Makefile.in 2005-01-20 18:00:55.000000000 +0100
|
||||
+++ openldap-2.2.26-1/clients/tools/Makefile.in 2005-05-08 15:47:08.000000000 +0200
|
||||
@@ -98,7 +98,7 @@
|
||||
-$(MKDIR) $(DESTDIR)$(bindir)
|
||||
@( \
|
||||
for prg in $(PROGRAMS); do \
|
||||
- $(LTINSTALL) $(INSTALLFLAGS) -s -m 755 $$prg$(EXEEXT) \
|
||||
+ $(LTINSTALL) $(INSTALLFLAGS) -m 755 $$prg$(EXEEXT) \
|
||||
$(DESTDIR)$(bindir); \
|
||||
done \
|
||||
)
|
||||
diff -ruN openldap-2.2.26-orig/servers/slapd/Makefile.in openldap-2.2.26-1/servers/slapd/Makefile.in
|
||||
--- openldap-2.2.26-orig/servers/slapd/Makefile.in 2005-01-20 18:01:05.000000000 +0100
|
||||
+++ openldap-2.2.26-1/servers/slapd/Makefile.in 2005-05-08 15:47:08.000000000 +0200
|
||||
@@ -355,7 +355,7 @@
|
||||
install-slapd: FORCE
|
||||
-$(MKDIR) $(DESTDIR)$(libexecdir)
|
||||
-$(MKDIR) $(DESTDIR)$(localstatedir)/run
|
||||
- $(LTINSTALL) $(INSTALLFLAGS) -s -m 755 \
|
||||
+ $(LTINSTALL) $(INSTALLFLAGS) -m 755 \
|
||||
slapd$(EXEEXT) $(DESTDIR)$(libexecdir)
|
||||
@for i in $(SUBDIRS); do \
|
||||
if test -d $$i -a -f $$i/Makefile ; then \
|
||||
diff -ruN openldap-2.2.26-orig/servers/slurpd/Makefile.in openldap-2.2.26-1/servers/slurpd/Makefile.in
|
||||
--- openldap-2.2.26-orig/servers/slurpd/Makefile.in 2005-01-20 18:01:19.000000000 +0100
|
||||
+++ openldap-2.2.26-1/servers/slurpd/Makefile.in 2005-05-08 15:47:08.000000000 +0200
|
||||
@@ -60,7 +60,7 @@
|
||||
@-$(INSTALL) -m 700 -d $(DESTDIR)$(localstatedir)/openldap-slurp
|
||||
@( \
|
||||
for prg in $(PROGRAMS); do \
|
||||
- $(LTINSTALL) $(INSTALLFLAGS) -s -m 755 $$prg$(EXEEXT) \
|
||||
+ $(LTINSTALL) $(INSTALLFLAGS) -m 755 $$prg$(EXEEXT) \
|
||||
$(DESTDIR)$(libexecdir); \
|
||||
done \
|
||||
)
|
Loading…
Reference in New Issue
Block a user