1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-02 19:02:20 +03:00

ar71xx: refresh patches

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17559 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
juhosg 2009-09-10 13:37:34 +00:00
parent 98337a7ad3
commit 994add5941
6 changed files with 11 additions and 11 deletions

View File

@ -1,7 +1,7 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
@@ -88,6 +88,11 @@ config AR8216_PHY
tristate "Driver for Atheros AR8216 switches"
@@ -92,6 +92,11 @@ config RTL8306_PHY
tristate "Driver for Realtek RTL8306S switches"
select SWCONFIG
+config MICREL_PHY
@ -14,9 +14,9 @@
depends on PHYLIB=y
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
@@ -18,6 +18,7 @@ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
obj-$(CONFIG_IP175C_PHY) += ip175c.o
@@ -19,6 +19,7 @@ obj-$(CONFIG_IP175C_PHY) += ip175c.o
obj-$(CONFIG_AR8216_PHY) += ar8216.o
obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o
+obj-$(CONFIG_MICREL_PHY) += micrel.o
obj-$(CONFIG_FIXED_PHY) += fixed.o

View File

@ -30,7 +30,7 @@
depends on USB_OHCI_HCD && (STB03xxx || PPC_MPC52xx)
--- a/drivers/usb/host/ehci-hcd.c
+++ b/drivers/usb/host/ehci-hcd.c
@@ -1072,6 +1072,11 @@ MODULE_LICENSE ("GPL");
@@ -1075,6 +1075,11 @@ MODULE_LICENSE ("GPL");
#define PLATFORM_DRIVER ixp4xx_ehci_driver
#endif

View File

@ -1,6 +1,6 @@
--- a/drivers/usb/host/ehci-q.c
+++ b/drivers/usb/host/ehci-q.c
@@ -1082,6 +1082,9 @@ static void end_unlink_async (struct ehc
@@ -1127,6 +1127,9 @@ static void end_unlink_async (struct ehc
ehci->reclaim = NULL;
start_unlink_async (ehci, next);
}

View File

@ -1,6 +1,6 @@
--- a/arch/mips/ar71xx/devices.c
+++ b/arch/mips/ar71xx/devices.c
@@ -792,6 +792,8 @@ static struct platform_device ar71xx_dsa
@@ -790,6 +790,8 @@ static struct platform_device ar71xx_dsa
void __init ar71xx_add_device_dsa(unsigned int id,
struct dsa_platform_data *d)
{
@ -9,7 +9,7 @@
switch (id) {
case 0:
d->netdev = &ar71xx_eth0_device.dev;
@@ -805,7 +807,10 @@ void __init ar71xx_add_device_dsa(unsign
@@ -803,7 +805,10 @@ void __init ar71xx_add_device_dsa(unsign
id);
return;
}

View File

@ -1,6 +1,6 @@
--- a/drivers/net/Kconfig
+++ b/drivers/net/Kconfig
@@ -2101,6 +2101,8 @@ config ACENIC_OMIT_TIGON_I
@@ -2103,6 +2103,8 @@ config ACENIC_OMIT_TIGON_I
The safe and default value for this is N.

View File

@ -1,6 +1,6 @@
--- a/arch/mips/ar71xx/devices.c
+++ b/arch/mips/ar71xx/devices.c
@@ -792,6 +792,8 @@ static struct platform_device ar71xx_dsa
@@ -790,6 +790,8 @@ static struct platform_device ar71xx_dsa
void __init ar71xx_add_device_dsa(unsigned int id,
struct dsa_platform_data *d)
{
@ -9,7 +9,7 @@
switch (id) {
case 0:
d->netdev = &ar71xx_eth0_device.dev;
@@ -805,7 +807,10 @@ void __init ar71xx_add_device_dsa(unsign
@@ -803,7 +805,10 @@ void __init ar71xx_add_device_dsa(unsign
id);
return;
}