1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-01 00:33:15 +03:00

[package] soloscli: fix new lines in soloscli

If the string received from the ADSL firmware is missing \n, add it in.

Signed-off-by: Nathan Williams <nathan@traverse.com.au>

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27096 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2011-06-02 14:38:01 +00:00
parent f0dde6b7e4
commit 9a842645c0
2 changed files with 8 additions and 4 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2006-2010 OpenWrt.org
# Copyright (C) 2006-2011 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=soloscli
PKG_VERSION:=0.11
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=solos-pci-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/openadsl

View File

@ -1,11 +1,15 @@
--- a/soloscli/soloscli.c
+++ b/soloscli/soloscli.c
@@ -238,7 +238,7 @@
@@ -238,7 +238,11 @@
}
if (strcmp(buf,pid) == 0) {
/* printf("Sequence matches.\n"); */
- printf("%s",bufp);
+ printf("%s\n",bufp);
+ if(buf[(len-1)] == '\n'){
+ printf("%s",bufp);
+ } else {
+ printf("%s\n",bufp);
+ }
} else {
printf("Sequence incorrect.\n");
buf[i] = '\n';