1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-16 14:32:49 +03:00

use target optimization cflags for ilbc codec

git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2707 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2005-12-16 19:19:22 +00:00
parent 14480c568e
commit a5cf9ff057

View File

@ -0,0 +1,21 @@
diff -ruN asterisk-1.2.1-old/codecs/ilbc/Makefile asterisk-1.2.1-new/codecs/ilbc/Makefile
--- asterisk-1.2.1-old/codecs/ilbc/Makefile 2005-11-29 19:24:39.000000000 +0100
+++ asterisk-1.2.1-new/codecs/ilbc/Makefile 2005-12-16 19:24:36.000000000 +0100
@@ -1,5 +1,5 @@
ARCH=$(PROC)
-CFLAGS+=-Wall -O3 -funroll-loops
+CFLAGS+=-Wall $(OPTIMIZE) -funroll-loops
ifneq (${OSARCH},CYGWIN)
CFLAGS += -fPIC
endif
@@ -15,8 +15,8 @@
$(LIB): $(OBJS)
- ar cr $(LIB) $(OBJS)
- ranlib $(LIB)
+ $(AR) cr $(LIB) $(OBJS)
+ $(RANLIB) $(LIB)
clean:
rm -f $(LIB) *.o