mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-27 17:13:11 +02:00
add watchdog package (thanks to Janos)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2874 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
6e2d81e960
commit
a80cf0453e
@ -257,6 +257,7 @@ source "package/pcmcia-cs/Config.in" # pcmcia-utils
|
||||
source "package/usbutils/Config.in" # lsusb
|
||||
source "package/strace/Config.in"
|
||||
source "package/udev/Config.in"
|
||||
source "package/watchdog/Config.in"
|
||||
|
||||
comment "FileSystems related"
|
||||
source "package/dosfstools/Config.in"
|
||||
|
@ -230,6 +230,7 @@ package-$(BR2_PACKAGE_VPNC) += vpnc
|
||||
package-$(BR2_PACKAGE_VRRPD) += vrrpd
|
||||
package-$(BR2_PACKAGE_VTUN) += vtun
|
||||
package-$(BR2_PACKAGE_VSFTPD) += vsftpd
|
||||
package-$(BR2_PACKAGE_WATCHDOG) += watchdog
|
||||
package-$(BR2_PACKAGE_WCCPD) += wccpd
|
||||
package-$(BR2_PACKAGE_WIFICONF) += wificonf
|
||||
package-$(BR2_PACKAGE_WIFIDOG) += wifidog
|
||||
|
7
package/watchdog/Config.in
Normal file
7
package/watchdog/Config.in
Normal file
@ -0,0 +1,7 @@
|
||||
config BR2_PACKAGE_WATCHDOG
|
||||
prompt "watchdog.......................... configurable watchdog"
|
||||
tristate
|
||||
default m if CONFIG_DEVEL
|
||||
help
|
||||
watchdog
|
||||
|
71
package/watchdog/Makefile
Normal file
71
package/watchdog/Makefile
Normal file
@ -0,0 +1,71 @@
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=watchdog
|
||||
PKG_VERSION:=5.2.4
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=c6ac132d92110eb2c4670d4f684105c3
|
||||
|
||||
PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/w/watchdog
|
||||
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION).orig
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(TOPDIR)/package/rules.mk
|
||||
|
||||
$(eval $(call PKG_template,WATCHDOG,watchdog,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||
|
||||
$(PKG_BUILD_DIR)/.configured:
|
||||
(cd $(PKG_BUILD_DIR); rm -rf config.cache; \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
|
||||
./configure \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--program-prefix="" \
|
||||
--program-suffix="" \
|
||||
--prefix=/usr \
|
||||
--exec-prefix=/usr \
|
||||
--bindir=/usr/bin \
|
||||
--datadir=/usr/share \
|
||||
--includedir=/usr/include \
|
||||
--infodir=/usr/share/info \
|
||||
--libdir=/usr/lib \
|
||||
--libexecdir=/usr/lib \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/share/man \
|
||||
--sbindir=/usr/sbin \
|
||||
--sysconfdir=/etc \
|
||||
$(DISABLE_NLS) \
|
||||
$(DISABLE_LARGEFILE) \
|
||||
);
|
||||
touch $@
|
||||
|
||||
$(PKG_BUILD_DIR)/.built:
|
||||
rm -rf $(PKG_INSTALL_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
CCOPT="$(TARGET_CFLAGS)" \
|
||||
INCLS="-I. -I$(STAGING_DIR)/usr/include" \
|
||||
LIBS="-L$(STAGING_DIR)/usr/lib" \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
touch $@
|
||||
|
||||
$(IPKG_WATCHDOG):
|
||||
install -d -m0755 $(IDIR_WATCHDOG)/etc
|
||||
cp -fpR $(PKG_INSTALL_DIR)/etc/watchdog.conf $(IDIR_WATCHDOG)/etc/
|
||||
install -d -m0755 $(IDIR_WATCHDOG)/etc/init.d
|
||||
install -m0755 ./files/watchdog.init $(IDIR_WATCHDOG)/etc/init.d/watchdog
|
||||
ln -sf watchdog $(IDIR_WATCHDOG)/etc/init.d/S90watchdog
|
||||
install -d -m0755 $(IDIR_WATCHDOG)/usr/sbin
|
||||
cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/watchdog $(IDIR_WATCHDOG)/usr/sbin/
|
||||
cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/wd_keepalive $(IDIR_WATCHDOG)/usr/sbin/
|
||||
$(RSTRIP) $(IDIR_WATCHDOG)
|
||||
$(IPKG_BUILD) $(IDIR_WATCHDOG) $(PACKAGE_DIR)
|
18
package/watchdog/files/watchdog.init
Normal file
18
package/watchdog/files/watchdog.init
Normal file
@ -0,0 +1,18 @@
|
||||
#!/bin/sh
|
||||
|
||||
RUN_D=/var/run
|
||||
PID_F=$RUN_D/watchdog.pid
|
||||
|
||||
case $1 in
|
||||
start)
|
||||
/usr/sbin/watchdog
|
||||
;;
|
||||
stop)
|
||||
[ -f $PID_F ] && kill $(cat $PID_F) >/dev/null 2>&1
|
||||
;;
|
||||
*)
|
||||
echo "usage: $0 (start|stop)"
|
||||
exit 1
|
||||
esac
|
||||
|
||||
exit $?
|
1
package/watchdog/ipkg/watchdog.conffiles
Normal file
1
package/watchdog/ipkg/watchdog.conffiles
Normal file
@ -0,0 +1 @@
|
||||
/etc/watchdog.conf
|
4
package/watchdog/ipkg/watchdog.control
Normal file
4
package/watchdog/ipkg/watchdog.control
Normal file
@ -0,0 +1,4 @@
|
||||
Package: watchdog
|
||||
Priority: opt
|
||||
Section: sys
|
||||
Description: watchdog
|
11
package/watchdog/patches/01-fstab-sys_siglist.patch
Normal file
11
package/watchdog/patches/01-fstab-sys_siglist.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- watchdog-5.2.4.orig.orig/src/fstab.c 2003-01-28 07:47:38.000000000 +0100
|
||||
+++ watchdog-5.2.4.orig/src/fstab.c 2005-12-29 20:05:47.859043112 +0100
|
||||
@@ -237,7 +237,7 @@
|
||||
/* Ensure that the lock is released if we are interrupted. */
|
||||
static void
|
||||
handler (int sig) {
|
||||
- die (EX_USER, "%s", sys_siglist[sig]);
|
||||
+ die (EX_USER, "%s", "sys_siglist[sig]");
|
||||
}
|
||||
|
||||
static void
|
Loading…
Reference in New Issue
Block a user