mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-27 17:15:00 +02:00
madwifi: reduce the size of the multicall tool binary
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18112 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
b3c44ec1cc
commit
ad35d749fe
@ -173,16 +173,17 @@
|
||||
if(strcmp(progname, "athstats") == 0)
|
||||
--- a/tools/Makefile
|
||||
+++ b/tools/Makefile
|
||||
@@ -48,6 +48,8 @@ endif
|
||||
@@ -48,14 +48,16 @@ endif
|
||||
|
||||
all: compile
|
||||
|
||||
+DEBUG = -DAR_DEBUG
|
||||
+
|
||||
ALLPROGS= athstats 80211stats athkey athchans athctrl \
|
||||
athdebug 80211debug wlanconfig ath_info
|
||||
- athdebug 80211debug wlanconfig ath_info
|
||||
+ $(if $(DEBUG),athdebug 80211debug) wlanconfig ath_info
|
||||
|
||||
@@ -55,7 +57,7 @@ OBJS= $(patsubst %,%.o,$(ALLPROGS))
|
||||
OBJS= $(patsubst %,%.o,$(ALLPROGS))
|
||||
|
||||
INCS= -I. -I../ath -I$(HAL) -I$(TOP) -I$(ATH_HAL)
|
||||
CFLAGS= -g -O2 -Wall
|
||||
|
@ -568,7 +568,7 @@
|
||||
|
||||
-ALLPROGS= athstats 80211stats athkey athchans athctrl \
|
||||
+ALLPROGS= athstats 80211stats athkey athchans \
|
||||
athdebug 80211debug wlanconfig ath_info
|
||||
$(if $(DEBUG),athdebug 80211debug) wlanconfig ath_info
|
||||
|
||||
OBJS= $(patsubst %,%.o,$(ALLPROGS))
|
||||
--- a/tools/athctrl.c
|
||||
|
Loading…
Reference in New Issue
Block a user