1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-20 12:21:59 +03:00

privoxy port, first try

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3364 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
wbx 2006-03-13 20:48:48 +00:00
parent 69e6087004
commit af3c8d623f
7 changed files with 131 additions and 0 deletions

View File

@ -122,6 +122,7 @@ source "package/portsentry/Config.in"
source "package/ppp/Config.in"
source "package/pptp/Config.in"
source "package/pptpd/Config.in"
source "package/privoxy/Config.in"
source "package/ptunnel/Config.in"
source "package/quagga/Config.in"
source "package/raddump/Config.in"

View File

@ -182,6 +182,7 @@ package-$(BR2_COMPILE_POSTGRESQL) += postgresql
package-$(BR2_PACKAGE_PPP) += ppp
package-$(BR2_PACKAGE_PPTP) += pptp
package-$(BR2_PACKAGE_PPTPD) += pptpd
package-$(BR2_PACKAGE_PRIVOXY) += privoxy
package-$(BR2_PACKAGE_PSYBNC) += psybnc
package-$(BR2_PACKAGE_PTUNNEL) += ptunnel
package-$(BR2_PACKAGE_QUAGGA) += quagga
@ -344,6 +345,7 @@ peerguardian-compile: libpthread-compile
portmap-compile: tcp_wrappers-compile
postgresql-compile: zlib-compile
ppp-compile: linux-atm-compile libpcap-compile
privoxy-compile: pcre-compile
ptunnel-compile: libpcap-compile
quagga-compile: readline-compile ncurses-compile
raddump-compile: openssl-compile libpcap-compile

View File

@ -0,0 +1,14 @@
config BR2_PACKAGE_PRIVOXY
prompt "privoxy........................... web proxy with advanced filtering capabilities"
tristate
default m if CONFIG_DEVEL
help
Privoxy is a web proxy with advanced filtering capabilities for
protecting privacy, modifying web page content, managing cookies,
controlling access, and removing ads, banners, pop-ups and other
obnoxious Internet junk. Privoxy has a very flexible configuration
and can be customized to suit individual needs and tastes. Privoxy
has application for both stand-alone systems and multi-user networks.
http://www.privoxy.org/

View File

@ -0,0 +1,64 @@
# $Id$
include $(TOPDIR)/rules.mk
PKG_NAME:=privoxy
PKG_VERSION:=3.0.3
PKG_RELEASE:=1
PKG_MD5SUM:=b0710be8af09409bfb03f52523a17010
PKG_SOURCE_URL:=@SF/ijbswa
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-stable-src.tar.gz
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-stable
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,PRIVOXY,privoxy,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(PKG_BUILD_DIR)/.configured:
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
autoheader && autoconf && \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(strip $(TARGET_CFLAGS))" \
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
./configure \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
--program-prefix="" \
--program-suffix="" \
--prefix=/usr \
--exec-prefix=/usr \
--bindir=/usr/bin \
--datadir=/usr/share \
--includedir=/usr/include \
--infodir=/usr/share/info \
--libdir=/usr/lib \
--libexecdir=/usr/lib \
--localstatedir=/var \
--mandir=/usr/share/man \
--sbindir=/usr/sbin \
--sysconfdir=/etc \
$(DISABLE_NLS) \
--disable-static \
);
touch $(PKG_BUILD_DIR)/.configured
$(PKG_BUILD_DIR)/.built:
$(MAKE) -C $(PKG_BUILD_DIR) \
SPECIAL_CFLAGS="-pthread -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib"
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
install
touch $(PKG_BUILD_DIR)/.built
$(IPKG_PRIVOXY):
install -d -m0755 $(IDIR_PRIVOXY)/usr/sbin $(IDIR_PRIVOXY)/etc/privoxy
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/privoxy $(IDIR_PRIVOXY)/usr/sbin/
$(RSTRIP) $(IDIR_PRIVOXY)
$(IPKG_BUILD) $(IDIR_PRIVOXY) $(PACKAGE_DIR)

View File

@ -0,0 +1,5 @@
Package: privoxy
Version: 3.0.3
Section: net
Description: web proxy with advanced filtering capabilities
Priority: optional

View File

@ -0,0 +1,13 @@
diff -Nur privoxy-3.0.3-stable/configure.in privoxy-3.0.3-stable.patched/configure.in
--- privoxy-3.0.3-stable/configure.in 2004-01-30 10:26:03.000000000 +0100
+++ privoxy-3.0.3-stable.patched/configure.in 2006-03-13 20:50:57.000000000 +0100
@@ -1092,7 +1092,8 @@
AC_PROG_GCC_TRADITIONAL
dnl uncommenting does not work for swa. suse linux
dnl AC_FUNC_MALLOC
-AC_FUNC_SETPGRP
+dnl uncommenting does not work for openwrt
+dnl AC_FUNC_SETPGRP
AC_TYPE_SIGNAL
dnl uncommenting does not work for swa. suse linux
dnl AC_FUNC_STAT

View File

@ -0,0 +1,32 @@
diff -Nur privoxy-3.0.3-stable/GNUmakefile.in privoxy-3.0.3-stable.patched/GNUmakefile.in
--- privoxy-3.0.3-stable/GNUmakefile.in 2004-01-31 02:15:33.000000000 +0100
+++ privoxy-3.0.3-stable.patched/GNUmakefile.in 2006-03-13 21:39:29.000000000 +0100
@@ -55,17 +55,17 @@
USER = @USER@
GROUP = @GROUP@
-prefix = @prefix@
-exec_prefix = @exec_prefix@
-CONF_BASE = @sysconfdir@
-SBIN_DEST = @sbindir@
-MAN_DIR = @mandir@
-MAN_DEST = $(MAN_DIR)/man1
-SHARE_DEST = @datadir@
-DOC_DEST = $(SHARE_DEST)/doc/privoxy
-VAR_DEST = @localstatedir@
-LOGS_DEST = $(VAR_DEST)/log/privoxy
-PIDS_DEST = $(VAR_DEST)/run
+prefix = $(DESTDIR)@prefix@
+exec_prefix = $(DESTDIR)@exec_prefix@
+CONF_BASE = $(DESTDIR)@sysconfdir@
+SBIN_DEST = $(DESTDIR)@sbindir@
+MAN_DIR = $(DESTDIR)@mandir@
+MAN_DEST = $(DESTDIR)$(MAN_DIR)/man1
+SHARE_DEST = $(DESTDIR)@datadir@
+DOC_DEST = $(DESTDIR)$(SHARE_DEST)/doc/privoxy
+VAR_DEST = $(DESTDIR)@localstatedir@
+LOGS_DEST = $(DESTDIR)$(VAR_DEST)/log/privoxy
+PIDS_DEST = $(DESTDIR)$(VAR_DEST)/run
# if $prefix = /usr/local then the default CONFDEST change from
# CONF_DEST = $(CONF_BASE) to CONF_DEST = $(CONF_BASE)/privoxy