1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-01 00:41:41 +03:00

[pjsip] fixes ccache compile and adds missing -lc

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32387 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
blogic 2012-06-15 23:42:48 +00:00
parent 7ae94609de
commit b008f41eef
2 changed files with 3 additions and 4 deletions

View File

@ -87,7 +87,7 @@ endef
define Build/Compile
CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS) $(TARGET_CPPFLAGS) $(EXTRA_CPPFLAGS)" \
CXXFLAGS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS) $(TARGET_CPPFLAGS) $(EXTRA_CPPFLAGS)" \
LDFLAGS="$(TARGET_LDFLAGS) $(EXTRA_LDFLAGS) $(LIBGCC_S) -lm" \
LDFLAGS="$(TARGET_LDFLAGS) -lc $(LIBGCC_S) -lm" \
$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR)/$(MAKE_PATH)
endef

View File

@ -1,14 +1,13 @@
--- a/aconfigure.ac
+++ b/aconfigure.ac
@@ -48,9 +48,9 @@ if test -z "$CROSS_COMPILE"; then
@@ -48,9 +48,8 @@ if test -z "$CROSS_COMPILE"; then
CROSS_COMPILE=`echo ${CC} | sed 's/gcc//'`
fi
-if test "$AR" = ""; then AR="${CROSS_COMPILE}ar rv"; fi
+AR="${CROSS_COMPILE}ar rv"
+AR="${AR} rv"
AC_SUBST(AR)
-if test "$LD" = ""; then LD="$CC"; fi
+LD="${CROSS_COMPILE}gcc"
AC_SUBST(LD)
if test "$LDOUT" = ""; then LDOUT="-o "; fi
AC_SUBST(LDOUT)