mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-10 14:21:51 +02:00
add pcmcia-cs package
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2546 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
c6cff70707
commit
b069bec88d
@ -221,6 +221,7 @@ source "package/setserial/Config.in"
|
||||
comment "Utilities"
|
||||
source "package/gdbserver/Config.in"
|
||||
source "package/madwifi-tools/Config.in"
|
||||
source "package/pcmcia-cs/Config.in" # pcmcia-utils
|
||||
source "package/usbutils/Config.in" # lsusb
|
||||
source "package/strace/Config.in"
|
||||
|
||||
|
@ -140,6 +140,7 @@ package-$(BR2_COMPILE_OSIRIS) += osiris
|
||||
package-$(BR2_PACKAGE_PALANTIR) += palantir
|
||||
package-$(BR2_PACKAGE_P910ND) += p910nd
|
||||
package-$(BR2_PACKAGE_PARPROUTED) += parprouted
|
||||
package-$(BR2_COMPILE_PCMCIA_CS) += pcmcia-cs
|
||||
package-$(BR2_COMPILE_PCRE) += pcre
|
||||
package-$(BR2_COMPILE_PHP4) += php4
|
||||
package-$(BR2_COMPILE_PHP5) += php5
|
||||
|
16
openwrt/package/pcmcia-cs/Config.in
Normal file
16
openwrt/package/pcmcia-cs/Config.in
Normal file
@ -0,0 +1,16 @@
|
||||
config BR2_COMPILE_PCMCIA_CS
|
||||
tristate
|
||||
default n
|
||||
depends BR2_PACKAGE_PCMCIA_UTILS
|
||||
|
||||
config BR2_PACKAGE_PCMCIA_UTILS
|
||||
prompt "pcmcia-utils...................... PCMCIA/Cardbus management utilities"
|
||||
tristate
|
||||
select BR2_COMPILE_PCMCIA_CS
|
||||
select BR2_PACKAGE_KMOD_PCMCIA_CORE
|
||||
default m if CONFIG_DEVEL
|
||||
help
|
||||
PCMCIA/Cardbus management utilities
|
||||
|
||||
http://pcmcia-cs.sourceforge.net/
|
||||
|
56
openwrt/package/pcmcia-cs/Makefile
Normal file
56
openwrt/package/pcmcia-cs/Makefile
Normal file
@ -0,0 +1,56 @@
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=pcmcia-cs
|
||||
PKG_VERSION:=3.2.8
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=0d6d65be8896eff081aee996049afaa5
|
||||
|
||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(TOPDIR)/package/rules.mk
|
||||
|
||||
$(eval $(call PKG_template,PCMCIA_UTILS,pcmcia-utils,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||
|
||||
$(PKG_BUILD_DIR)/.configured:
|
||||
( cd $(PKG_BUILD_DIR); \
|
||||
./Configure \
|
||||
--noprompt \
|
||||
--kernel="$(LINUX_DIR)" \
|
||||
--target="$(PKG_INSTALL_DIR)" \
|
||||
--arch="$(ARCH)" \
|
||||
--ucc="$(TARGET_CC)" \
|
||||
--uflags="$(TARGET_CFLAGS)" \
|
||||
--srctree \
|
||||
--cardbus \
|
||||
--noapm \
|
||||
--nopnp \
|
||||
--notrust \
|
||||
--nox11 \
|
||||
--sysv --rcdir="/etc" \
|
||||
)
|
||||
touch $@
|
||||
|
||||
$(PKG_BUILD_DIR)/.built:
|
||||
rm -rf $(PKG_INSTALL_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
all install
|
||||
touch $@
|
||||
|
||||
$(IPKG_PCMCIA_UTILS):
|
||||
install -m0755 -d $(IDIR_PCMCIA_UTILS)/etc
|
||||
cp -fpR $(PKG_INSTALL_DIR)/etc/pcmcia $(IDIR_PCMCIA_UTILS)/etc/
|
||||
install -m0755 -d $(IDIR_PCMCIA_UTILS)/usr/sbin
|
||||
cp -fpR $(PKG_INSTALL_DIR)/sbin/cardctl $(IDIR_PCMCIA_UTILS)/usr/sbin/
|
||||
cp -fpR $(PKG_INSTALL_DIR)/sbin/cardmgr $(IDIR_PCMCIA_UTILS)/usr/sbin/
|
||||
$(RSTRIP) $(IDIR_PCMCIA_UTILS)
|
||||
$(IPKG_BUILD) $(IDIR_PCMCIA_UTILS) $(PACKAGE_DIR)
|
||||
|
10
openwrt/package/pcmcia-cs/ipkg/pcmcia-utils.conffiles
Normal file
10
openwrt/package/pcmcia-cs/ipkg/pcmcia-utils.conffiles
Normal file
@ -0,0 +1,10 @@
|
||||
/etc/pcmcia/config.opts
|
||||
/etc/pcmcia/ftl.opts
|
||||
/etc/pcmcia/ide.opts
|
||||
/etc/pcmcia/ieee1394.opts
|
||||
/etc/pcmcia/memory.opts
|
||||
/etc/pcmcia/network.opts
|
||||
/etc/pcmcia/parport.opts
|
||||
/etc/pcmcia/scsi.opts
|
||||
/etc/pcmcia/serial.opts
|
||||
/etc/pcmcia/wireless.opts
|
5
openwrt/package/pcmcia-cs/ipkg/pcmcia-utils.control
Normal file
5
openwrt/package/pcmcia-cs/ipkg/pcmcia-utils.control
Normal file
@ -0,0 +1,5 @@
|
||||
Package: pcmcia-utils
|
||||
Priority: optional
|
||||
Section: sys
|
||||
Depends: kmod-pcmcia-core
|
||||
Description: PCMCIA/Cardbus management utilities
|
@ -0,0 +1,14 @@
|
||||
diff -ruN pcmcia-cs-3.2.8-old/etc/config pcmcia-cs-3.2.8-new/etc/config
|
||||
--- pcmcia-cs-3.2.8-old/etc/config 2004-07-16 18:38:25.000000000 +0200
|
||||
+++ pcmcia-cs-3.2.8-new/etc/config 2005-11-21 08:52:54.000000000 +0100
|
||||
@@ -2413,6 +2413,10 @@
|
||||
pci 0x115d, 0x0101
|
||||
bind "serial_cb"
|
||||
|
||||
+card "Novatel Wireless - Merlin U630 UMTS Modem"
|
||||
+ manfid 0x00a4, 0x0276
|
||||
+ bind "serial_cs" to 0, "serial_cs" to 1
|
||||
+
|
||||
# Include configuration files for add-on drivers
|
||||
|
||||
source ./*.conf
|
Loading…
Reference in New Issue
Block a user