1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-11-28 06:45:19 +02:00

extend mkdep fix (fixes #36)

git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2414 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nbd 2005-11-11 13:40:51 +00:00
parent bf111601e9
commit b0bea448ab

View File

@ -9,3 +9,14 @@
ifdef ALL_SUB_DIRS ifdef ALL_SUB_DIRS
$(MAKE) $(patsubst %,_sfdep_%,$(ALL_SUB_DIRS)) _FASTDEP_ALL_SUB_DIRS="$(ALL_SUB_DIRS)" $(MAKE) $(patsubst %,_sfdep_%,$(ALL_SUB_DIRS)) _FASTDEP_ALL_SUB_DIRS="$(ALL_SUB_DIRS)"
endif endif
--- linux-2.4.30/Makefile.old 2005-11-11 14:27:55.878482250 +0100
+++ linux-2.4.30/Makefile 2005-11-11 14:28:57.926360000 +0100
@@ -509,7 +509,7 @@
ifdef CONFIG_MODVERSIONS
$(MAKE) update-modverfile
endif
- scripts/mkdep -- `find $(FINDHPATH) \( -name SCCS -o -name .svn \) -prune -o -follow -name \*.h ! -name modversions.h -print` > .hdepend
+ find $(FINDHPATH) \( -name SCCS -o -name .svn \) -prune -o -follow -name \*.h ! -name modversions.h -print | xargs scripts/mkdep -- > .hdepend
scripts/mkdep -- init/*.c > .depend
ifdef CONFIG_MODVERSIONS