1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-30 00:56:21 +03:00

[package] add uboot-pxa for Gumstix boards

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33608 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2012-10-03 16:14:21 +00:00
parent 09c7ab130e
commit b1f4fb5c48
2 changed files with 101 additions and 0 deletions

View File

@ -0,0 +1,88 @@
#
# Copyright (C) 2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=u-boot
PKG_VERSION:=2011.08.25
PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://github.com/ashcharles/verdex-uboot.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_VERSION:=ca6bf3ef6ac5f5132a359b43dfa31e07076b74b7
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
include $(INCLUDE_DIR)/package.mk
define uboot/Default
TITLE:=
CONFIG:=
IMAGE:=
endef
define uboot/gumstix
TITLE:=U-Boot for the Gumstix Verdex
endef
UBOOTS:=gumstix
define Package/uboot/template
define Package/uboot-pxa-$(1)
SECTION:=boot
CATEGORY:=Boot Loaders
DEPENDS:=@TARGET_pxa
TITLE:=$(2)
URL:=http://www.denx.de/wiki/U-Boot
VARIANT:=$(1)
endef
endef
define BuildUBootPackage
$(eval $(uboot/Default))
$(eval $(uboot/$(1)))
$(call Package/uboot/template,$(1),$(TITLE))
endef
ifdef BUILD_VARIANT
$(eval $(call uboot/$(BUILD_VARIANT)))
UBOOT_CONFIG:=$(if $(CONFIG),$(CONFIG),$(BUILD_VARIANT))
UBOOT_IMAGE:=$(if $(IMAGE),$(IMAGE),openwrt-$(BOARD)-$(BUILD_VARIANT)-u-boot.bin)
endif
define Build/Configure
$(MAKE) -C $(PKG_BUILD_DIR) \
$(UBOOT_CONFIG)_config
endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
u-boot.bin \
CROSS_COMPILE=$(TARGET_CROSS)
endef
define Package/uboot/install/default
$(INSTALL_DIR) $(BIN_DIR)
$(CP) $(PKG_BUILD_DIR)/u-boot.bin \
$(BIN_DIR)/openwrt-$(BOARD)-$(1)-u-boot.bin
endef
define Package/uboot/install/template
define Package/uboot-pxa-$(1)/install
$(call Package/uboot/install/default,$(2))
endef
endef
$(foreach u,$(UBOOTS), \
$(eval $(call Package/uboot/install/template,$(u),$(u))) \
)
$(foreach u,$(UBOOTS), \
$(eval $(call BuildUBootPackage,$(u))) \
$(eval $(call BuildPackage,uboot-pxa-$(u))) \
)

View File

@ -0,0 +1,13 @@
diff --git a/include/configs/gumstix.h b/include/configs/gumstix.h
index 319da63..5483993 100644
--- a/include/configs/gumstix.h
+++ b/include/configs/gumstix.h
@@ -136,7 +136,7 @@
#define CONFIG_MISC_INIT_R /* misc_init_r function in gumstix sets board serial number */
#define CONFIG_BOOTFILE boot/uImage
-#define CONFIG_BOOTARGS "console=ttyS0,115200n8 root=1f01 rootfstype=jffs2 reboot=cold,hard"
+#define CONFIG_BOOTARGS "console=ttyS0,115200n8 root=1f01 rootfstype=squashfs,jffs2 reboot=cold,hard"
#define CONFIG_BOOTCOMMAND "icache on; setenv stderr nulldev; setenv stdout nulldev; if pinit on && fatload ide 0 a2000000 gumstix-factory.script; then setenv stdout serial; setenv stderr serial; echo Found gumstix-factory.script on CF...; autoscr; else if mmcinit && fatload mmc 0 a2000000 gumstix-factory.script; then setenv stdout serial; setenv stderr serial; echo Found gumstix-factory.script on MMC...; autoscr; else setenv stdout serial; setenv stderr serial; katload 100000 && bootm; fi; fi"
#define CONFIG_BOOTDELAY 2 /* in seconds */
#define CONFIG_EXTRA_ENV_SETTINGS "verify=no"