mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-23 22:34:04 +02:00
[package] linux-atm: Update to stable version 2.5.1 from upstream project
This commit integrates the upstream version of the linux-atm tools version 2.5.1. It simplify the patchset but keeps the debian-patches, prevent the usage of libflex on the target, and let the package compiles every tools. The Makefile only installs atmarp & atmarpd, but some useful debug programs are also included (like aread/awrite, atmdump,...) in the makefile, but commented by default. Signed-off-by: Obinou <obconseil@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20216 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
30c92b3390
commit
b69c2d4576
@ -1,4 +1,4 @@
|
||||
#
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
@ -8,14 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=linux-atm
|
||||
PKG_VERSION:=2.4.1
|
||||
PKG_VERSION:=2.5.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
|
||||
PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/l/linux-atm/
|
||||
PKG_MD5SUM:=84fef49cc39ff2605204246666f65864
|
||||
|
||||
PKG_FIXUP:=libtool
|
||||
PKG_MD5SUM:=9560b0e1f410a05b849dfdab465dd758
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
@ -23,7 +21,6 @@ define Package/linux-atm
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE:=Linux ATM library
|
||||
DEPENDS:=+kmod-atm
|
||||
URL:=http://linux-atm.sourceforge.net/
|
||||
endef
|
||||
|
||||
@ -81,6 +78,36 @@ define Package/atm-tools/install
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/atmarp{,d} $(1)/usr/sbin/
|
||||
$(INSTALL_DIR) $(1)/lib/network
|
||||
$(INSTALL_BIN) ./files/ipoa.sh $(1)/lib/network/
|
||||
$(INSTALL_DIR) $(1)/usr/bin/
|
||||
|
||||
#
|
||||
#The following is disabled by default but still useful for some debugging
|
||||
#
|
||||
# $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/atmaddr $(1)/usr/sbin/
|
||||
# $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/atmloop $(1)/usr/sbin/
|
||||
# $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/atmtcp $(1)/usr/sbin/
|
||||
# $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/esi $(1)/usr/sbin/
|
||||
# $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/aread $(1)/usr/bin/
|
||||
# $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/awrite $(1)/usr/bin/
|
||||
# $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/atmdiag $(1)/usr/bin/
|
||||
# $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/atmdump $(1)/usr/bin/
|
||||
#
|
||||
# The following is really for some specific application, and obsolete for most of it
|
||||
#
|
||||
# $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/atmsigd $(1)/usr/sbin/
|
||||
# $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/bus $(1)/usr/sbin/
|
||||
# $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ilmid $(1)/usr/sbin/
|
||||
# $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ilmidiag $(1)/usr/sbin/
|
||||
# $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/lecs $(1)/usr/sbin/
|
||||
# $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/les $(1)/usr/sbin/
|
||||
# $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/mpcd $(1)/usr/sbin/
|
||||
# $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/zeppelin $(1)/usr/sbin/
|
||||
# $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/atmswitch $(1)/usr/bin/
|
||||
# $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/saaldump $(1)/usr/bin/
|
||||
# $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/sonetdiag $(1)/usr/bin/
|
||||
# $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/svc_recv $(1)/usr/bin/
|
||||
# $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/svc_send $(1)/usr/bin/
|
||||
# $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ttcp_atm $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,linux-atm))
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -1,162 +0,0 @@
|
||||
Index: linux-atm-2.4.1/configure.in
|
||||
===================================================================
|
||||
--- linux-atm-2.4.1.orig/configure.in 2007-10-20 19:19:10.594232210 +0200
|
||||
+++ linux-atm-2.4.1/configure.in 2007-10-20 19:19:16.214552491 +0200
|
||||
@@ -153,26 +153,5 @@
|
||||
src/Makefile \
|
||||
src/include/Makefile \
|
||||
src/lib/Makefile \
|
||||
- src/test/Makefile \
|
||||
- src/debug/Makefile \
|
||||
- src/qgen/Makefile \
|
||||
- src/saal/Makefile \
|
||||
- src/sigd/Makefile \
|
||||
- src/maint/Makefile \
|
||||
- src/arpd/Makefile \
|
||||
- src/ilmid/Makefile \
|
||||
- src/ilmid/asn1/Makefile \
|
||||
- src/man/Makefile \
|
||||
- src/led/Makefile \
|
||||
- src/lane/Makefile \
|
||||
- src/mpoad/Makefile \
|
||||
- src/switch/Makefile \
|
||||
- src/switch/debug/Makefile \
|
||||
- src/switch/tcp/Makefile \
|
||||
- src/config/Makefile \
|
||||
- src/config/init-redhat/Makefile \
|
||||
- src/extra/Makefile \
|
||||
- src/extra/linux-atm.spec \
|
||||
- src/extra/ANS/Makefile
|
||||
)
|
||||
|
||||
Index: linux-atm-2.4.1/src/Makefile.am
|
||||
===================================================================
|
||||
--- linux-atm-2.4.1.orig/src/Makefile.am 2007-10-20 19:19:10.602232664 +0200
|
||||
+++ linux-atm-2.4.1/src/Makefile.am 2007-10-20 19:19:16.218552720 +0200
|
||||
@@ -1,3 +1,2 @@
|
||||
-SUBDIRS = include lib test debug qgen saal sigd maint arpd ilmid man led lane \
|
||||
- mpoad switch config extra
|
||||
+SUBDIRS = include lib
|
||||
|
||||
Index: linux-atm-2.4.1/src/include/linux/atmbr2684.h
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ linux-atm-2.4.1/src/include/linux/atmbr2684.h 2007-10-20 19:19:16.230553402 +0200
|
||||
@@ -0,0 +1,117 @@
|
||||
+#ifndef _LINUX_ATMBR2684_H
|
||||
+#define _LINUX_ATMBR2684_H
|
||||
+
|
||||
+#include <linux/atm.h>
|
||||
+#include <linux/if.h> /* For IFNAMSIZ */
|
||||
+#include <linux/if_ether.h> /* ETH_P_* */
|
||||
+
|
||||
+/*
|
||||
+ * Type of media we're bridging (ethernet, token ring, etc) Currently only
|
||||
+ * ethernet is supported
|
||||
+ */
|
||||
+#define BR2684_MEDIA_ETHERNET (0) /* 802.3 */
|
||||
+#define BR2684_MEDIA_802_4 (1) /* 802.4 */
|
||||
+#define BR2684_MEDIA_TR (2) /* 802.5 - token ring */
|
||||
+#define BR2684_MEDIA_FDDI (3)
|
||||
+#define BR2684_MEDIA_802_6 (4) /* 802.6 */
|
||||
+
|
||||
+/*
|
||||
+ * Is there FCS inbound on this VC? This currently isn't supported.
|
||||
+ */
|
||||
+#define BR2684_FCSIN_NO (0)
|
||||
+#define BR2684_FCSIN_IGNORE (1)
|
||||
+#define BR2684_FCSIN_VERIFY (2)
|
||||
+
|
||||
+/*
|
||||
+ * Is there FCS outbound on this VC? This currently isn't supported.
|
||||
+ */
|
||||
+#define BR2684_FCSOUT_NO (0)
|
||||
+#define BR2684_FCSOUT_SENDZERO (1)
|
||||
+#define BR2684_FCSOUT_GENERATE (2)
|
||||
+
|
||||
+/*
|
||||
+ * Does this VC include LLC encapsulation?
|
||||
+ */
|
||||
+#define BR2684_ENCAPS_VC (0) /* VC-mux */
|
||||
+#define BR2684_ENCAPS_LLC (1)
|
||||
+#define BR2684_ENCAPS_AUTODETECT (2) /* Unsuported */
|
||||
+
|
||||
+/*
|
||||
+ * Is this VC bridged or routed?
|
||||
+ */
|
||||
+
|
||||
+#define BR2684_PAYLOAD_ROUTED (0)
|
||||
+#define BR2684_PAYLOAD_BRIDGED (1)
|
||||
+
|
||||
+
|
||||
+/*
|
||||
+ * This is for the ATM_NEWBACKENDIF call - these are like socket families:
|
||||
+ * the first element of the structure is the backend number and the rest
|
||||
+ * is per-backend specific
|
||||
+ */
|
||||
+struct atm_newif_br2684 {
|
||||
+ atm_backend_t backend_num; /* ATM_BACKEND_BR2684 */
|
||||
+ int media; /* BR2684_MEDIA_* */
|
||||
+ char ifname[IFNAMSIZ];
|
||||
+ int mtu;
|
||||
+ int payload; /* bridged or routed */
|
||||
+};
|
||||
+
|
||||
+/*
|
||||
+ * This structure is used to specify a br2684 interface - either by a
|
||||
+ * positive integer (returned by ATM_NEWBACKENDIF) or the interfaces name
|
||||
+ */
|
||||
+#define BR2684_FIND_BYNOTHING (0)
|
||||
+#define BR2684_FIND_BYNUM (1)
|
||||
+#define BR2684_FIND_BYIFNAME (2)
|
||||
+struct br2684_if_spec {
|
||||
+ int method; /* BR2684_FIND_* */
|
||||
+ union {
|
||||
+ char ifname[IFNAMSIZ];
|
||||
+ int devnum;
|
||||
+ } spec;
|
||||
+};
|
||||
+
|
||||
+/*
|
||||
+ * This is for the ATM_SETBACKEND call - these are like socket families:
|
||||
+ * the first element of the structure is the backend number and the rest
|
||||
+ * is per-backend specific
|
||||
+ */
|
||||
+struct atm_backend_br2684 {
|
||||
+ atm_backend_t backend_num; /* ATM_BACKEND_BR2684 */
|
||||
+ struct br2684_if_spec ifspec;
|
||||
+ int fcs_in; /* BR2684_FCSIN_* */
|
||||
+ int fcs_out; /* BR2684_FCSOUT_* */
|
||||
+ int fcs_auto; /* 1: fcs_{in,out} disabled if no FCS rx'ed */
|
||||
+ int encaps; /* BR2684_ENCAPS_* */
|
||||
+ int payload; /* BR2684_PAYLOAD_* */
|
||||
+ int has_vpiid; /* 1: use vpn_id - Unsupported */
|
||||
+ __u8 vpn_id[7];
|
||||
+ int send_padding; /* unsupported */
|
||||
+ int min_size; /* we will pad smaller packets than this */
|
||||
+};
|
||||
+
|
||||
+/*
|
||||
+ * The BR2684_SETFILT ioctl is an experimental mechanism for folks
|
||||
+ * terminating a large number of IP-only vcc's. When netfilter allows
|
||||
+ * efficient per-if in/out filters, this support will be removed
|
||||
+ */
|
||||
+struct br2684_filter {
|
||||
+ __u32 prefix; /* network byte order */
|
||||
+ __u32 netmask; /* 0 = disable filter */
|
||||
+};
|
||||
+
|
||||
+struct br2684_filter_set {
|
||||
+ struct br2684_if_spec ifspec;
|
||||
+ struct br2684_filter filter;
|
||||
+};
|
||||
+
|
||||
+enum br2684_payload {
|
||||
+ p_routed = BR2684_PAYLOAD_ROUTED,
|
||||
+ p_bridged = BR2684_PAYLOAD_BRIDGED,
|
||||
+};
|
||||
+
|
||||
+#define BR2684_SETFILT _IOW( 'a', ATMIOC_BACKEND + 0, \
|
||||
+ struct br2684_filter_set)
|
||||
+
|
||||
+#endif /* _LINUX_ATMBR2684_H */
|
@ -1,34 +1,43 @@
|
||||
Index: linux-atm-2.4.1/src/qgen/Makefile.am
|
||||
Index: linux-atm-2.5.1/src/qgen/Makefile.am
|
||||
===================================================================
|
||||
--- linux-atm-2.4.1.orig/src/qgen/Makefile.am 2007-10-20 19:19:10.354218533 +0200
|
||||
+++ linux-atm-2.4.1/src/qgen/Makefile.am 2007-10-20 19:19:16.814586679 +0200
|
||||
@@ -3,7 +3,7 @@
|
||||
--- linux-atm-2.5.1.orig/src/qgen/Makefile.am 2010-02-27 01:36:10.156687492 +0100
|
||||
+++ linux-atm-2.5.1/src/qgen/Makefile.am 2010-02-27 01:36:23.388686762 +0100
|
||||
@@ -2,7 +2,7 @@
|
||||
|
||||
qgen_SOURCES = common.c common.h file.c file.h first.c ql_y.y ql_l.l qgen.c \
|
||||
qgen.h second.c third.c
|
||||
-qgen_LDADD = -lfl
|
||||
+qgen_LDADD =
|
||||
|
||||
q_dump_SOURCES = common.c
|
||||
q_dump_LDADD = qd.dump.standalone.o
|
||||
Index: linux-atm-2.4.1/src/qgen/Makefile.in
|
||||
CC = @CC_FOR_BUILD@
|
||||
CFLAGS = @CFLAGS_FOR_BUILD@
|
||||
Index: linux-atm-2.5.1/src/qgen/Makefile.in
|
||||
===================================================================
|
||||
--- linux-atm-2.4.1.orig/src/qgen/Makefile.in 2007-10-20 19:19:11.898306522 +0200
|
||||
+++ linux-atm-2.4.1/src/qgen/Makefile.in 2007-10-20 19:19:16.814586679 +0200
|
||||
@@ -90,7 +90,7 @@
|
||||
|
||||
qgen_SOURCES = common.c common.h file.c file.h first.c ql_y.y ql_l.l qgen.c qgen.h second.c third.c
|
||||
--- linux-atm-2.5.1.orig/src/qgen/Makefile.in 2010-02-27 01:36:10.156687492 +0100
|
||||
+++ linux-atm-2.5.1/src/qgen/Makefile.in 2010-02-27 02:06:38.992684137 +0100
|
||||
@@ -58,7 +58,7 @@
|
||||
am__depfiles_maybe = depfiles
|
||||
am__mv = mv -f
|
||||
COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
|
||||
- $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
|
||||
+ $(AM_CFLAGS) $(CFLAGS)
|
||||
LTCOMPILE = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
|
||||
--mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
|
||||
$(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
|
||||
@@ -208,7 +208,7 @@
|
||||
qgen_SOURCES = common.c common.h file.c file.h first.c ql_y.y ql_l.l qgen.c \
|
||||
qgen.h second.c third.c
|
||||
|
||||
-qgen_LDADD = -lfl
|
||||
+qgen_LDADD =
|
||||
|
||||
q_dump_SOURCES = common.c
|
||||
q_dump_LDADD = qd.dump.standalone.o
|
||||
Index: linux-atm-2.4.1/src/qgen/ql_l.c
|
||||
#TESTS = $(check_PROGRAMS)
|
||||
EXTRA_DIST = ql_y.h ql_y.c ql_l.c
|
||||
Index: linux-atm-2.5.1/src/qgen/ql_l.c
|
||||
===================================================================
|
||||
--- linux-atm-2.4.1.orig/src/qgen/ql_l.c 2007-10-20 19:19:11.906306980 +0200
|
||||
+++ linux-atm-2.4.1/src/qgen/ql_l.c 2007-10-20 19:19:16.842588278 +0200
|
||||
@@ -501,6 +501,11 @@
|
||||
--- linux-atm-2.5.1.orig/src/qgen/ql_l.c 2010-02-27 01:36:22.669685751 +0100
|
||||
+++ linux-atm-2.5.1/src/qgen/ql_l.c 2010-02-27 01:36:23.392683892 +0100
|
||||
@@ -514,6 +514,11 @@
|
||||
#include "qgen.h"
|
||||
#include "ql_y.h"
|
||||
|
||||
@ -40,27 +49,27 @@ Index: linux-atm-2.4.1/src/qgen/ql_l.c
|
||||
|
||||
typedef struct _tree {
|
||||
struct _tree *left,*right;
|
||||
Index: linux-atm-2.4.1/src/sigd/cfg_l.c
|
||||
Index: linux-atm-2.5.1/src/sigd/cfg_l.c
|
||||
===================================================================
|
||||
--- linux-atm-2.4.1.orig/src/sigd/cfg_l.c 2007-10-20 19:19:10.378219897 +0200
|
||||
+++ linux-atm-2.4.1/src/sigd/cfg_l.c 2007-10-20 19:19:16.854588969 +0200
|
||||
@@ -11,6 +11,10 @@
|
||||
#include <stdio.h>
|
||||
#include <unistd.h>
|
||||
--- linux-atm-2.5.1.orig/src/sigd/cfg_l.c 2010-02-27 01:36:22.673681076 +0100
|
||||
+++ linux-atm-2.5.1/src/sigd/cfg_l.c 2010-02-27 01:36:23.392683892 +0100
|
||||
@@ -617,6 +617,10 @@
|
||||
|
||||
#include "cfg_y.h"
|
||||
|
||||
+int yywrap(void)
|
||||
+{
|
||||
+ return 1;
|
||||
+}
|
||||
|
||||
/* cfront 1.2 defines "c_plusplus" instead of "__cplusplus" */
|
||||
#ifdef c_plusplus
|
||||
Index: linux-atm-2.4.1/src/sigd/Makefile.am
|
||||
static int lineno = 1;
|
||||
static int token; /* f@#%ing flex doesn't grok return after BEGIN */
|
||||
Index: linux-atm-2.5.1/src/sigd/Makefile.am
|
||||
===================================================================
|
||||
--- linux-atm-2.4.1.orig/src/sigd/Makefile.am 2007-10-20 19:19:10.386220355 +0200
|
||||
+++ linux-atm-2.4.1/src/sigd/Makefile.am 2007-10-20 19:19:16.882590565 +0200
|
||||
--- linux-atm-2.5.1.orig/src/sigd/Makefile.am 2010-02-27 01:36:10.160686786 +0100
|
||||
+++ linux-atm-2.5.1/src/sigd/Makefile.am 2010-02-27 01:36:23.392683892 +0100
|
||||
@@ -8,7 +8,7 @@
|
||||
$(top_builddir)/src/qgen/qd.dump.o \
|
||||
$(top_builddir)/src/q2931/qd.dump.o \
|
||||
$(top_builddir)/src/lib/libatm.la \
|
||||
$(top_builddir)/src/saal/libsaal.a
|
||||
-atmsigd_LDADD = $(atmsigd_XTRAS) -lfl
|
||||
@ -68,23 +77,23 @@ Index: linux-atm-2.4.1/src/sigd/Makefile.am
|
||||
atmsigd_DEPENDENCIES = mess.c $(atmsigd_XTRAS)
|
||||
|
||||
CLEANFILES = mess.c
|
||||
Index: linux-atm-2.4.1/src/sigd/Makefile.in
|
||||
Index: linux-atm-2.5.1/src/sigd/Makefile.in
|
||||
===================================================================
|
||||
--- linux-atm-2.4.1.orig/src/sigd/Makefile.in 2007-10-20 19:19:12.018313361 +0200
|
||||
+++ linux-atm-2.4.1/src/sigd/Makefile.in 2007-10-20 19:19:16.886590795 +0200
|
||||
@@ -92,7 +92,7 @@
|
||||
|
||||
atmsigd_XTRAS = mess.o $(top_builddir)/src/qgen/q.out.o $(top_builddir)/src/qgen/qd.dump.o $(top_builddir)/src/lib/libatm.la $(top_builddir)/src/saal/libsaal.a
|
||||
--- linux-atm-2.5.1.orig/src/sigd/Makefile.in 2010-02-27 01:36:10.160686786 +0100
|
||||
+++ linux-atm-2.5.1/src/sigd/Makefile.in 2010-02-27 01:36:23.396685195 +0100
|
||||
@@ -244,7 +244,7 @@
|
||||
$(top_builddir)/src/lib/libatm.la \
|
||||
$(top_builddir)/src/saal/libsaal.a
|
||||
|
||||
-atmsigd_LDADD = $(atmsigd_XTRAS) -lfl
|
||||
+atmsigd_LDADD = $(atmsigd_XTRAS)
|
||||
atmsigd_DEPENDENCIES = mess.c $(atmsigd_XTRAS)
|
||||
|
||||
CLEANFILES = mess.c
|
||||
Index: linux-atm-2.4.1/src/switch/debug/debug.c
|
||||
sysconf_DATA = atmsigd.conf
|
||||
Index: linux-atm-2.5.1/src/switch/debug/debug.c
|
||||
===================================================================
|
||||
--- linux-atm-2.4.1.orig/src/switch/debug/debug.c 2007-10-20 19:19:12.414335932 +0200
|
||||
+++ linux-atm-2.4.1/src/switch/debug/debug.c 2007-10-20 19:19:16.894591246 +0200
|
||||
--- linux-atm-2.5.1.orig/src/switch/debug/debug.c 2010-02-27 01:36:10.160686786 +0100
|
||||
+++ linux-atm-2.5.1/src/switch/debug/debug.c 2010-02-27 01:36:23.396685195 +0100
|
||||
@@ -20,6 +20,11 @@
|
||||
|
||||
#define PRV(call) ((FAB *) (call)->fab)
|
||||
@ -97,10 +106,10 @@ Index: linux-atm-2.4.1/src/switch/debug/debug.c
|
||||
|
||||
typedef struct _fab {
|
||||
CALL *next; /* relay.c may not keep track of calls, but WE are */
|
||||
Index: linux-atm-2.4.1/src/switch/debug/Makefile.am
|
||||
Index: linux-atm-2.5.1/src/switch/debug/Makefile.am
|
||||
===================================================================
|
||||
--- linux-atm-2.4.1.orig/src/switch/debug/Makefile.am 2007-10-20 19:19:10.406221495 +0200
|
||||
+++ linux-atm-2.4.1/src/switch/debug/Makefile.am 2007-10-20 19:19:16.906591931 +0200
|
||||
--- linux-atm-2.5.1.orig/src/switch/debug/Makefile.am 2010-02-27 01:36:10.164686879 +0100
|
||||
+++ linux-atm-2.5.1/src/switch/debug/Makefile.am 2010-02-27 01:36:23.396685195 +0100
|
||||
@@ -5,7 +5,7 @@
|
||||
sw_debug_SOURCES = debug.c
|
||||
sw_debug_XTRAS = $(top_builddir)/src/switch/libsw.a \
|
||||
@ -110,23 +119,24 @@ Index: linux-atm-2.4.1/src/switch/debug/Makefile.am
|
||||
|
||||
sw_debug_DEPENDENCIES = $(sw_debug_XTRAS)
|
||||
|
||||
Index: linux-atm-2.4.1/src/switch/debug/Makefile.in
|
||||
Index: linux-atm-2.5.1/src/switch/debug/Makefile.in
|
||||
===================================================================
|
||||
--- linux-atm-2.4.1.orig/src/switch/debug/Makefile.in 2007-10-20 19:19:12.378333877 +0200
|
||||
+++ linux-atm-2.4.1/src/switch/debug/Makefile.in 2007-10-20 19:19:16.918592613 +0200
|
||||
@@ -92,7 +92,7 @@
|
||||
sw_debug_SOURCES = debug.c
|
||||
sw_debug_XTRAS = $(top_builddir)/src/switch/libsw.a $(top_builddir)/src/lib/libatm.la
|
||||
--- linux-atm-2.5.1.orig/src/switch/debug/Makefile.in 2010-02-27 01:36:10.164686879 +0100
|
||||
+++ linux-atm-2.5.1/src/switch/debug/Makefile.in 2010-02-27 01:36:23.396685195 +0100
|
||||
@@ -199,7 +199,8 @@
|
||||
sw_debug_XTRAS = $(top_builddir)/src/switch/libsw.a \
|
||||
$(top_builddir)/src/lib/libatm.la
|
||||
|
||||
-sw_debug_LDADD = $(sw_debug_XTRAS) -lfl
|
||||
+sw_debug_LDADD = $(sw_debug_XTRAS)
|
||||
|
||||
+sw_debug_LDADD = $(sw_debug_XTRAS)
|
||||
+
|
||||
sw_debug_DEPENDENCIES = $(sw_debug_XTRAS)
|
||||
|
||||
Index: linux-atm-2.4.1/src/switch/tcp/Makefile.am
|
||||
EXTRA_DIST = demo README
|
||||
all: all-am
|
||||
Index: linux-atm-2.5.1/src/switch/tcp/Makefile.am
|
||||
===================================================================
|
||||
--- linux-atm-2.4.1.orig/src/switch/tcp/Makefile.am 2007-10-20 19:19:10.422222406 +0200
|
||||
+++ linux-atm-2.4.1/src/switch/tcp/Makefile.am 2007-10-20 19:19:16.922592837 +0200
|
||||
--- linux-atm-2.5.1.orig/src/switch/tcp/Makefile.am 2010-02-27 01:36:10.201682113 +0100
|
||||
+++ linux-atm-2.5.1/src/switch/tcp/Makefile.am 2010-02-27 01:36:23.412882977 +0100
|
||||
@@ -5,7 +5,7 @@
|
||||
sw_tcp_SOURCES = tcpsw.c
|
||||
sw_tcp_XTRAS = $(top_builddir)/src/switch/libsw.a \
|
||||
@ -136,23 +146,23 @@ Index: linux-atm-2.4.1/src/switch/tcp/Makefile.am
|
||||
sw_tcp_DEPENDENCIES = $(sw_tcp_XTRAS)
|
||||
|
||||
EXTRA_DIST = mkfiles README
|
||||
Index: linux-atm-2.4.1/src/switch/tcp/Makefile.in
|
||||
Index: linux-atm-2.5.1/src/switch/tcp/Makefile.in
|
||||
===================================================================
|
||||
--- linux-atm-2.4.1.orig/src/switch/tcp/Makefile.in 2007-10-20 19:19:12.422336385 +0200
|
||||
+++ linux-atm-2.4.1/src/switch/tcp/Makefile.in 2007-10-20 19:19:16.926593064 +0200
|
||||
@@ -92,7 +92,7 @@
|
||||
sw_tcp_SOURCES = tcpsw.c
|
||||
sw_tcp_XTRAS = $(top_builddir)/src/switch/libsw.a $(top_builddir)/src/lib/libatm.la
|
||||
--- linux-atm-2.5.1.orig/src/switch/tcp/Makefile.in 2010-02-27 01:36:10.209681349 +0100
|
||||
+++ linux-atm-2.5.1/src/switch/tcp/Makefile.in 2010-02-27 01:36:23.417680887 +0100
|
||||
@@ -199,7 +199,7 @@
|
||||
sw_tcp_XTRAS = $(top_builddir)/src/switch/libsw.a \
|
||||
$(top_builddir)/src/lib/libatm.la
|
||||
|
||||
-sw_tcp_LDADD = $(sw_tcp_XTRAS) -lfl
|
||||
+sw_tcp_LDADD = $(sw_tcp_XTRAS)
|
||||
sw_tcp_DEPENDENCIES = $(sw_tcp_XTRAS)
|
||||
|
||||
EXTRA_DIST = mkfiles README
|
||||
Index: linux-atm-2.4.1/src/switch/tcp/tcpsw.c
|
||||
all: all-am
|
||||
Index: linux-atm-2.5.1/src/switch/tcp/tcpsw.c
|
||||
===================================================================
|
||||
--- linux-atm-2.4.1.orig/src/switch/tcp/tcpsw.c 2007-10-20 19:19:12.426336614 +0200
|
||||
+++ linux-atm-2.4.1/src/switch/tcp/tcpsw.c 2007-10-20 19:19:16.954594660 +0200
|
||||
--- linux-atm-2.5.1.orig/src/switch/tcp/tcpsw.c 2010-02-27 01:36:10.221684444 +0100
|
||||
+++ linux-atm-2.5.1/src/switch/tcp/tcpsw.c 2010-02-27 01:36:23.428680415 +0100
|
||||
@@ -35,6 +35,10 @@
|
||||
#define MAX_PACKET (ATM_MAX_AAL5_PDU+sizeof(struct atmtcp_hdr))
|
||||
#define BUFFER_SIZE (MAX_PACKET*2)
|
||||
@ -164,13 +174,13 @@ Index: linux-atm-2.4.1/src/switch/tcp/tcpsw.c
|
||||
|
||||
typedef struct _table {
|
||||
struct _link *out; /* output port */
|
||||
Index: linux-atm-2.4.1/src/test/ispl_l.c
|
||||
Index: linux-atm-2.5.1/src/test/ispl_l.c
|
||||
===================================================================
|
||||
--- linux-atm-2.4.1.orig/src/test/ispl_l.c 2007-10-20 19:19:10.442223546 +0200
|
||||
+++ linux-atm-2.4.1/src/test/ispl_l.c 2007-10-20 19:19:16.962595124 +0200
|
||||
@@ -11,6 +11,11 @@
|
||||
#include <stdio.h>
|
||||
#include <unistd.h>
|
||||
--- linux-atm-2.5.1.orig/src/test/ispl_l.c 2010-02-27 01:36:22.677681892 +0100
|
||||
+++ linux-atm-2.5.1/src/test/ispl_l.c 2010-02-27 01:36:23.428680415 +0100
|
||||
@@ -629,6 +629,11 @@
|
||||
#include "isp.h"
|
||||
#include "ispl_y.h"
|
||||
|
||||
+int yywrap(void)
|
||||
+{
|
||||
@ -178,31 +188,31 @@ Index: linux-atm-2.4.1/src/test/ispl_l.c
|
||||
+}
|
||||
+
|
||||
|
||||
/* cfront 1.2 defines "c_plusplus" instead of "__cplusplus" */
|
||||
#ifdef c_plusplus
|
||||
Index: linux-atm-2.4.1/src/test/Makefile.am
|
||||
static int lineno = 1;
|
||||
|
||||
Index: linux-atm-2.5.1/src/test/Makefile.am
|
||||
===================================================================
|
||||
--- linux-atm-2.4.1.orig/src/test/Makefile.am 2007-10-20 19:19:11.858304242 +0200
|
||||
+++ linux-atm-2.4.1/src/test/Makefile.am 2007-10-20 19:19:16.962595124 +0200
|
||||
@@ -15,7 +15,7 @@
|
||||
--- linux-atm-2.5.1.orig/src/test/Makefile.am 2010-02-27 01:36:10.221684444 +0100
|
||||
+++ linux-atm-2.5.1/src/test/Makefile.am 2010-02-27 01:36:23.428680415 +0100
|
||||
@@ -20,7 +20,7 @@
|
||||
bw_SOURCES = bw.c
|
||||
isp_SOURCES = isp.c isp.h ispl_y.y ispl_l.l
|
||||
isp_XTRAS = $(LDADD)
|
||||
-isp_LDADD = $(isp_XTRAS) -lfl
|
||||
+isp_LDADD = $(isp_XTRAS)
|
||||
isp_DEPENDENCIES = $(isp_XTRAS) errnos.inc
|
||||
+isp_LDADD = $(isp_XTRAS)
|
||||
isp_DEPENDENCIES = $(isp_XTRAS)
|
||||
window_SOURCES = window.c
|
||||
|
||||
Index: linux-atm-2.4.1/src/test/Makefile.in
|
||||
Index: linux-atm-2.5.1/src/test/Makefile.in
|
||||
===================================================================
|
||||
--- linux-atm-2.4.1.orig/src/test/Makefile.in 2007-10-20 19:19:11.826302420 +0200
|
||||
+++ linux-atm-2.4.1/src/test/Makefile.in 2007-10-20 19:19:16.962595124 +0200
|
||||
@@ -102,7 +102,7 @@
|
||||
--- linux-atm-2.5.1.orig/src/test/Makefile.in 2010-02-27 01:36:10.225688778 +0100
|
||||
+++ linux-atm-2.5.1/src/test/Makefile.in 2010-02-27 01:36:23.432685583 +0100
|
||||
@@ -282,7 +282,7 @@
|
||||
bw_SOURCES = bw.c
|
||||
isp_SOURCES = isp.c isp.h ispl_y.y ispl_l.l
|
||||
isp_XTRAS = $(LDADD)
|
||||
-isp_LDADD = $(isp_XTRAS) -lfl
|
||||
+isp_LDADD = $(isp_XTRAS)
|
||||
isp_DEPENDENCIES = $(isp_XTRAS) errnos.inc
|
||||
+isp_LDADD = $(isp_XTRAS)
|
||||
isp_DEPENDENCIES = $(isp_XTRAS)
|
||||
window_SOURCES = window.c
|
||||
|
||||
CLEANFILES = errnos.inc
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -1,13 +0,0 @@
|
||||
Index: linux-atm-2.4.1/src/include/stdint.h
|
||||
===================================================================
|
||||
--- linux-atm-2.4.1.orig/src/include/stdint.h 2007-10-20 19:19:10.194209414 +0200
|
||||
+++ linux-atm-2.4.1/src/include/stdint.h 2007-10-20 19:19:18.282670346 +0200
|
||||
@@ -6,7 +6,7 @@
|
||||
|
||||
#if __GLIBC__ >= 2 && __GLIBC_MINOR__ >= 1
|
||||
|
||||
-#include "/usr/include/stdint.h"
|
||||
+#include_next <stdint.h>
|
||||
|
||||
#elif __GLIBC__ >= 2
|
||||
|
@ -1,53 +0,0 @@
|
||||
Index: linux-atm-2.4.1/configure
|
||||
===================================================================
|
||||
--- linux-atm-2.4.1.orig/configure 2007-10-20 19:19:17.578630228 +0200
|
||||
+++ linux-atm-2.4.1/configure 2007-10-20 19:19:18.630690180 +0200
|
||||
@@ -8825,7 +8825,7 @@
|
||||
fi;
|
||||
|
||||
|
||||
- ac_config_files="$ac_config_files Makefile doc/Makefile m4/Makefile src/Makefile src/include/Makefile src/lib/Makefile"
|
||||
+ ac_config_files="$ac_config_files Makefile doc/Makefile m4/Makefile src/Makefile src/include/Makefile src/lib/Makefile src/arpd/Makefile"
|
||||
cat >confcache <<\_ACEOF
|
||||
# This file is a shell script that caches the results of configure
|
||||
# tests run on this system so they can be shared between configure
|
||||
@@ -9367,6 +9367,7 @@
|
||||
"src/Makefile" ) CONFIG_FILES="$CONFIG_FILES src/Makefile" ;;
|
||||
"src/include/Makefile" ) CONFIG_FILES="$CONFIG_FILES src/include/Makefile" ;;
|
||||
"src/lib/Makefile" ) CONFIG_FILES="$CONFIG_FILES src/lib/Makefile" ;;
|
||||
+ "src/arpd/Makefile" ) CONFIG_FILES="$CONFIG_FILES src/arpd/Makefile" ;;
|
||||
"default-1" ) CONFIG_COMMANDS="$CONFIG_COMMANDS default-1" ;;
|
||||
"config.h" ) CONFIG_HEADERS="$CONFIG_HEADERS config.h" ;;
|
||||
*) { { echo "$as_me:$LINENO: error: invalid argument: $ac_config_target" >&5
|
||||
Index: linux-atm-2.4.1/configure.in
|
||||
===================================================================
|
||||
--- linux-atm-2.4.1.orig/configure.in 2007-10-20 19:19:16.214552491 +0200
|
||||
+++ linux-atm-2.4.1/configure.in 2007-10-20 19:19:18.642690862 +0200
|
||||
@@ -153,5 +153,6 @@
|
||||
src/Makefile \
|
||||
src/include/Makefile \
|
||||
src/lib/Makefile \
|
||||
+ src/arpd/Makefile \
|
||||
)
|
||||
|
||||
Index: linux-atm-2.4.1/src/Makefile.am
|
||||
===================================================================
|
||||
--- linux-atm-2.4.1.orig/src/Makefile.am 2007-10-20 19:19:16.218552720 +0200
|
||||
+++ linux-atm-2.4.1/src/Makefile.am 2007-10-20 19:19:18.650691320 +0200
|
||||
@@ -1,2 +1,2 @@
|
||||
-SUBDIRS = include lib
|
||||
+SUBDIRS = include lib arpd
|
||||
|
||||
Index: linux-atm-2.4.1/src/Makefile.in
|
||||
===================================================================
|
||||
--- linux-atm-2.4.1.orig/src/Makefile.in 2007-10-20 19:19:17.650634330 +0200
|
||||
+++ linux-atm-2.4.1/src/Makefile.in 2007-10-20 19:19:18.678692917 +0200
|
||||
@@ -96,7 +96,7 @@
|
||||
VERSION = @VERSION@
|
||||
YACC = @YACC@
|
||||
|
||||
-SUBDIRS = include lib
|
||||
+SUBDIRS = include lib arpd
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
||||
CONFIG_HEADER = ../config.h
|
||||
CONFIG_CLEAN_FILES =
|
@ -1,42 +0,0 @@
|
||||
Index: linux-atm-2.4.1/src/arpd/arp.c
|
||||
===================================================================
|
||||
--- linux-atm-2.4.1.orig/src/arpd/arp.c 2007-10-20 19:19:10.002198470 +0200
|
||||
+++ linux-atm-2.4.1/src/arpd/arp.c 2007-10-20 19:19:19.138719139 +0200
|
||||
@@ -15,7 +15,6 @@
|
||||
#include <sys/types.h>
|
||||
#include <sys/socket.h> /* for linux/if_arp.h */
|
||||
#include <netinet/in.h> /* for ntohs, etc. */
|
||||
-#define _LINUX_NETDEVICE_H /* very crude hack for glibc2 */
|
||||
#include <linux/if_arp.h>
|
||||
#include <linux/if_ether.h>
|
||||
#include <atm.h>
|
||||
Index: linux-atm-2.4.1/src/arpd/io.c
|
||||
===================================================================
|
||||
--- linux-atm-2.4.1.orig/src/arpd/io.c 2007-10-20 19:19:09.994198016 +0200
|
||||
+++ linux-atm-2.4.1/src/arpd/io.c 2007-10-20 19:19:19.154720039 +0200
|
||||
@@ -16,12 +16,11 @@
|
||||
#include <sys/types.h>
|
||||
#include <sys/socket.h>
|
||||
#include <sys/ioctl.h>
|
||||
-#include <net/if.h>
|
||||
+#include <linux/if.h>
|
||||
#include <netinet/in.h>
|
||||
#include <atm.h>
|
||||
#include <linux/atmclip.h> /* for CLIP_DEFAULT_IDLETIMER */
|
||||
#include <linux/atmarp.h>
|
||||
-#define _LINUX_NETDEVICE_H /* glibc2 */
|
||||
#include <linux/if_arp.h>
|
||||
|
||||
#include "atmd.h"
|
||||
Index: linux-atm-2.4.1/src/arpd/itf.c
|
||||
===================================================================
|
||||
--- linux-atm-2.4.1.orig/src/arpd/itf.c 2007-10-20 19:19:10.010198930 +0200
|
||||
+++ linux-atm-2.4.1/src/arpd/itf.c 2007-10-20 19:19:19.186721859 +0200
|
||||
@@ -12,7 +12,6 @@
|
||||
#include <sys/types.h>
|
||||
#include <linux/atmclip.h>
|
||||
#include <sys/socket.h>
|
||||
-#define _LINUX_NETDEVICE_H /* glibc2 */
|
||||
#include <linux/if_arp.h>
|
||||
|
||||
#include "atmd.h"
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user