mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-24 01:43:08 +02:00
[kernel] refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17738 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
545acb046c
commit
b69ee884f4
@ -23,7 +23,7 @@
|
||||
/* The Mellanox Tavor device gives false positive parity errors
|
||||
* Mark this device with a broken_parity_status, to allow
|
||||
* PCI scanning code to "skip" this now blacklisted device.
|
||||
@@ -1859,7 +1860,9 @@ static void __devinit fixup_rev1_53c810(
|
||||
@@ -1860,7 +1861,9 @@ static void __devinit fixup_rev1_53c810(
|
||||
}
|
||||
}
|
||||
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_NCR, PCI_DEVICE_ID_NCR_53C810, fixup_rev1_53c810);
|
||||
@ -33,7 +33,7 @@
|
||||
/* Enable 1k I/O space granularity on the Intel P64H2 */
|
||||
static void __devinit quirk_p64h2_1k_io(struct pci_dev *dev)
|
||||
{
|
||||
@@ -2463,6 +2466,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
|
||||
@@ -2466,6 +2469,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
|
||||
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x10e7, quirk_i82576_sriov);
|
||||
|
||||
#endif /* CONFIG_PCI_IOV */
|
||||
|
@ -23,7 +23,7 @@
|
||||
/* The Mellanox Tavor device gives false positive parity errors
|
||||
* Mark this device with a broken_parity_status, to allow
|
||||
* PCI scanning code to "skip" this now blacklisted device.
|
||||
@@ -1866,7 +1867,9 @@ static void __devinit fixup_rev1_53c810(
|
||||
@@ -1867,7 +1868,9 @@ static void __devinit fixup_rev1_53c810(
|
||||
}
|
||||
}
|
||||
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_NCR, PCI_DEVICE_ID_NCR_53C810, fixup_rev1_53c810);
|
||||
@ -33,8 +33,8 @@
|
||||
/* Enable 1k I/O space granularity on the Intel P64H2 */
|
||||
static void __devinit quirk_p64h2_1k_io(struct pci_dev *dev)
|
||||
{
|
||||
@@ -2494,6 +2497,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
|
||||
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x150a, quirk_i82576_sriov);
|
||||
@@ -2498,6 +2501,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
|
||||
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x150d, quirk_i82576_sriov);
|
||||
|
||||
#endif /* CONFIG_PCI_IOV */
|
||||
+#endif /* !CONFIG_PCI_DISABLE_COMMON_QUIRKS */
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/drivers/mtd/devices/block2mtd.c
|
||||
+++ b/drivers/mtd/devices/block2mtd.c
|
||||
@@ -268,6 +268,7 @@
|
||||
@@ -268,6 +268,7 @@ static int _open_bdev(struct block2mtd_d
|
||||
/* We might not have rootfs mounted at this point. Try
|
||||
to resolve the device name by other means. */
|
||||
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -1,6 +1,6 @@
|
||||
--- a/fs/namespace.c
|
||||
+++ b/fs/namespace.c
|
||||
@@ -1550,7 +1550,7 @@
|
||||
@@ -1550,7 +1550,7 @@ static int do_loopback(struct path *path
|
||||
if (!mnt)
|
||||
goto out;
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/include/linux/union.h
|
||||
+++ b/include/linux/union.h
|
||||
@@ -77,7 +77,7 @@
|
||||
@@ -77,7 +77,7 @@ extern int union_permission(struct path
|
||||
#define __union_copyup(x, y, z) ({ BUG(); (0); })
|
||||
#define union_copyup(x, y) ({ (0); })
|
||||
#define union_copyup_dir(x) ({ BUG(); (0); })
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/fs/Kconfig
|
||||
+++ b/fs/Kconfig
|
||||
@@ -188,6 +188,7 @@ source "fs/sysv/Kconfig"
|
||||
@@ -196,6 +196,7 @@ source "fs/sysv/Kconfig"
|
||||
source "fs/ufs/Kconfig"
|
||||
source "fs/exofs/Kconfig"
|
||||
source "fs/nilfs2/Kconfig"
|
||||
@ -10,7 +10,7 @@
|
||||
|
||||
--- a/fs/Makefile
|
||||
+++ b/fs/Makefile
|
||||
@@ -125,3 +125,4 @@ obj-$(CONFIG_OCFS2_FS) += ocfs2/
|
||||
@@ -126,3 +126,4 @@ obj-$(CONFIG_OCFS2_FS) += ocfs2/
|
||||
obj-$(CONFIG_BTRFS_FS) += btrfs/
|
||||
obj-$(CONFIG_GFS2_FS) += gfs2/
|
||||
obj-$(CONFIG_EXOFS_FS) += exofs/
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/mm/shmem.c
|
||||
+++ b/mm/shmem.c
|
||||
@@ -2769,6 +2769,16 @@
|
||||
@@ -2769,6 +2769,16 @@ int shmem_unuse(swp_entry_t entry, struc
|
||||
|
||||
/* common code */
|
||||
|
||||
@ -17,7 +17,7 @@
|
||||
/**
|
||||
* shmem_file_setup - get an unlinked file living in tmpfs
|
||||
* @name: name for dentry (to be seen in /proc/<pid>/maps
|
||||
@@ -2848,10 +2858,7 @@
|
||||
@@ -2848,10 +2858,7 @@ int shmem_zero_setup(struct vm_area_stru
|
||||
if (IS_ERR(file))
|
||||
return PTR_ERR(file);
|
||||
|
||||
@ -31,7 +31,7 @@
|
||||
|
||||
--- a/fs/file.c
|
||||
+++ b/fs/file.c
|
||||
@@ -270,6 +270,7 @@
|
||||
@@ -270,6 +270,7 @@ int expand_files(struct files_struct *fi
|
||||
/* All good, so we try */
|
||||
return expand_fdtable(files, nr);
|
||||
}
|
||||
@ -41,7 +41,7 @@
|
||||
{
|
||||
--- a/kernel/exit.c
|
||||
+++ b/kernel/exit.c
|
||||
@@ -507,6 +507,7 @@
|
||||
@@ -507,6 +507,7 @@ struct files_struct *get_files_struct(st
|
||||
|
||||
return files;
|
||||
}
|
||||
@ -49,7 +49,7 @@
|
||||
|
||||
void put_files_struct(struct files_struct *files)
|
||||
{
|
||||
@@ -526,6 +527,7 @@
|
||||
@@ -526,6 +527,7 @@ void put_files_struct(struct files_struc
|
||||
free_fdtable(fdt);
|
||||
}
|
||||
}
|
||||
@ -59,7 +59,7 @@
|
||||
{
|
||||
--- a/kernel/fork.c
|
||||
+++ b/kernel/fork.c
|
||||
@@ -159,6 +159,7 @@
|
||||
@@ -159,6 +159,7 @@ void __put_task_struct(struct task_struc
|
||||
if (!profile_handoff_task(tsk))
|
||||
free_task(tsk);
|
||||
}
|
||||
@ -69,7 +69,7 @@
|
||||
* macro override instead of weak attribute alias, to workaround
|
||||
--- a/kernel/sched.c
|
||||
+++ b/kernel/sched.c
|
||||
@@ -5981,6 +5981,7 @@
|
||||
@@ -5981,6 +5981,7 @@ int can_nice(const struct task_struct *p
|
||||
return (nice_rlim <= p->signal->rlim[RLIMIT_NICE].rlim_cur ||
|
||||
capable(CAP_SYS_NICE));
|
||||
}
|
||||
@ -79,7 +79,7 @@
|
||||
|
||||
--- a/mm/memory.c
|
||||
+++ b/mm/memory.c
|
||||
@@ -1064,6 +1064,7 @@
|
||||
@@ -1064,6 +1064,7 @@ unsigned long zap_page_range(struct vm_a
|
||||
tlb_finish_mmu(tlb, address, end);
|
||||
return end;
|
||||
}
|
||||
@ -87,7 +87,7 @@
|
||||
|
||||
/**
|
||||
* zap_vma_ptes - remove ptes mapping the vma
|
||||
@@ -2490,6 +2491,7 @@
|
||||
@@ -2490,6 +2491,7 @@ int vmtruncate_range(struct inode *inode
|
||||
|
||||
return 0;
|
||||
}
|
||||
@ -97,7 +97,7 @@
|
||||
* We enter with non-exclusive mmap_sem (to exclude vma changes,
|
||||
--- a/mm/vmalloc.c
|
||||
+++ b/mm/vmalloc.c
|
||||
@@ -1101,6 +1101,7 @@
|
||||
@@ -1101,6 +1101,7 @@ void unmap_kernel_range(unsigned long ad
|
||||
vunmap_page_range(addr, end);
|
||||
flush_tlb_kernel_range(addr, end);
|
||||
}
|
||||
@ -105,7 +105,7 @@
|
||||
|
||||
int map_vm_area(struct vm_struct *area, pgprot_t prot, struct page ***pages)
|
||||
{
|
||||
@@ -1214,6 +1215,7 @@
|
||||
@@ -1214,6 +1215,7 @@ struct vm_struct *get_vm_area(unsigned l
|
||||
return __get_vm_area_node(size, flags, VMALLOC_START, VMALLOC_END,
|
||||
-1, GFP_KERNEL, __builtin_return_address(0));
|
||||
}
|
||||
@ -115,7 +115,7 @@
|
||||
void *caller)
|
||||
--- a/include/linux/mm.h
|
||||
+++ b/include/linux/mm.h
|
||||
@@ -711,6 +711,7 @@
|
||||
@@ -711,6 +711,7 @@ static inline int shmem_lock(struct file
|
||||
#endif
|
||||
struct file *shmem_file_setup(const char *name, loff_t size, unsigned long flags);
|
||||
|
||||
@ -125,7 +125,7 @@
|
||||
#ifndef CONFIG_MMU
|
||||
--- a/kernel/signal.c
|
||||
+++ b/kernel/signal.c
|
||||
@@ -1061,6 +1061,7 @@
|
||||
@@ -1061,6 +1061,7 @@ struct sighand_struct *lock_task_sighand
|
||||
|
||||
return sighand;
|
||||
}
|
||||
|
Loading…
Reference in New Issue
Block a user