mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-23 23:32:49 +02:00
disable debugging stuff in madwifi - saves precious flash space :)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6329 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
7150f5906a
commit
b774325e71
@ -143,7 +143,7 @@ define KernelPackage/madwifi/install
|
||||
$(INSTALL_DIR) $(1)/lib/wifi
|
||||
$(INSTALL_DATA) ./files/lib/wifi/madwifi.sh $(1)/lib/wifi
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(CP) $(PKG_BUILD_DIR)/tools/{madwifi_multi,80211debug,80211stats,athchans,athctrl,athdebug,athkey,athstats,wlanconfig} $(1)/usr/sbin/
|
||||
$(CP) $(PKG_BUILD_DIR)/tools/{madwifi_multi,80211stats,athchans,athctrl,athkey,athstats,wlanconfig} $(1)/usr/sbin/
|
||||
endef
|
||||
|
||||
$(eval $(call KernelPackage,madwifi))
|
||||
|
105
package/madwifi/patches/200-no_debug.patch
Normal file
105
package/madwifi/patches/200-no_debug.patch
Normal file
@ -0,0 +1,105 @@
|
||||
diff -Nur madwifi-0.9.2.1/ath/if_ath.c madwifi-0.9.2.1-nodebug/ath/if_ath.c
|
||||
--- madwifi-0.9.2.1/ath/if_ath.c 2006-07-08 08:47:19.000000000 +0200
|
||||
+++ madwifi-0.9.2.1-nodebug/ath/if_ath.c 2007-02-20 11:48:05.000000000 +0100
|
||||
@@ -72,7 +72,7 @@
|
||||
#include <net80211/if_llc.h>
|
||||
#endif
|
||||
|
||||
-#define AR_DEBUG
|
||||
+#undef AR_DEBUG
|
||||
|
||||
#include "if_athrate.h"
|
||||
#include "net80211/if_athproto.h"
|
||||
diff -Nur madwifi-0.9.2.1/ath_rate/amrr/amrr.c madwifi-0.9.2.1-nodebug/ath_rate/amrr/amrr.c
|
||||
--- madwifi-0.9.2.1/ath_rate/amrr/amrr.c 2006-07-04 12:23:35.000000000 +0200
|
||||
+++ madwifi-0.9.2.1-nodebug/ath_rate/amrr/amrr.c 2007-02-20 11:49:10.000000000 +0100
|
||||
@@ -67,7 +67,7 @@
|
||||
|
||||
#include "amrr.h"
|
||||
|
||||
-#define AMRR_DEBUG
|
||||
+#undef AMRR_DEBUG
|
||||
#ifdef AMRR_DEBUG
|
||||
#define DPRINTF(sc, _fmt, ...) do { \
|
||||
if (sc->sc_debug & 0x10) \
|
||||
diff -Nur madwifi-0.9.2.1/ath_rate/onoe/onoe.c madwifi-0.9.2.1-nodebug/ath_rate/onoe/onoe.c
|
||||
--- madwifi-0.9.2.1/ath_rate/onoe/onoe.c 2006-07-04 12:23:35.000000000 +0200
|
||||
+++ madwifi-0.9.2.1-nodebug/ath_rate/onoe/onoe.c 2007-02-20 11:48:51.000000000 +0100
|
||||
@@ -63,7 +63,7 @@
|
||||
|
||||
#include "onoe.h"
|
||||
|
||||
-#define ONOE_DEBUG
|
||||
+#undef ONOE_DEBUG
|
||||
#ifdef ONOE_DEBUG
|
||||
enum {
|
||||
ATH_DEBUG_RATE = 0x00000010, /* rate control */
|
||||
diff -Nur madwifi-0.9.2.1/ath_rate/sample/sample.c madwifi-0.9.2.1-nodebug/ath_rate/sample/sample.c
|
||||
--- madwifi-0.9.2.1/ath_rate/sample/sample.c 2006-07-04 12:23:35.000000000 +0200
|
||||
+++ madwifi-0.9.2.1-nodebug/ath_rate/sample/sample.c 2007-02-20 11:48:31.000000000 +0100
|
||||
@@ -65,7 +65,7 @@
|
||||
|
||||
#include "sample.h"
|
||||
|
||||
-#define SAMPLE_DEBUG
|
||||
+#undef SAMPLE_DEBUG
|
||||
#ifdef SAMPLE_DEBUG
|
||||
enum {
|
||||
ATH_DEBUG_RATE = 0x00000010 /* rate control */
|
||||
diff -Nur madwifi-0.9.2.1/net80211/ieee80211_var.h madwifi-0.9.2.1-nodebug/net80211/ieee80211_var.h
|
||||
--- madwifi-0.9.2.1/net80211/ieee80211_var.h 2006-07-06 05:23:08.000000000 +0200
|
||||
+++ madwifi-0.9.2.1-nodebug/net80211/ieee80211_var.h 2007-02-20 11:43:09.000000000 +0100
|
||||
@@ -37,7 +37,7 @@
|
||||
/*
|
||||
* Definitions for IEEE 802.11 drivers.
|
||||
*/
|
||||
-#define IEEE80211_DEBUG
|
||||
+#undef IEEE80211_DEBUG
|
||||
#undef IEEE80211_DEBUG_REFCNT /* node refcnt stuff */
|
||||
|
||||
#include <net80211/ieee80211_linux.h>
|
||||
diff -Nur madwifi-0.9.2.1/tools/do_multi.c madwifi-0.9.2.1-nodebug/tools/do_multi.c
|
||||
--- madwifi-0.9.2.1/tools/do_multi.c 2007-02-20 11:53:44.000000000 +0100
|
||||
+++ madwifi-0.9.2.1-nodebug/tools/do_multi.c 2007-02-20 11:58:22.000000000 +0100
|
||||
@@ -9,16 +9,20 @@
|
||||
|
||||
progname = basename(argv[0]);
|
||||
|
||||
+#if 0
|
||||
if(strcmp(progname, "80211debug") == 0)
|
||||
ret = a80211debug_init(argc, argv);
|
||||
+#endif
|
||||
if(strcmp(progname, "80211stats") == 0)
|
||||
ret = a80211stats_init(argc, argv);
|
||||
if(strcmp(progname, "athchans") == 0)
|
||||
ret = athchans_init(argc, argv);
|
||||
if(strcmp(progname, "athctrl") == 0)
|
||||
ret = athctrl_init(argc, argv);
|
||||
+#if 0
|
||||
if(strcmp(progname, "athdebug") == 0)
|
||||
ret = athdebug_init(argc, argv);
|
||||
+#endif
|
||||
if(strcmp(progname, "athkey") == 0)
|
||||
ret = athkey_init(argc, argv);
|
||||
if(strcmp(progname, "athstats") == 0)
|
||||
diff -Nur madwifi-0.9.2.1/tools/Makefile madwifi-0.9.2.1-nodebug/tools/Makefile
|
||||
--- madwifi-0.9.2.1/tools/Makefile 2007-02-20 11:53:44.000000000 +0100
|
||||
+++ madwifi-0.9.2.1-nodebug/tools/Makefile 2007-02-20 11:57:23.000000000 +0100
|
||||
@@ -52,7 +52,7 @@
|
||||
|
||||
ifdef DOMULTI
|
||||
OBJS= do_multi.o athstats.o 80211stats.o athkey.o athchans.o athctrl.o \
|
||||
- athdebug.o 80211debug.o wlanconfig.o
|
||||
+ wlanconfig.o
|
||||
ALL= ${OBJS} madwifi_multi
|
||||
endif
|
||||
|
||||
@@ -85,7 +85,7 @@
|
||||
${CC} -c -o do_multi.o -DDOMULTI=1 ${ALL_CFLAGS} do_multi.c
|
||||
madwifi_multi:
|
||||
${CC} -o madwifi_multi ${LDFLAGS} ${OBJS}
|
||||
- for i in athstats 80211stats athkey athchans athctrl athdebug wlanconfig 80211debug; do \
|
||||
+ for i in athstats 80211stats athkey athchans athctrl wlanconfig; do \
|
||||
ln -s -f madwifi_multi $$i; \
|
||||
done
|
||||
|
Loading…
Reference in New Issue
Block a user