mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-05 04:44:59 +02:00
Upgrade fuse to 2.6.5 (#1955)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7716 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
cad5267742
commit
b947ccab5d
@ -10,12 +10,12 @@ include $(TOPDIR)/rules.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=fuse
|
||||
PKG_VERSION:=2.6.3
|
||||
PKG_VERSION:=2.6.5
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
||||
PKG_MD5SUM:=3f4f5d07d12dedc0a3fd23472171fe94
|
||||
PKG_MD5SUM:=66bd30503df55a87b9868835ca5a45bc
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
@ -1,7 +1,7 @@
|
||||
Index: fuse-2.6.3/kernel/configure
|
||||
Index: fuse-2.6.5/kernel/configure
|
||||
===================================================================
|
||||
--- fuse-2.6.3.orig/kernel/configure 2007-06-04 13:22:29.716337712 +0200
|
||||
+++ fuse-2.6.3/kernel/configure 2007-06-04 13:22:29.783327528 +0200
|
||||
--- fuse-2.6.5.orig/kernel/configure 2007-06-23 13:03:50.000000000 +0200
|
||||
+++ fuse-2.6.5/kernel/configure 2007-06-23 13:03:50.000000000 +0200
|
||||
@@ -1851,7 +1851,9 @@
|
||||
|
||||
{ echo "$as_me:$LINENO: checking kernel source version" >&5
|
||||
|
@ -1,7 +1,7 @@
|
||||
Index: fuse-2.6.3/kernel/Makefile.in
|
||||
Index: fuse-2.6.5/kernel/Makefile.in
|
||||
===================================================================
|
||||
--- fuse-2.6.3.orig/kernel/Makefile.in 2007-06-04 13:22:29.695340904 +0200
|
||||
+++ fuse-2.6.3/kernel/Makefile.in 2007-06-04 13:22:29.975298344 +0200
|
||||
--- fuse-2.6.5.orig/kernel/Makefile.in 2007-06-23 13:03:50.000000000 +0200
|
||||
+++ fuse-2.6.5/kernel/Makefile.in 2007-06-23 13:03:50.000000000 +0200
|
||||
@@ -25,11 +25,9 @@
|
||||
install-y: all
|
||||
$(mkdir_p) $(DESTDIR)$(fusemoduledir)
|
||||
|
@ -1,7 +1,7 @@
|
||||
Index: fuse-2.6.3/util/Makefile.in
|
||||
Index: fuse-2.6.5/util/Makefile.in
|
||||
===================================================================
|
||||
--- fuse-2.6.3.orig/util/Makefile.in 2007-06-04 13:22:29.674344096 +0200
|
||||
+++ fuse-2.6.3/util/Makefile.in 2007-06-04 13:22:30.163269768 +0200
|
||||
--- fuse-2.6.5.orig/util/Makefile.in 2007-06-23 13:03:50.000000000 +0200
|
||||
+++ fuse-2.6.5/util/Makefile.in 2007-06-23 13:03:50.000000000 +0200
|
||||
@@ -489,7 +489,7 @@
|
||||
install-exec-hook:
|
||||
-chown root $(DESTDIR)$(bindir)/fusermount
|
||||
|
@ -1,7 +1,7 @@
|
||||
Index: fuse-2.6.3/include/fuse_common_compat.h
|
||||
Index: fuse-2.6.5/include/fuse_common_compat.h
|
||||
===================================================================
|
||||
--- fuse-2.6.3.orig/include/fuse_common_compat.h 2007-06-04 13:22:29.628351088 +0200
|
||||
+++ fuse-2.6.3/include/fuse_common_compat.h 2007-06-04 13:22:30.344242256 +0200
|
||||
--- fuse-2.6.5.orig/include/fuse_common_compat.h 2007-06-23 13:03:50.000000000 +0200
|
||||
+++ fuse-2.6.5/include/fuse_common_compat.h 2007-06-23 13:03:51.000000000 +0200
|
||||
@@ -17,6 +17,7 @@
|
||||
unsigned int keep_cache : 1;
|
||||
};
|
||||
@ -16,10 +16,10 @@ Index: fuse-2.6.3/include/fuse_common_compat.h
|
||||
void fuse_unmount_compat22(const char *mountpoint);
|
||||
-
|
||||
+#endif
|
||||
Index: fuse-2.6.3/lib/fuse.c
|
||||
Index: fuse-2.6.5/lib/fuse.c
|
||||
===================================================================
|
||||
--- fuse-2.6.3.orig/lib/fuse.c 2007-06-04 13:22:29.634350176 +0200
|
||||
+++ fuse-2.6.3/lib/fuse.c 2007-06-04 13:22:30.345242104 +0200
|
||||
--- fuse-2.6.5.orig/lib/fuse.c 2007-06-23 13:03:50.000000000 +0200
|
||||
+++ fuse-2.6.5/lib/fuse.c 2007-06-23 13:03:51.000000000 +0200
|
||||
@@ -128,6 +128,7 @@
|
||||
static pthread_mutex_t fuse_context_lock = PTHREAD_MUTEX_INITIALIZER;
|
||||
static int fuse_context_ref;
|
||||
@ -132,10 +132,10 @@ Index: fuse-2.6.3/lib/fuse.c
|
||||
__asm__(".symver fuse_new_compat25,fuse_new@FUSE_2.5");
|
||||
+
|
||||
+#endif
|
||||
Index: fuse-2.6.3/lib/fuse_lowlevel.c
|
||||
Index: fuse-2.6.5/lib/fuse_lowlevel.c
|
||||
===================================================================
|
||||
--- fuse-2.6.3.orig/lib/fuse_lowlevel.c 2007-06-04 13:22:29.639349416 +0200
|
||||
+++ fuse-2.6.3/lib/fuse_lowlevel.c 2007-06-04 13:22:30.346241952 +0200
|
||||
--- fuse-2.6.5.orig/lib/fuse_lowlevel.c 2007-06-23 13:03:50.000000000 +0200
|
||||
+++ fuse-2.6.5/lib/fuse_lowlevel.c 2007-06-23 13:03:51.000000000 +0200
|
||||
@@ -1297,6 +1297,7 @@
|
||||
}
|
||||
|
||||
@ -149,10 +149,10 @@ Index: fuse-2.6.3/lib/fuse_lowlevel.c
|
||||
|
||||
__asm__(".symver fuse_lowlevel_new_compat25,fuse_lowlevel_new@FUSE_2.5");
|
||||
+#endif
|
||||
Index: fuse-2.6.3/lib/helper.c
|
||||
Index: fuse-2.6.5/lib/helper.c
|
||||
===================================================================
|
||||
--- fuse-2.6.3.orig/lib/helper.c 2007-06-04 13:22:29.645348504 +0200
|
||||
+++ fuse-2.6.3/lib/helper.c 2007-06-04 13:22:30.346241952 +0200
|
||||
--- fuse-2.6.5.orig/lib/helper.c 2007-06-23 13:03:50.000000000 +0200
|
||||
+++ fuse-2.6.5/lib/helper.c 2007-06-23 13:03:51.000000000 +0200
|
||||
@@ -195,7 +195,7 @@
|
||||
struct fuse_args *args)
|
||||
{
|
||||
@ -175,10 +175,10 @@ Index: fuse-2.6.3/lib/helper.c
|
||||
__asm__(".symver fuse_main_real_compat25,fuse_main_real@FUSE_2.5");
|
||||
__asm__(".symver fuse_mount_compat25,fuse_mount@FUSE_2.5");
|
||||
+#endif
|
||||
Index: fuse-2.6.3/lib/mount.c
|
||||
Index: fuse-2.6.5/lib/mount.c
|
||||
===================================================================
|
||||
--- fuse-2.6.3.orig/lib/mount.c 2007-06-04 13:22:29.652347440 +0200
|
||||
+++ fuse-2.6.3/lib/mount.c 2007-06-04 13:22:30.346241952 +0200
|
||||
--- fuse-2.6.5.orig/lib/mount.c 2007-06-23 13:03:50.000000000 +0200
|
||||
+++ fuse-2.6.5/lib/mount.c 2007-06-23 13:03:51.000000000 +0200
|
||||
@@ -219,11 +219,16 @@
|
||||
waitpid(pid, NULL, 0);
|
||||
}
|
||||
|
@ -1,6 +1,8 @@
|
||||
--- fuse.old/kernel/file.c 2007-01-28 21:25:02.000000000 +0000
|
||||
+++ fuse.dev/kernel/file.c 2007-05-29 00:10:29.000000000 +0100
|
||||
@@ -781,6 +785,10 @@
|
||||
Index: fuse-2.6.5/kernel/file.c
|
||||
===================================================================
|
||||
--- fuse-2.6.5.orig/kernel/file.c 2007-06-23 13:03:50.000000000 +0200
|
||||
+++ fuse-2.6.5/kernel/file.c 2007-06-23 13:03:51.000000000 +0200
|
||||
@@ -781,6 +781,10 @@
|
||||
|
||||
if (cmd == F_GETLK) {
|
||||
if (fc->no_lock) {
|
||||
@ -11,7 +13,7 @@
|
||||
#ifdef KERNEL_2_6_17_PLUS
|
||||
if (!posix_test_lock(file, fl, fl))
|
||||
fl->fl_type = F_UNLCK;
|
||||
@@ -791,6 +799,7 @@
|
||||
@@ -791,6 +795,7 @@
|
||||
else
|
||||
*fl = *cfl;
|
||||
#endif
|
||||
|
@ -1,5 +1,7 @@
|
||||
--- fuse.old/kernel/dev.c 2007-01-28 21:26:41.000000000 +0000
|
||||
+++ fuse.dev/kernel/dev.c 2007-05-29 00:28:47.000000000 +0100
|
||||
Index: fuse-2.6.5/kernel/dev.c
|
||||
===================================================================
|
||||
--- fuse-2.6.5.orig/kernel/dev.c 2007-06-23 13:03:50.000000000 +0200
|
||||
+++ fuse-2.6.5/kernel/dev.c 2007-06-23 13:03:51.000000000 +0200
|
||||
@@ -21,7 +21,11 @@
|
||||
MODULE_ALIAS_MISCDEV(FUSE_MINOR);
|
||||
#endif
|
||||
@ -12,7 +14,7 @@
|
||||
|
||||
static struct fuse_conn *fuse_get_conn(struct file *file)
|
||||
{
|
||||
@@ -1093,9 +1093,13 @@
|
||||
@@ -1093,9 +1097,13 @@
|
||||
int __init fuse_dev_init(void)
|
||||
{
|
||||
int err = -ENOMEM;
|
||||
@ -26,8 +28,10 @@
|
||||
if (!fuse_req_cachep)
|
||||
goto out;
|
||||
|
||||
--- fuse.old/kernel/inode.c 2007-02-04 13:34:51.000000000 +0000
|
||||
+++ fuse.dev/kernel/inode.c 2007-05-29 00:26:12.000000000 +0100
|
||||
Index: fuse-2.6.5/kernel/inode.c
|
||||
===================================================================
|
||||
--- fuse-2.6.5.orig/kernel/inode.c 2007-06-23 13:03:50.000000000 +0200
|
||||
+++ fuse-2.6.5/kernel/inode.c 2007-06-23 13:03:51.000000000 +0200
|
||||
@@ -24,7 +24,7 @@
|
||||
MODULE_LICENSE("GPL");
|
||||
#endif
|
||||
|
@ -1,5 +1,7 @@
|
||||
--- fuse.old/kernel/inode.c 2007-05-29 07:31:43.000000000 +0100
|
||||
+++ fuse.dev/kernel/inode.c 2007-05-29 07:29:42.000000000 +0100
|
||||
Index: fuse-2.6.5/kernel/inode.c
|
||||
===================================================================
|
||||
--- fuse-2.6.5.orig/kernel/inode.c 2007-06-23 13:03:51.000000000 +0200
|
||||
+++ fuse-2.6.5/kernel/inode.c 2007-06-23 13:03:51.000000000 +0200
|
||||
@@ -858,12 +858,20 @@
|
||||
if (err)
|
||||
return err;
|
||||
@ -7,7 +9,7 @@
|
||||
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,22)
|
||||
+ kobj_set_kset_s(&fuse_subsys, fs_subsys);
|
||||
+#else
|
||||
kset_set_kset_s(&fuse_subsys, fs_subsys);
|
||||
kset_set_kset_s(&fuse_subsys, fs_subsys);
|
||||
+#endif
|
||||
err = subsystem_register(&fuse_subsys);
|
||||
if (err)
|
||||
@ -16,7 +18,7 @@
|
||||
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,22)
|
||||
+ kobj_set_kset_s(&connections_subsys, fuse_subsys);
|
||||
+#else
|
||||
kset_set_kset_s(&connections_subsys, fuse_subsys);
|
||||
kset_set_kset_s(&connections_subsys, fuse_subsys);
|
||||
+#endif
|
||||
err = subsystem_register(&connections_subsys);
|
||||
if (err)
|
||||
|
Loading…
Reference in New Issue
Block a user