1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-12-25 03:01:09 +02:00

Add the RDC PCI ids for a fancier PCI device table.Return the system name on boot.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9327 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2007-10-15 16:13:25 +00:00
parent cfe57b0b5f
commit cf20e81492
4 changed files with 34 additions and 2 deletions

View File

@ -1,5 +1,5 @@
#
# Makefile for the RDC321x specific parts of the kernel
#
obj-$(CONFIG_X86_RDC) := gpio.o platform.o wdt.o
obj-$(CONFIG_X86_RDC) := gpio.o platform.o wdt.o setup.o

View File

@ -0,0 +1,14 @@
/*
* Machine specific setup for generic
*/
#include <linux/init.h>
#include <linux/interrupt.h>
#include <asm/arch_hooks.h>
#include <asm/io.h>
#include <asm/setup.h>
char * __init machine_specific_memory_setup(void)
{
return "RDC R-321x";
}

View File

@ -67,7 +67,7 @@ diff -urN linux-2.6.19/arch/i386/Makefile linux-2.6.19.new/arch/i386/Makefile
};
static struct device_fixup fixups_table[] = {
+{ 0x17F3, 0x6030, r8610_reset },
+{ PCI_VENDOR_ID_RDC, PCI_DEVICE_ID_R6030, r8610_reset },
{ PCI_VENDOR_ID_CYRIX, PCI_DEVICE_ID_CYRIX_5530_LEGACY, cs5530a_warm_reset },
{ PCI_VENDOR_ID_AMD, PCI_DEVICE_ID_AMD_CS5536_ISA, cs5536_warm_reset },
};

View File

@ -0,0 +1,18 @@
diff --git a/include/linux/pci_ids.h b/include/linux/pci_ids.h
index 55f307f..4a1aa34 100644
--- a/include/linux/pci_ids.h
+++ b/include/linux/pci_ids.h
@@ -2076,6 +2076,13 @@
#define PCI_DEVICE_ID_HERC_WIN 0x5732
#define PCI_DEVICE_ID_HERC_UNI 0x5832
+#define PCI_VENDOR_ID_RDC 0x17f3
+#define PCI_DEVICE_ID_RDC_R6020 0x6020
+#define PCI_DEVICE_ID_RDC_R6030 0x6030
+#define PCI_DEVICE_ID_RDC_R6040 0x6040
+#define PCI_DEVICE_ID_RDC_R6060 0x6060
+#define PCI_DEVICE_ID_RDC_R6061 0x6061
+
#define PCI_VENDOR_ID_SITECOM 0x182d
#define PCI_DEVICE_ID_SITECOM_DC105V2 0x3069