mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-10 12:33:08 +02:00
add miax package (thanks to Markus Becker)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2570 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
6894f2b234
commit
d202a2c925
@ -236,6 +236,7 @@ source "package/util-linux/Config.in"
|
||||
comment "Bluetooth"
|
||||
source "package/bluez-libs/Config.in"
|
||||
source "package/bluez-utils/Config.in"
|
||||
source "package/miax/Config.in"
|
||||
|
||||
comment "Extra stuff"
|
||||
source "package/sdk/Config.in"
|
||||
|
@ -108,6 +108,7 @@ package-$(BR2_COMPILE_LUA) += lua
|
||||
package-$(BR2_PACKAGE_MADWIFI_TOOLS) += madwifi-tools
|
||||
package-$(BR2_PACKAGE_MARADNS) += maradns
|
||||
package-$(BR2_COMPILE_MATRIXSSL) += matrixssl
|
||||
package-$(BR2_PACKAGE_MIAX) += miax
|
||||
package-$(BR2_PACKAGE_MICROCOM) += microcom
|
||||
package-$(BR2_PACKAGE_MICROPERL) += microperl
|
||||
package-$(BR2_COMPILE_MINI_HTTPD) += mini_httpd
|
||||
@ -263,6 +264,7 @@ libvorbis-compile: libogg-compile
|
||||
libxml2-compile: zlib-compile
|
||||
libxslt-compile: libxml2-compile
|
||||
lighttpd-compile: openssl-compile pcre-compile
|
||||
miax-compile: bluez-libs-compile
|
||||
miredo-compile: uclibc++-compile
|
||||
mt-daapd-compile: howl-compile libgdbm-compile libid3tag-compile
|
||||
mtr-compile: ncurses-compile
|
||||
|
12
openwrt/package/miax/Config.in
Normal file
12
openwrt/package/miax/Config.in
Normal file
@ -0,0 +1,12 @@
|
||||
config BR2_PACKAGE_MIAX
|
||||
prompt "miax.............................. A console iax (asterisk) client"
|
||||
tristate
|
||||
default m if CONFIG_DEVEL
|
||||
select BR2_PACKAGE_BLUEZ_LIBS
|
||||
select BR2_PACKAGE_LIBPTHREAD
|
||||
help
|
||||
miax is a console iax (asterisk) client, it can work with
|
||||
a soundcard as a normal voip phone, taking input/output from
|
||||
keyboard, analog/gsm/isdn modem or bluetooth phones.
|
||||
|
||||
http://www.eja.it/?l=gpl&testo=miax
|
36
openwrt/package/miax/Makefile
Normal file
36
openwrt/package/miax/Makefile
Normal file
@ -0,0 +1,36 @@
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=miax
|
||||
PKG_VERSION:=1.4
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=44f0d2ef46ee2697d890b7b96846adc7
|
||||
|
||||
PKG_SOURCE_URL:=http://mesh.dl.sourceforge.net/sourceforge/miax/
|
||||
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
|
||||
|
||||
include $(TOPDIR)/package/rules.mk
|
||||
|
||||
$(eval $(call PKG_template,MIAX,miax,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||
|
||||
$(PKG_BUILD_DIR)/.configured:
|
||||
touch $@
|
||||
|
||||
$(PKG_BUILD_DIR)/.built:
|
||||
$(MAKE) -C "$(PKG_BUILD_DIR)" \
|
||||
CC="$(TARGET_CC)" \
|
||||
OFLAGS="$(TARGET_CFLAGS)" \
|
||||
CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
|
||||
all
|
||||
touch $@
|
||||
|
||||
$(IPKG_MIAX):
|
||||
install -d -m0755 $(IDIR_MIAX)/usr/bin
|
||||
install -m0755 $(PKG_BUILD_DIR)/miax $(IDIR_MIAX)/usr/bin/
|
||||
$(RSTRIP) $(IDIR_MIAX)
|
||||
$(IPKG_BUILD) $(IDIR_MIAX) $(PACKAGE_DIR)
|
5
openwrt/package/miax/ipkg/miax.control
Normal file
5
openwrt/package/miax/ipkg/miax.control
Normal file
@ -0,0 +1,5 @@
|
||||
Package: miax
|
||||
Priority: optional
|
||||
Section: net
|
||||
Description: A console iax (asterisk) client
|
||||
Depends: kmod-bluetooth, bluez-libs, libpthread
|
24
openwrt/package/miax/patches/01-cross.patch
Normal file
24
openwrt/package/miax/patches/01-cross.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -ruN miax-1.4-old/Makefile miax-1.4-new/Makefile
|
||||
--- miax-1.4-old/Makefile 2005-04-27 18:56:13.000000000 +0200
|
||||
+++ miax-1.4-new/Makefile 2005-11-30 01:07:21.000000000 +0100
|
||||
@@ -1,4 +1,5 @@
|
||||
-CFLAGS= -Iiax/ -Igsm/inc -DIAXC_IAX2 -DLIBIAX -g -DPOSIXSLEEP -DLINUX -O2
|
||||
+OFLAGS= -02 -g
|
||||
+CFLAGS= -Iiax/ -Igsm/inc $(CPPFLAGS) -DIAXC_IAX2 -DLIBIAX -DPOSIXSLEEP -DLINUX $(OFLAGS)
|
||||
SYSLIBS=-lpthread -lm -lbluetooth
|
||||
|
||||
|
||||
@@ -32,11 +33,10 @@
|
||||
miax.o
|
||||
|
||||
all: $(OBJS)
|
||||
- gcc $(OBJS) $(CFLAGS) $(SYSLIBS) -o miax
|
||||
- cp miax /bin/miax
|
||||
+ $(CC) $(OBJS) $(CFLAGS) $(LDFLAGS) $(SYSLIBS) -o miax
|
||||
|
||||
static: $(OBJS) bluetooth.o
|
||||
- gcc $(OBJS) $(CFLAGS) $(SYSLIBS) -static -o miax
|
||||
+ $(CC) $(OBJS) $(CFLAGS) $(LDFLAGS) $(SYSLIBS) -static -o miax
|
||||
|
||||
clean:
|
||||
rm -f $(OBJS) miax
|
Loading…
Reference in New Issue
Block a user