mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-23 21:37:10 +02:00
[OpenWrt-Devel] update e2fsprogs
Update e2fsprogs to the last upstream version 1.42. blkid works fine without 100_add_missing_libpthread_for_blkid.patch. Signed-off-by: Luka Perkov <openwrt@lukaperkov.net> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30535 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
f1215ac7aa
commit
d4076adb6f
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2006-2010 OpenWrt.org
|
||||
# Copyright (C) 2006-2012 OpenWrt.org
|
||||
# Copyright 2010 Vertical Communications
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -8,9 +8,9 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=e2fsprogs
|
||||
PKG_VERSION:=1.41.12
|
||||
PKG_MD5SUM:=1b24a21fc0c2381ef420961cbfec733f
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=1.42
|
||||
PKG_MD5SUM:=a3c4ffd7352310ab5e9412965d575610
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/e2fsprogs
|
||||
@ -123,12 +123,10 @@ endef
|
||||
TARGET_CFLAGS += $(FPIC)
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--disable-rpath \
|
||||
--enable-elf-shlibs \
|
||||
--enable-dynamic-e2fsck \
|
||||
--disable-tls
|
||||
--disable-tls \
|
||||
--disable-nls \
|
||||
--disable-rpath
|
||||
|
||||
define Build/Prepare
|
||||
$(call Build/Prepare/Default)
|
||||
|
15
package/e2fsprogs/patches/000-uclibc_compile_fix.patch
Normal file
15
package/e2fsprogs/patches/000-uclibc_compile_fix.patch
Normal file
@ -0,0 +1,15 @@
|
||||
Without this patch compiling e2fsprogs 1.42 fails in the case the linux
|
||||
kernel headers provide linux/falloc.h but the libc is not implementing
|
||||
fallocate() as it is still the case with latest versions of uClibc.
|
||||
|
||||
--- a/lib/ext2fs/unix_io.c
|
||||
+++ b/lib/ext2fs/unix_io.c
|
||||
@@ -895,7 +895,7 @@ static errcode_t unix_discard(io_channel
|
||||
goto unimplemented;
|
||||
#endif
|
||||
} else {
|
||||
-#ifdef FALLOC_FL_PUNCH_HOLE
|
||||
+#if defined HAVE_FALLOCATE && defined FALLOC_FL_PUNCH_HOLE
|
||||
/*
|
||||
* If we are not on block device, try to use punch hole
|
||||
* to reclaim free space.
|
22
package/e2fsprogs/patches/100-upstream_fix.patch
Normal file
22
package/e2fsprogs/patches/100-upstream_fix.patch
Normal file
@ -0,0 +1,22 @@
|
||||
--- a/e2fsck/pass1.c
|
||||
+++ b/e2fsck/pass1.c
|
||||
@@ -545,7 +545,7 @@ void e2fsck_pass1(e2fsck_t ctx)
|
||||
int i;
|
||||
__u64 max_sizes;
|
||||
ext2_filsys fs = ctx->fs;
|
||||
- ext2_ino_t ino;
|
||||
+ ext2_ino_t ino = 0;
|
||||
struct ext2_inode *inode;
|
||||
ext2_inode_scan scan;
|
||||
char *block_buf;
|
||||
--- a/e2fsck/pass1b.c
|
||||
+++ b/e2fsck/pass1b.c
|
||||
@@ -267,7 +267,7 @@ struct process_block_struct {
|
||||
static void pass1b(e2fsck_t ctx, char *block_buf)
|
||||
{
|
||||
ext2_filsys fs = ctx->fs;
|
||||
- ext2_ino_t ino;
|
||||
+ ext2_ino_t ino = 0;
|
||||
struct ext2_inode inode;
|
||||
ext2_inode_scan scan;
|
||||
struct process_block_struct pb;
|
@ -1,11 +0,0 @@
|
||||
--- a/lib/blkid/Makefile.in
|
||||
+++ b/lib/blkid/Makefile.in
|
||||
@@ -126,7 +126,7 @@ tst_types: tst_types.o blkid_types.h
|
||||
|
||||
blkid: ../../misc/blkid.o libblkid.a $(DEPLIBUUID)
|
||||
$(E) " LD $@"
|
||||
- $(Q) $(CC) -o blkid ../../misc/blkid.o libblkid.a $(LIBUUID)
|
||||
+ $(Q) $(CC) -lpthread -o blkid ../../misc/blkid.o libblkid.a $(LIBUUID)
|
||||
|
||||
test_probe: test_probe.in Makefile
|
||||
$(E) "Creating test_probe..."
|
Loading…
Reference in New Issue
Block a user