mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-12-03 21:24:06 +02:00
[package] openssl: fix build failure on arm, aes asm version is not shipped anymore (closes: #6778)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19945 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
d7c7e4f683
commit
d96f30084c
@ -82,11 +82,7 @@ else
|
||||
OPENSSL_OPTIONS += no-engines
|
||||
endif
|
||||
|
||||
ifdef CONFIG_arm
|
||||
OPENSSL_MAKEFLAGS := AES_ASM_OBJ="aes-armv4.o aes_cbc.o"
|
||||
else
|
||||
OPENSSL_OPTIONS += no-perlasm
|
||||
endif
|
||||
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR); \
|
||||
|
@ -1,12 +0,0 @@
|
||||
--- a/crypto/aes/Makefile
|
||||
+++ b/crypto/aes/Makefile
|
||||
@@ -47,6 +47,9 @@ lib: $(LIBOBJ)
|
||||
|
||||
$(LIBOBJ): $(LIBSRC)
|
||||
|
||||
+aes-armv4.s: asm/aes-armv4.pl
|
||||
+ $(PERL) $^ > $@
|
||||
+
|
||||
aes-ia64.s: asm/aes-ia64.S
|
||||
$(CC) $(CFLAGS) -E asm/aes-ia64.S > $@
|
||||
|
Loading…
Reference in New Issue
Block a user