mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-24 00:04:38 +02:00
[target/generic]: refresh 2.6.38 patches with -rc2
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25081 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
d544567329
commit
dab65574c2
@ -1,6 +1,6 @@
|
||||
--- a/arch/mips/Kconfig
|
||||
+++ b/arch/mips/Kconfig
|
||||
@@ -904,6 +904,10 @@ config SYNC_R4K
|
||||
@@ -901,6 +901,10 @@ config SYNC_R4K
|
||||
config MIPS_MACHINE
|
||||
def_bool n
|
||||
|
||||
|
@ -8,7 +8,7 @@ Signed-off-by: Florian Fainelli <florian@openwrt.org>
|
||||
--
|
||||
--- a/arch/mips/Kconfig
|
||||
+++ b/arch/mips/Kconfig
|
||||
@@ -889,6 +889,17 @@ config I8259
|
||||
@@ -886,6 +886,17 @@ config I8259
|
||||
config MIPS_BONITO64
|
||||
bool
|
||||
|
||||
|
@ -17,7 +17,7 @@
|
||||
depends on BLOCK
|
||||
--- a/drivers/char/Makefile
|
||||
+++ b/drivers/char/Makefile
|
||||
@@ -82,6 +82,7 @@ obj-$(CONFIG_NWFLASH) += nwflash.o
|
||||
@@ -69,6 +69,7 @@ obj-$(CONFIG_NWFLASH) += nwflash.o
|
||||
obj-$(CONFIG_SCx200_GPIO) += scx200_gpio.o
|
||||
obj-$(CONFIG_PC8736x_GPIO) += pc8736x_gpio.o
|
||||
obj-$(CONFIG_NSC_GPIO) += nsc_gpio.o
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/init/main.c
|
||||
+++ b/init/main.c
|
||||
@@ -890,7 +890,7 @@ static int __init kernel_init(void * unu
|
||||
@@ -899,7 +899,7 @@ static int __init kernel_init(void * unu
|
||||
|
||||
/* Open the /dev/console on the rootfs, this should never fail */
|
||||
if (sys_open((const char __user *) "/dev/console", O_RDWR, 0) < 0)
|
||||
|
@ -829,7 +829,7 @@
|
||||
+be done automatically.
|
||||
--- a/MAINTAINERS
|
||||
+++ b/MAINTAINERS
|
||||
@@ -2851,6 +2851,11 @@ T: git git://git.kernel.org/pub/scm/linu
|
||||
@@ -2855,6 +2855,11 @@ T: git git://git.kernel.org/pub/scm/linu
|
||||
S: Maintained
|
||||
F: drivers/media/video/gspca/
|
||||
|
||||
|
@ -122,7 +122,7 @@
|
||||
void *caller)
|
||||
--- a/include/linux/mm.h
|
||||
+++ b/include/linux/mm.h
|
||||
@@ -854,6 +854,7 @@ extern void show_free_areas(void);
|
||||
@@ -856,6 +856,7 @@ extern void show_free_areas(void);
|
||||
|
||||
int shmem_lock(struct file *file, int lock, struct user_struct *user);
|
||||
struct file *shmem_file_setup(const char *name, loff_t size, unsigned long flags);
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- a/usr/Kconfig
|
||||
+++ b/usr/Kconfig
|
||||
@@ -84,7 +84,7 @@ config RD_XZ
|
||||
config RD_LZO
|
||||
bool "Support initial ramdisks compressed using LZO" if EMBEDDED
|
||||
default !EMBEDDED
|
||||
- depends on BLK_DEV_INITRD
|
||||
+ depends on BLK_DEV_INITRD && HAVE_KERNEL_LZO
|
||||
select DECOMPRESS_LZO
|
||||
help
|
||||
Support loading of a LZO encoded initial ramdisk or cpio buffer
|
@ -1,6 +1,6 @@
|
||||
--- a/init/main.c
|
||||
+++ b/init/main.c
|
||||
@@ -843,10 +843,7 @@ static noinline int init_post(void)
|
||||
@@ -852,10 +852,7 @@ static noinline int init_post(void)
|
||||
printk(KERN_WARNING "Failed to execute %s. Attempting "
|
||||
"defaults...\n", execute_command);
|
||||
}
|
||||
|
Loading…
Reference in New Issue
Block a user