mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-05 04:02:27 +02:00
package/lua: refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20470 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
48531c2e77
commit
ded8981416
File diff suppressed because it is too large
Load Diff
@ -1,8 +1,6 @@
|
||||
Index: lua-5.1.3/src/lua.h
|
||||
===================================================================
|
||||
--- lua-5.1.3.orig/src/lua.h 2008-06-29 11:45:55.000000000 +0200
|
||||
+++ lua-5.1.3/src/lua.h 2008-06-29 11:46:28.000000000 +0200
|
||||
@@ -79,7 +79,7 @@
|
||||
--- a/src/lua.h
|
||||
+++ b/src/lua.h
|
||||
@@ -79,7 +79,7 @@ typedef void * (*lua_Alloc) (void *ud, v
|
||||
* not acceptable for 5.1, maybe 5.2 onwards?
|
||||
* 9: greater than existing (5.1) type values.
|
||||
*/
|
||||
|
@ -1,8 +1,6 @@
|
||||
Index: lua-5.1.4/Makefile
|
||||
===================================================================
|
||||
--- lua-5.1.4.orig/Makefile 2008-08-24 16:46:37.000000000 +0200
|
||||
+++ lua-5.1.4/Makefile 2008-08-24 16:48:42.000000000 +0200
|
||||
@@ -42,8 +42,8 @@
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -42,8 +42,8 @@ PLATS= aix ansi bsd freebsd generic linu
|
||||
|
||||
# What to install.
|
||||
TO_BIN= lua luac
|
||||
@ -13,7 +11,7 @@ Index: lua-5.1.4/Makefile
|
||||
TO_MAN= lua.1 luac.1
|
||||
|
||||
# Lua version and release.
|
||||
@@ -63,6 +63,7 @@
|
||||
@@ -63,6 +63,7 @@ install: dummy
|
||||
cd src && $(INSTALL_EXEC) $(TO_BIN) $(INSTALL_BIN)
|
||||
cd src && $(INSTALL_DATA) $(TO_INC) $(INSTALL_INC)
|
||||
cd src && $(INSTALL_DATA) $(TO_LIB) $(INSTALL_LIB)
|
||||
@ -21,11 +19,9 @@ Index: lua-5.1.4/Makefile
|
||||
cd doc && $(INSTALL_DATA) $(TO_MAN) $(INSTALL_MAN)
|
||||
|
||||
ranlib:
|
||||
Index: lua-5.1.4/src/ldo.h
|
||||
===================================================================
|
||||
--- lua-5.1.4.orig/src/ldo.h 2008-08-24 16:46:37.000000000 +0200
|
||||
+++ lua-5.1.4/src/ldo.h 2008-08-24 16:48:42.000000000 +0200
|
||||
@@ -46,7 +46,7 @@
|
||||
--- a/src/ldo.h
|
||||
+++ b/src/ldo.h
|
||||
@@ -46,7 +46,7 @@ LUAI_FUNC int luaD_pcall (lua_State *L,
|
||||
LUAI_FUNC int luaD_poscall (lua_State *L, StkId firstResult);
|
||||
LUAI_FUNC void luaD_reallocCI (lua_State *L, int newsize);
|
||||
LUAI_FUNC void luaD_reallocstack (lua_State *L, int newsize);
|
||||
@ -34,10 +30,8 @@ Index: lua-5.1.4/src/ldo.h
|
||||
|
||||
LUAI_FUNC void luaD_throw (lua_State *L, int errcode);
|
||||
LUAI_FUNC int luaD_rawrunprotected (lua_State *L, Pfunc f, void *ud);
|
||||
Index: lua-5.1.4/src/lfunc.h
|
||||
===================================================================
|
||||
--- lua-5.1.4.orig/src/lfunc.h 2008-08-24 16:46:37.000000000 +0200
|
||||
+++ lua-5.1.4/src/lfunc.h 2008-08-24 16:48:42.000000000 +0200
|
||||
--- a/src/lfunc.h
|
||||
+++ b/src/lfunc.h
|
||||
@@ -18,7 +18,7 @@
|
||||
cast(int, sizeof(TValue *)*((n)-1)))
|
||||
|
||||
@ -47,10 +41,8 @@ Index: lua-5.1.4/src/lfunc.h
|
||||
LUAI_FUNC Closure *luaF_newCclosure (lua_State *L, int nelems, Table *e);
|
||||
LUAI_FUNC Closure *luaF_newLclosure (lua_State *L, int nelems, Table *e);
|
||||
LUAI_FUNC UpVal *luaF_newupval (lua_State *L);
|
||||
Index: lua-5.1.4/src/lmem.h
|
||||
===================================================================
|
||||
--- lua-5.1.4.orig/src/lmem.h 2008-08-24 16:46:37.000000000 +0200
|
||||
+++ lua-5.1.4/src/lmem.h 2008-08-24 16:48:42.000000000 +0200
|
||||
--- a/src/lmem.h
|
||||
+++ b/src/lmem.h
|
||||
@@ -38,9 +38,9 @@
|
||||
((v)=cast(t *, luaM_reallocv(L, v, oldn, n, sizeof(t))))
|
||||
|
||||
@ -63,10 +55,8 @@ Index: lua-5.1.4/src/lmem.h
|
||||
LUAI_FUNC void *luaM_growaux_ (lua_State *L, void *block, int *size,
|
||||
size_t size_elem, int limit,
|
||||
const char *errormsg);
|
||||
Index: lua-5.1.4/src/lstring.h
|
||||
===================================================================
|
||||
--- lua-5.1.4.orig/src/lstring.h 2008-08-24 16:46:37.000000000 +0200
|
||||
+++ lua-5.1.4/src/lstring.h 2008-08-24 16:48:42.000000000 +0200
|
||||
--- a/src/lstring.h
|
||||
+++ b/src/lstring.h
|
||||
@@ -25,7 +25,7 @@
|
||||
|
||||
LUAI_FUNC void luaS_resize (lua_State *L, int newsize);
|
||||
@ -76,11 +66,9 @@ Index: lua-5.1.4/src/lstring.h
|
||||
|
||||
|
||||
#endif
|
||||
Index: lua-5.1.4/src/lundump.h
|
||||
===================================================================
|
||||
--- lua-5.1.4.orig/src/lundump.h 2008-08-24 16:46:37.000000000 +0200
|
||||
+++ lua-5.1.4/src/lundump.h 2008-08-24 16:48:42.000000000 +0200
|
||||
@@ -17,7 +17,7 @@
|
||||
--- a/src/lundump.h
|
||||
+++ b/src/lundump.h
|
||||
@@ -17,7 +17,7 @@ LUAI_FUNC Proto* luaU_undump (lua_State*
|
||||
LUAI_FUNC void luaU_header (char* h);
|
||||
|
||||
/* dump one chunk; from ldump.c */
|
||||
@ -89,11 +77,9 @@ Index: lua-5.1.4/src/lundump.h
|
||||
|
||||
#ifdef luac_c
|
||||
/* print one chunk; from print.c */
|
||||
Index: lua-5.1.4/src/Makefile
|
||||
===================================================================
|
||||
--- lua-5.1.4.orig/src/Makefile 2008-08-24 16:48:20.000000000 +0200
|
||||
+++ lua-5.1.4/src/Makefile 2008-08-24 16:48:42.000000000 +0200
|
||||
@@ -23,6 +23,7 @@
|
||||
--- a/src/Makefile
|
||||
+++ b/src/Makefile
|
||||
@@ -23,6 +23,7 @@ MYLIBS=
|
||||
PLATS= aix ansi bsd freebsd generic linux macosx mingw posix solaris
|
||||
|
||||
LUA_A= liblua.a
|
||||
@ -101,7 +87,7 @@ Index: lua-5.1.4/src/Makefile
|
||||
CORE_O= lapi.o lcode.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o lmem.o \
|
||||
lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o ltm.o \
|
||||
lundump.o lvm.o lzio.o lnum.o
|
||||
@@ -33,11 +34,12 @@
|
||||
@@ -33,11 +34,12 @@ LUA_T= lua
|
||||
LUA_O= lua.o
|
||||
|
||||
LUAC_T= luac
|
||||
@ -116,7 +102,7 @@ Index: lua-5.1.4/src/Makefile
|
||||
|
||||
default: $(PLAT)
|
||||
|
||||
@@ -47,14 +49,23 @@
|
||||
@@ -47,14 +49,23 @@ o: $(ALL_O)
|
||||
|
||||
a: $(ALL_A)
|
||||
|
||||
@ -143,7 +129,7 @@ Index: lua-5.1.4/src/Makefile
|
||||
$(CC) -o $@ $(MYLDFLAGS) $(LUAC_O) $(LUA_A) $(LIBS)
|
||||
|
||||
clean:
|
||||
@@ -96,7 +107,7 @@
|
||||
@@ -96,7 +107,7 @@ generic:
|
||||
$(MAKE) all MYCFLAGS=
|
||||
|
||||
linux:
|
||||
|
@ -1,8 +1,6 @@
|
||||
Index: lua-5.1.4/src/ldump.c
|
||||
===================================================================
|
||||
--- lua-5.1.4.orig/src/ldump.c 2008-08-24 16:48:20.000000000 +0200
|
||||
+++ lua-5.1.4/src/ldump.c 2008-08-24 16:48:52.000000000 +0200
|
||||
@@ -67,12 +67,12 @@
|
||||
--- a/src/ldump.c
|
||||
+++ b/src/ldump.c
|
||||
@@ -67,12 +67,12 @@ static void DumpString(const TString* s,
|
||||
{
|
||||
if (s==NULL || getstr(s)==NULL)
|
||||
{
|
||||
@ -17,11 +15,9 @@ Index: lua-5.1.4/src/ldump.c
|
||||
DumpVar(size,D);
|
||||
DumpBlock(getstr(s),size,D);
|
||||
}
|
||||
Index: lua-5.1.4/src/lundump.c
|
||||
===================================================================
|
||||
--- lua-5.1.4.orig/src/lundump.c 2008-08-24 16:48:20.000000000 +0200
|
||||
+++ lua-5.1.4/src/lundump.c 2008-08-24 16:48:52.000000000 +0200
|
||||
@@ -25,6 +25,7 @@
|
||||
--- a/src/lundump.c
|
||||
+++ b/src/lundump.c
|
||||
@@ -25,6 +25,7 @@ typedef struct {
|
||||
ZIO* Z;
|
||||
Mbuffer* b;
|
||||
const char* name;
|
||||
@ -29,7 +25,7 @@ Index: lua-5.1.4/src/lundump.c
|
||||
} LoadState;
|
||||
|
||||
#ifdef LUAC_TRUST_BINARIES
|
||||
@@ -40,7 +41,6 @@
|
||||
@@ -40,7 +41,6 @@ static void error(LoadState* S, const ch
|
||||
}
|
||||
#endif
|
||||
|
||||
@ -37,7 +33,7 @@ Index: lua-5.1.4/src/lundump.c
|
||||
#define LoadByte(S) (lu_byte)LoadChar(S)
|
||||
#define LoadVar(S,x) LoadMem(S,&x,1,sizeof(x))
|
||||
#define LoadVector(S,b,n,size) LoadMem(S,b,n,size)
|
||||
@@ -51,6 +51,49 @@
|
||||
@@ -51,6 +51,49 @@ static void LoadBlock(LoadState* S, void
|
||||
IF (r!=0, "unexpected end");
|
||||
}
|
||||
|
||||
@ -87,7 +83,7 @@ Index: lua-5.1.4/src/lundump.c
|
||||
static int LoadChar(LoadState* S)
|
||||
{
|
||||
char x;
|
||||
@@ -82,7 +125,7 @@
|
||||
@@ -82,7 +125,7 @@ static lua_Integer LoadInteger(LoadState
|
||||
|
||||
static TString* LoadString(LoadState* S)
|
||||
{
|
||||
@ -96,7 +92,7 @@ Index: lua-5.1.4/src/lundump.c
|
||||
LoadVar(S,size);
|
||||
if (size==0)
|
||||
return NULL;
|
||||
@@ -196,6 +239,7 @@
|
||||
@@ -196,6 +239,7 @@ static void LoadHeader(LoadState* S)
|
||||
char s[LUAC_HEADERSIZE];
|
||||
luaU_header(h);
|
||||
LoadBlock(S,s,LUAC_HEADERSIZE);
|
||||
@ -104,7 +100,7 @@ Index: lua-5.1.4/src/lundump.c
|
||||
IF (memcmp(h,s,LUAC_HEADERSIZE)!=0, "bad header");
|
||||
}
|
||||
|
||||
@@ -230,7 +274,7 @@
|
||||
@@ -230,7 +274,7 @@ void luaU_header (char* h)
|
||||
*h++=(char)LUAC_FORMAT;
|
||||
*h++=(char)*(char*)&x; /* endianness */
|
||||
*h++=(char)sizeof(int);
|
||||
|
@ -1,6 +1,5 @@
|
||||
diff -ur lua-luci-5.1.3/src/luaconf.h lua-luci-5.1.3-new/src/luaconf.h
|
||||
--- lua-luci-5.1.3/src/luaconf.h 2008-04-14 13:19:54.000000000 +0200
|
||||
+++ lua-luci-5.1.3-new/src/luaconf.h 2008-04-14 13:19:17.000000000 +0200
|
||||
--- a/src/luaconf.h
|
||||
+++ b/src/luaconf.h
|
||||
@@ -38,7 +38,6 @@
|
||||
#if defined(LUA_USE_LINUX)
|
||||
#define LUA_USE_POSIX
|
||||
@ -9,11 +8,9 @@ diff -ur lua-luci-5.1.3/src/luaconf.h lua-luci-5.1.3-new/src/luaconf.h
|
||||
#endif
|
||||
|
||||
#if defined(LUA_USE_MACOSX)
|
||||
Nur in lua-luci-5.1.3-new/src: luaconf.h.orig.
|
||||
diff -ur lua-luci-5.1.3/src/Makefile lua-luci-5.1.3-new/src/Makefile
|
||||
--- lua-luci-5.1.3/src/Makefile 2008-04-14 13:19:57.000000000 +0200
|
||||
+++ lua-luci-5.1.3-new/src/Makefile 2008-04-14 13:19:17.000000000 +0200
|
||||
@@ -17,6 +17,7 @@
|
||||
--- a/src/Makefile
|
||||
+++ b/src/Makefile
|
||||
@@ -17,6 +17,7 @@ LIBS= -lm $(MYLIBS)
|
||||
MYCFLAGS=
|
||||
MYLDFLAGS=
|
||||
MYLIBS=
|
||||
@ -21,7 +18,7 @@ diff -ur lua-luci-5.1.3/src/Makefile lua-luci-5.1.3-new/src/Makefile
|
||||
|
||||
# == END OF USER SETTINGS. NO NEED TO CHANGE ANYTHING BELOW THIS LINE =========
|
||||
|
||||
@@ -86,7 +87,7 @@
|
||||
@@ -86,7 +87,7 @@ echo:
|
||||
@echo "MYLIBS = $(MYLIBS)"
|
||||
|
||||
# convenience targets for popular platforms
|
||||
@ -30,7 +27,7 @@ diff -ur lua-luci-5.1.3/src/Makefile lua-luci-5.1.3-new/src/Makefile
|
||||
none:
|
||||
@echo "Please choose a platform:"
|
||||
@echo " $(PLATS)"
|
||||
@@ -101,16 +102,16 @@
|
||||
@@ -101,16 +102,16 @@ bsd:
|
||||
$(MAKE) all MYCFLAGS="-DLUA_USE_POSIX -DLUA_USE_DLOPEN" MYLIBS="-Wl,-E"
|
||||
|
||||
freebsd:
|
||||
@ -50,4 +47,3 @@ diff -ur lua-luci-5.1.3/src/Makefile lua-luci-5.1.3-new/src/Makefile
|
||||
# use this on Mac OS X 10.3-
|
||||
# $(MAKE) all MYCFLAGS=-DLUA_USE_MACOSX
|
||||
|
||||
Nur in lua-luci-5.1.3-new/src: Makefile.orig.
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- b/src/luaconf.h 2008-05-06 20:10:46.000000000 +0200
|
||||
+++ a/src/luaconf.h 2008-05-06 20:10:27.000000000 +0200
|
||||
--- a/src/luaconf.h
|
||||
+++ b/src/luaconf.h
|
||||
@@ -95,9 +95,9 @@
|
||||
".\\?.dll;" LUA_CDIR"?.dll;" LUA_CDIR"loadall.dll"
|
||||
|
||||
|
@ -1,8 +1,6 @@
|
||||
Index: lua-5.1.4/src/Makefile
|
||||
===================================================================
|
||||
--- lua-5.1.4.orig/src/Makefile 2008-09-25 12:19:44.000000000 +0200
|
||||
+++ lua-5.1.4/src/Makefile 2008-09-25 12:20:03.000000000 +0200
|
||||
@@ -12,7 +12,7 @@
|
||||
--- a/src/Makefile
|
||||
+++ b/src/Makefile
|
||||
@@ -12,7 +12,7 @@ CFLAGS= -O2 -Wall $(MYCFLAGS)
|
||||
AR= ar rcu
|
||||
RANLIB= ranlib
|
||||
RM= rm -f
|
||||
@ -11,7 +9,7 @@ Index: lua-5.1.4/src/Makefile
|
||||
|
||||
MYCFLAGS=
|
||||
MYLDFLAGS=
|
||||
@@ -29,7 +29,7 @@
|
||||
@@ -29,7 +29,7 @@ CORE_O= lapi.o lcode.o ldebug.o ldo.o ld
|
||||
lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o ltm.o \
|
||||
lundump.o lvm.o lzio.o lnum.o
|
||||
LIB_O= lauxlib.o lbaselib.o ldblib.o liolib.o lmathlib.o loslib.o ltablib.o \
|
||||
@ -20,11 +18,9 @@ Index: lua-5.1.4/src/Makefile
|
||||
|
||||
LUA_T= lua
|
||||
LUA_O= lua.o
|
||||
Index: lua-5.1.4/src/linit.c
|
||||
===================================================================
|
||||
--- lua-5.1.4.orig/src/linit.c 2008-09-25 12:19:02.000000000 +0200
|
||||
+++ lua-5.1.4/src/linit.c 2008-09-25 12:19:32.000000000 +0200
|
||||
@@ -23,6 +23,7 @@
|
||||
--- a/src/linit.c
|
||||
+++ b/src/linit.c
|
||||
@@ -23,6 +23,7 @@ static const luaL_Reg lualibs[] = {
|
||||
{LUA_STRLIBNAME, luaopen_string},
|
||||
{LUA_MATHLIBNAME, luaopen_math},
|
||||
{LUA_DBLIBNAME, luaopen_debug},
|
||||
@ -32,10 +28,8 @@ Index: lua-5.1.4/src/linit.c
|
||||
{NULL, NULL}
|
||||
};
|
||||
|
||||
Index: lua-5.1.4/src/lposix.c
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ lua-5.1.4/src/lposix.c 2008-09-25 12:16:29.000000000 +0200
|
||||
--- /dev/null
|
||||
+++ b/src/lposix.c
|
||||
@@ -0,0 +1,1139 @@
|
||||
+/*
|
||||
+* lposix.c
|
||||
@ -1176,11 +1170,9 @@ Index: lua-5.1.4/src/lposix.c
|
||||
+}
|
||||
+
|
||||
+/*EOF*/
|
||||
Index: lua-5.1.4/src/lualib.h
|
||||
===================================================================
|
||||
--- lua-5.1.4.orig/src/lualib.h 2008-09-25 12:18:14.000000000 +0200
|
||||
+++ lua-5.1.4/src/lualib.h 2008-09-25 12:18:53.000000000 +0200
|
||||
@@ -39,6 +39,9 @@
|
||||
--- a/src/lualib.h
|
||||
+++ b/src/lualib.h
|
||||
@@ -39,6 +39,9 @@ LUALIB_API int (luaopen_debug) (lua_Stat
|
||||
#define LUA_LOADLIBNAME "package"
|
||||
LUALIB_API int (luaopen_package) (lua_State *L);
|
||||
|
||||
@ -1190,10 +1182,8 @@ Index: lua-5.1.4/src/lualib.h
|
||||
|
||||
/* open all previous libraries */
|
||||
LUALIB_API void (luaL_openlibs) (lua_State *L);
|
||||
Index: lua-5.1.4/src/modemuncher.c
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ lua-5.1.4/src/modemuncher.c 2008-09-25 12:16:29.000000000 +0200
|
||||
--- /dev/null
|
||||
+++ b/src/modemuncher.c
|
||||
@@ -0,0 +1,261 @@
|
||||
+/*
|
||||
+ Mode Muncher -- modemuncher.c
|
||||
|
@ -205,7 +205,7 @@
|
||||
lua_unlock(L);
|
||||
return res;
|
||||
}
|
||||
@@ -1040,20 +1046,21 @@ LUA_API int lua_next (lua_State *L, int
|
||||
@@ -1040,8 +1046,9 @@ LUA_API int lua_next (lua_State *L, int
|
||||
if (more) {
|
||||
api_incr_top(L);
|
||||
}
|
||||
@ -217,11 +217,7 @@
|
||||
lua_unlock(L);
|
||||
return more;
|
||||
}
|
||||
|
||||
|
||||
LUA_API void lua_concat (lua_State *L, int n) {
|
||||
lua_lock(L);
|
||||
api_checknelems(L, n);
|
||||
@@ -1053,7 +1060,7 @@ LUA_API void lua_concat (lua_State *L, i
|
||||
if (n >= 2) {
|
||||
luaC_checkGC(L);
|
||||
luaV_concat(L, n, cast_int(L->top - L->base) - 1);
|
||||
@ -230,7 +226,7 @@
|
||||
}
|
||||
else if (n == 0) { /* push empty string */
|
||||
setsvalue2s(L, L->top, luaS_newlstr(L, "", 0));
|
||||
@@ -1139,6 +1147,7 @@ LUA_API const char *lua_setupvalue (lua_
|
||||
@@ -1139,6 +1146,7 @@ LUA_API const char *lua_setupvalue (lua_
|
||||
if (name) {
|
||||
L->top--;
|
||||
setobj(L, val, L->top);
|
||||
@ -238,7 +234,7 @@
|
||||
luaC_barrier(L, clvalue(fi), L->top);
|
||||
}
|
||||
lua_unlock(L);
|
||||
@@ -1160,7 +1169,7 @@ LUA_API const char *lua_setupvalue (lua_
|
||||
@@ -1160,7 +1168,7 @@ LUA_API const char *lua_setupvalue (lua_
|
||||
int lua_pushvalue_as_number (lua_State *L, int idx)
|
||||
{
|
||||
const TValue *o = index2adr(L, idx);
|
||||
@ -518,7 +514,7 @@
|
||||
}
|
||||
}
|
||||
return p;
|
||||
@@ -543,7 +551,7 @@ static void atomic (lua_State *L) {
|
||||
@@ -543,7 +546,7 @@ static void atomic (lua_State *L) {
|
||||
udsize = luaC_separateudata(L, 0); /* separate userdata to be finalized */
|
||||
marktmu(g); /* mark `preserved' userdata */
|
||||
udsize += propagateall(g); /* remark, to propagate `preserveness' */
|
||||
@ -527,7 +523,7 @@
|
||||
/* flip current white */
|
||||
g->currentwhite = cast_byte(otherwhite(g));
|
||||
g->sweepstrgc = 0;
|
||||
@@ -685,8 +693,11 @@ void luaC_barrierback (lua_State *L, Tab
|
||||
@@ -685,8 +688,11 @@ void luaC_barrierback (lua_State *L, Tab
|
||||
|
||||
void luaC_link (lua_State *L, GCObject *o, lu_byte tt) {
|
||||
global_State *g = G(L);
|
||||
@ -977,7 +973,7 @@
|
||||
lua_Number d;
|
||||
lua_Integer i;
|
||||
|
||||
@@ -384,6 +386,7 @@ void luaV_concat (lua_State *L, int tota
|
||||
@@ -384,6 +385,7 @@ void luaV_concat (lua_State *L, int tota
|
||||
size_t l = tsvalue(top-i)->len;
|
||||
memcpy(buffer+tl, svalue(top-i), l);
|
||||
tl += l;
|
||||
@ -985,7 +981,7 @@
|
||||
}
|
||||
setsvalue2s(L, top-n, luaS_newlstr(L, buffer, tl));
|
||||
}
|
||||
@@ -420,7 +423,7 @@ void luaV_concat (lua_State *L, int tota
|
||||
@@ -420,7 +422,7 @@ void luaV_concat (lua_State *L, int tota
|
||||
*/
|
||||
static void Arith (lua_State *L, StkId ra, const TValue *rb,
|
||||
const TValue *rc, TMS op) {
|
||||
@ -994,7 +990,7 @@
|
||||
const TValue *b, *c;
|
||||
lua_Number nb,nc;
|
||||
|
||||
@@ -663,7 +666,7 @@ void luaV_execute (lua_State *L, int nex
|
||||
@@ -663,7 +665,7 @@ void luaV_execute (lua_State *L, int nex
|
||||
OPCODE_TARGET(LOADNIL) {
|
||||
TValue *rb = RB(i);
|
||||
do {
|
||||
@ -1003,7 +999,7 @@
|
||||
} while (rb >= ra);
|
||||
continue;
|
||||
}
|
||||
@@ -673,7 +676,7 @@ void luaV_execute (lua_State *L, int nex
|
||||
@@ -673,7 +675,7 @@ void luaV_execute (lua_State *L, int nex
|
||||
continue;
|
||||
}
|
||||
OPCODE_TARGET(GETGLOBAL) {
|
||||
@ -1012,7 +1008,7 @@
|
||||
TValue *rb = KBx(i);
|
||||
sethvalue(L, &g, cl->env);
|
||||
lua_assert(ttisstring(rb));
|
||||
@@ -685,7 +688,7 @@ void luaV_execute (lua_State *L, int nex
|
||||
@@ -685,7 +687,7 @@ void luaV_execute (lua_State *L, int nex
|
||||
continue;
|
||||
}
|
||||
OPCODE_TARGET(SETGLOBAL) {
|
||||
@ -1021,7 +1017,7 @@
|
||||
sethvalue(L, &g, cl->env);
|
||||
lua_assert(ttisstring(KBx(i)));
|
||||
Protect(luaV_settable(L, &g, KBx(i), ra));
|
||||
@@ -895,7 +900,7 @@ void luaV_execute (lua_State *L, int nex
|
||||
@@ -895,7 +897,7 @@ void luaV_execute (lua_State *L, int nex
|
||||
if (--nexeccalls == 0) /* was previous function running `here'? */
|
||||
return; /* no: return */
|
||||
else { /* yes: continue its execution */
|
||||
@ -1030,7 +1026,7 @@
|
||||
lua_assert(isLua(L->ci));
|
||||
lua_assert(GET_OPCODE(*((L->ci)->savedpc - 1)) == OP_CALL);
|
||||
goto reentry;
|
||||
@@ -986,6 +991,7 @@ void luaV_execute (lua_State *L, int nex
|
||||
@@ -986,6 +988,7 @@ void luaV_execute (lua_State *L, int nex
|
||||
for (; n > 0; n--) {
|
||||
TValue *val = ra+n;
|
||||
setobj2t(L, luaH_setint(L, h, last--), val);
|
||||
@ -1038,7 +1034,7 @@
|
||||
luaC_barriert(L, h, val);
|
||||
}
|
||||
continue;
|
||||
@@ -1030,7 +1036,7 @@ void luaV_execute (lua_State *L, int nex
|
||||
@@ -1030,7 +1033,7 @@ void luaV_execute (lua_State *L, int nex
|
||||
setobjs2s(L, ra + j, ci->base - n + j);
|
||||
}
|
||||
else {
|
||||
|
Loading…
Reference in New Issue
Block a user