1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-08-19 16:39:19 +03:00

nuke magicbox-2.6 2.6.21 patches - 2.6.22-rc is stable here

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7848 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nbd 2007-07-02 06:53:30 +00:00
parent e843d1020d
commit df40b4d7da
2 changed files with 0 additions and 118 deletions

View File

@ -1,68 +0,0 @@
diff -urN linux.old/arch/ppc/platforms/4xx/Kconfig linux.dev/arch/ppc/platforms/4xx/Kconfig
--- linux.old/arch/ppc/platforms/4xx/Kconfig 2006-11-29 22:57:37.000000000 +0100
+++ linux.dev/arch/ppc/platforms/4xx/Kconfig 2006-12-14 08:49:18.000000000 +0100
@@ -52,6 +52,12 @@
help
This option enables support for the IBM PPC405GP evaluation board.
+config MAGICBOX
+ bool "MagicBox"
+ select WANT_EARLY_SERIAL
+ help
+ This option enables support for the IBM PPC405EP evaluation board.
+
config XILINX_ML300
bool "Xilinx-ML300"
help
@@ -173,7 +179,7 @@
config IBM_OCP
bool
- depends on ASH || BAMBOO || BUBINGA || CPCI405 || EBONY || EP405 || LUAN || YUCCA || OCOTEA || REDWOOD_5 || REDWOOD_6 || SYCAMORE || TAISHAN || WALNUT
+ depends on ASH || BAMBOO || BUBINGA || CPCI405 || EBONY || EP405 || LUAN || YUCCA || OCOTEA || REDWOOD_5 || REDWOOD_6 || SYCAMORE || TAISHAN || WALNUT || MAGICBOX
default y
config IBM_EMAC4
@@ -183,7 +189,7 @@
config BIOS_FIXUP
bool
- depends on BUBINGA || EP405 || SYCAMORE || WALNUT || CPCI405
+ depends on BUBINGA || EP405 || SYCAMORE || WALNUT || CPCI405 || MAGICBOX
default y
# OAK doesn't exist but wanted to keep this around for any future 403GCX boards
@@ -194,7 +200,7 @@
config 405EP
bool
- depends on BUBINGA
+ depends on BUBINGA || MAGICBOX
default y
config 405GP
diff -urN linux.old/arch/ppc/platforms/4xx/Makefile linux.dev/arch/ppc/platforms/4xx/Makefile
--- linux.old/arch/ppc/platforms/4xx/Makefile 2006-11-29 22:57:37.000000000 +0100
+++ linux.dev/arch/ppc/platforms/4xx/Makefile 2006-12-14 08:48:56.000000000 +0100
@@ -13,6 +13,7 @@
obj-$(CONFIG_REDWOOD_6) += redwood6.o
obj-$(CONFIG_SYCAMORE) += sycamore.o
obj-$(CONFIG_WALNUT) += walnut.o
+obj-$(CONFIG_MAGICBOX) += magicbox.o
obj-$(CONFIG_XILINX_ML300) += xilinx_ml300.o
obj-$(CONFIG_XILINX_ML403) += xilinx_ml403.o
diff -urN linux.old/include/asm-ppc/ibm4xx.h linux.dev/include/asm-ppc/ibm4xx.h
--- linux.old/include/asm-ppc/ibm4xx.h 2006-11-29 22:57:37.000000000 +0100
+++ linux.dev/include/asm-ppc/ibm4xx.h 2006-12-14 08:48:56.000000000 +0100
@@ -18,6 +18,10 @@
#ifdef CONFIG_40x
+#if defined(CONFIG_MAGICBOX)
+#include <platforms/4xx/magicbox.h>
+#endif
+
#if defined(CONFIG_BUBINGA)
#include <platforms/4xx/bubinga.h>
#endif

View File

@ -1,50 +0,0 @@
diff -purN linux.old/drivers/ide/ide.c linux.dev/drivers/ide/ide.c
--- linux.old/drivers/ide/ide.c 2007-01-10 20:10:37.000000000 +0100
+++ linux.dev/drivers/ide/ide.c 2007-04-09 01:25:30.866800288 +0200
@@ -1783,6 +1783,7 @@ done:
extern void __init pnpide_init(void);
extern void __exit pnpide_exit(void);
extern void __init h8300_ide_init(void);
+extern void __init ide_magicbox_init(void);
/*
* probe_for_hwifs() finds/initializes "known" IDE interfaces
@@ -1847,6 +1848,9 @@ static void __init probe_for_hwifs (void
#ifdef CONFIG_H8300
h8300_ide_init();
#endif
+#ifdef CONFIG_BLK_DEV_MAGICBOX_IDE
+ ide_magicbox_init();
+#endif
}
void ide_register_subdriver(ide_drive_t *drive, ide_driver_t *driver)
diff -purN linux.old/drivers/ide/Kconfig linux.dev/drivers/ide/Kconfig
--- linux.old/drivers/ide/Kconfig 2007-01-10 20:10:37.000000000 +0100
+++ linux.dev/drivers/ide/Kconfig 2007-04-09 01:15:27.570515264 +0200
@@ -925,6 +925,14 @@ config BLK_DEV_MPC8xx_IDE
If unsure, say N.
+config BLK_DEV_MAGICBOX_IDE
+ bool "MagicBox 2.0 CF IDE support"
+ depends on 4xx && IDE
+ help
+ This option provides support for IDE on MagicBox 2.0 boards.
+
+ If unsure, say N.
+
choice
prompt "Type of MPC8xx IDE interface"
depends on BLK_DEV_MPC8xx_IDE
diff -purN linux.old/drivers/ide/Makefile linux.dev/drivers/ide/Makefile
--- linux.old/drivers/ide/Makefile 2007-01-10 20:10:37.000000000 +0100
+++ linux.dev/drivers/ide/Makefile 2007-04-09 00:23:29.332559488 +0200
@@ -36,6 +36,7 @@ ide-core-$(CONFIG_BLK_DEV_Q40IDE) += leg
# built-in only drivers from ppc/
ide-core-$(CONFIG_BLK_DEV_MPC8xx_IDE) += ppc/mpc8xx.o
ide-core-$(CONFIG_BLK_DEV_IDE_PMAC) += ppc/pmac.o
+ide-core-$(CONFIG_BLK_DEV_MAGICBOX_IDE) += ppc/magicbox_ide.o
# built-in only drivers from h8300/
ide-core-$(CONFIG_H8300) += h8300/ide-h8300.o